View Issue Details

IDProjectCategoryView StatusLast Update
0001310Ham Radio DeluxeBugpublic2019-02-24 15:12
ReporterSupportAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin XP SP3OSWin XP SP3OS Version
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0001310: Logbook Column Alignment Not Working
DescriptionUnable to change alignment of logbook column data.
Steps To ReproduceOpen logbook.

Right click column heading.

Select "ALIGNMENT"

Chose "Align Left" "Align Center" "Align Right"

Alignment of data does not change.
Additional InformationReported by KH2D
TagsNo tags attached.
ModuleLogbook
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

has duplicate 0002097 closedK7ZCZ 5 - Closed w/o Action Logbook column alignment selection not working 
has duplicate 0002811 closedg3ucq 5 - Closed w/o Action Logbook column allignment does not work 

Activities

WA9PIE

2014-01-30 22:22

administrator   ~0000209

Replicated and Confirmed

WA9PIE

2017-03-05 21:46

administrator   ~0003111

Confirmed in 633

WA9PIE

2017-06-25 22:19

administrator   ~0003320

Confirmed as a remaining problem in 654

K7ZCZ

2017-07-10 19:48

administrator   ~0003612

Super curious problem. The CodeJock library gives us the header control and list view control in the Logbook's view.

It's the header control that offers the menu to change alignment. It has code to react to those menu commands; that code should flick the status bits on the column and force them to draw aligned.

Because our PDBs are broken, I can't debug into the CodeJock code to see if that code is actually working.

However, if I add code that dumps the alignment for columns, it never shows me that an alignment is set. And if I write code that slams the alignment ot an i dentifiable value when the column is created, it also doesn't work.

So, something's up here, but I can't see what it is. I'm suspicious that the CodeJock wrapper for the list view control we're trying to use is doing something we don't expect, but I don't have documentation for the Codejock library.

K7ZCZ

2017-07-10 20:08

administrator   ~0003613

Fiddled with it a little more, and I CAN set the alignment manually in code. So the problem is between the CodeJock header menu items and the CodeJock list view control.

That means I'll have to park this issue until we've got working PDBs across the product. At that point, I can debug the CodeJock code and see what's going on in there.

K7ZCZ

2019-01-20 19:31

administrator   ~0007041

Okay! Finally had a moment to look at this again. Super easy to figure out now that we've got a propery development setup with good PDBs product-wide.

Turns out the alignment code is built into CodeJock. It sets the alignment by getting the parent window of the header control, and double-checking to see if the parent is a kind of CListView or CListCtrl window ... which makes sense, otherwise it can't handle the alignment setting.

The Logbook's database view has a DECLARE_DYNCREATE declaration, but it wasn't wired-up correctly; the base class was set to CView instead of CXTListView. This gave it the wrong type, and wasn't a kind-of CListView. With the RTTI hooked-up correctly, everything seems fine.

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4748



WA9PIE

2019-01-21 02:36

administrator   ~0007052

Wow... cool! This one has been out there for quite some time.

Validated!

Issue History

Date Modified Username Field Change
2013-12-23 21:44 WA9PIE New Issue
2013-12-23 21:44 WA9PIE Assigned To => Support
2013-12-24 09:33 WA9PIE Project 2 - Next Dev List (Holding Area) => @5@
2013-12-24 22:12 WA9PIE Status assigned => new
2014-01-30 22:22 WA9PIE Release => 6.1
2014-01-30 22:22 WA9PIE Module => Logbook
2014-01-30 22:22 WA9PIE Sub-Module => General
2014-01-30 22:22 WA9PIE Report Build => 6.1.4.189
2014-01-30 22:22 WA9PIE Note Added: 0000209
2014-01-30 22:22 WA9PIE Assigned To Support =>
2014-01-30 22:22 WA9PIE Status new => confirmed
2014-02-02 11:43 WA9PIE Summary Logbook Column Alignment Not Working => Bug: Logbook Column Alignment Not Working
2014-02-02 11:43 WA9PIE Description Updated View Revisions
2014-02-02 11:43 WA9PIE Steps to Reproduce Updated View Revisions
2014-02-02 16:40 WA9PIE View Status private => public
2015-09-17 13:17 WA9PIE Category Logbook => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-29 14:10 WA9PIE Fix Build => (select)
2015-09-29 14:10 WA9PIE Summary Bug: Logbook Column Alignment Not Working => Logbook Column Alignment Not Working
2017-03-05 21:46 WA9PIE Note Added: 0003111
2017-06-24 08:25 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2017-06-25 22:19 WA9PIE Note Added: 0003320
2017-06-25 22:20 WA9PIE Assigned To => K7ZCZ
2017-06-25 22:20 WA9PIE Status confirmed => assigned
2017-06-25 22:20 WA9PIE Sub-Module General => Appearance/UI
2017-07-10 19:48 K7ZCZ Note Added: 0003612
2017-07-10 20:08 K7ZCZ Note Added: 0003613
2017-07-10 21:59 K7ZCZ Relationship added has duplicate 0002097
2017-09-18 00:14 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2018-07-18 10:37 K7ZCZ Relationship added has duplicate 0002811
2019-01-20 19:31 K7ZCZ Status assigned => resolved
2019-01-20 19:31 K7ZCZ Resolution open => fixed
2019-01-20 19:31 K7ZCZ Testing => Not Started
2019-01-20 19:31 K7ZCZ Note Added: 0007041
2019-01-21 02:36 WA9PIE Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2019-01-21 02:36 WA9PIE Status resolved => closed
2019-01-21 02:36 WA9PIE Fixed in Version => 6.5.0.187
2019-01-21 02:36 WA9PIE Testing Not Started => Beta Successful
2019-01-21 02:36 WA9PIE Note Added: 0007052
2019-02-24 14:40 WA9PIE Fixed in Version 6.5.0.187 => 6.5.0.196
2019-02-24 15:12 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe