View Issue Details

IDProjectCategoryView StatusLast Update
0001415Ham Radio DeluxeBugpublic2017-06-19 20:37
ReporterSupport 
Assigned ToERIK 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformNoneOSEmptyOS Version
Product Version 
Target VersionFixed in Version6.2.7 
Summary0001415: Header sent to HRDLOG.net
DescriptionSending new QSO to HRDLOG.net please add into the Header - UserAgent the program
version (now you send only "HRD Logbook")
Additional InformationReported by iw1qlh
TagsNo tags attached.
ModuleLogbook
Sub-ModuleHRDLog.net
Testing

Relationships

related to 0001537 closedWA9PIE 4 - Closed w/o Action HRDLog.net - autoupload 

Activities

WA9PIE

2014-01-30 00:02

administrator   ~0000189

User reported:

Version "Public Beta 6.1.0.159", in the header of the HTTP request you send:
POST /NewEntry.aspx HTTP/1.1
Content-Type: application/x-www-form-urlencoded
User-Agent: HRD Logbook
Host: robot.hrdlog.net

my suggestion:
POST /NewEntry.aspx HTTP/1.1
Content-Type: application/x-www-form-urlencoded
User-Agent: HRD Logbook 6
Host: robot.hrdlog.net

WA9PIE

2014-01-30 00:03

administrator   ~0000190

Forum post
===================
I had it all working ok, uploading auto to HRDlognet and a couple of nights ago the DM780 locked, and completely shut it self off. Since that time my updates are not going to HRDlognet... I have gone to the logfile to see what is happening and got this... somehwere in the load of my file and loading Class Clogfileframe, it appears I end up with invalid date time, etc... then HRDLognet does not recognize me... Where do I go from here?

14:14:55 Reload Loaded 402/402 records in 106 milliseconds, 3792.5 records per second

14:14:56 General Loading class CLogfileFrame

Invalid DateTime Web Loaded 14 lines from http://www.sec.noaa.gov/ftpdir/latest/wwv.txt
Invalid DateTime Web WWV data ..: SF:98 A:6 K:1

Invalid DateTime HRD Interface Host name = Ham-shack
Invalid DateTime HRD Interface Host address 1 = 192.168.10.113
Invalid DateTime HRD Interface Connecting to localhost port 7809
Invalid DateTime HRD Interface Ham-shack address 1 = 127.0.0.1
Invalid DateTime HRD Interface Connected
Invalid DateTime HRD Interface Set recv timeout = 30000 milliseconds
Invalid DateTime HRD Interface Get recv timeout = 30000 milliseconds
Invalid DateTime HRD Interface Set send timeout = 30000 milliseconds
Invalid DateTime HRD Interface Get send timeout = 30000 milliseconds
Invalid DateTime HRD Interface Set recv buffer = 32768 Bytes
Invalid DateTime HRD Interface Get recv buffer = 32768 Bytes
Invalid DateTime HRD Interface Set send buffer = 32768 Bytes
Invalid DateTime HRD Interface Get send buffer = 32768 Bytes

Invalid DateTime Network Svr Connection with 127.0.0.1
Invalid DateTime Network Svr Recv timeout: 30000 ms
Invalid DateTime Network Svr Send timeout: 30000 ms
Invalid DateTime Network Svr Recv buffer : 32768 Bytes
Invalid DateTime Network Svr Send buffer : 32768 Bytes

Invalid DateTime Thread Callsign Lookup: Creating thread
Invalid DateTime Thread Callsign Lookup: Created thread, handle = 000007B0, errno = 0

Invalid DateTime Update Updating record 427
Invalid DateTime Update DSN=HRD My Logbook - Access
Invalid DateTime Update Open status 1
Invalid DateTime Update Opening table TABLE_HRD_CONTACTS_V01
Invalid DateTime Update Supplied distance 2374.9kms, heading 61.4°, not recomputed
Invalid DateTime Update OK

Invalid DateTime WebLog Upload Uploading 1 QSOs
Invalid DateTime WebLog Upload Submitted OK
Invalid DateTime WebLog Upload Upload data .: Callsign=TEST&Code=0000000000&ADIFData=<CALL:5>KD8 IE+<BAND:3>40m+<FREQ:8>7.070150+<MODE:5>PSK31+<RST _SENT:3>599+<RST_RCVD:3>599+<STATION_CALLSIGN:6>WD 0AJG+<GRIDSQUARE:6>EN91fl+<DXCC:3>291+<DISTANCE:4> 1475+<QSL_SENT:2>No+<QSL_RCVD:2>No+<QSL_SENT_VIA:6 >Direct+<EOR> -
Invalid DateTime WebLog Upload Reply .......: <?xml version="1.0" ?><HrdLog xmlns="http://xml.hrdlog.com"><NewEntry><error>Missing QSO_Date Time_OnA record should contain at least: Call, QSO_Date, Time_On, Band, Mode</error></NewEntry></HrdLog>
Invalid DateTime WebLog Upload Error .......: Missing QSO_Date Time_OnA record should contain at least: Call, QSO_Date, Time_On, Band, Mode
Invalid DateTime WebLog Upload Status ......:

WA9PIE

2014-01-30 00:04

administrator   ~0000191

Another forum post:
===============
Same error message when trying to upload selected QSO's (175 in total).

Invalid DateTime WebLog Upload Error .......: Missing QSO_Date Time_OnA record should contain at least: Call, QSO_Date, Time_On, Band, Mode

Logbook seems to be connecting to HRDLog.net account OK as it is correctly showing me as on air and frequency readout from radio is correct.

EDIT: Normal single 'add to log and upload to HRDLog.net' seems to be working fine for me.

W4PC

2014-05-10 15:38

updater   ~0000429

added new header

WA9PIE

2014-08-18 15:04

administrator   ~0000511

Cleaning up closed items already marked "Resolved".

Mike, WA9PIE

Issue History

Date Modified Username Field Change
2013-12-23 21:44 WA9PIE New Issue
2013-12-23 21:44 WA9PIE Assigned To => Support
2013-12-24 09:33 WA9PIE Project 2 - Next Dev List (Holding Area) => @5@
2013-12-24 20:26 WA9PIE Release => (select)
2013-12-24 20:26 WA9PIE Module => (select)
2013-12-24 20:26 WA9PIE Sub-Module => (select)
2013-12-24 20:26 WA9PIE Report Build => (select)
2013-12-24 20:26 WA9PIE Assigned To Support =>
2013-12-24 20:26 WA9PIE Resolution @0@ => open
2013-12-24 22:12 WA9PIE Status assigned => new
2014-01-29 00:48 WA9PIE Project @5@ => 3 - Current Dev List
2014-01-30 00:02 WA9PIE Note Added: 0000189
2014-01-30 00:03 WA9PIE Note Added: 0000190
2014-01-30 00:04 WA9PIE Note Added: 0000191
2014-02-02 12:47 WA9PIE Status new => acknowledged
2014-02-02 12:47 WA9PIE Description Updated View Revisions
2014-02-02 15:20 WA9PIE Summary Header sent to HRDLOG.net => Bug: Header sent to HRDLOG.net
2014-02-02 16:39 WA9PIE View Status private => public
2014-02-04 19:40 WA9PIE Relationship added related to 0001537
2014-05-10 09:17 W4PC Assigned To => ERIK
2014-05-10 09:17 W4PC Status acknowledged => assigned
2014-05-10 15:38 W4PC Release (select) => 6.2
2014-05-10 15:38 W4PC Fix Build => 256+
2014-05-10 15:38 W4PC Module (select) => Logbook
2014-05-10 15:38 W4PC Sub-Module (select) => HRDLog.net
2014-05-10 15:38 W4PC Note Added: 0000429
2014-05-10 15:38 W4PC Status assigned => resolved
2014-05-10 15:38 W4PC Resolution open => fixed
2014-05-27 14:39 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-05-27 14:39 WA9PIE Category Logbook => General
2014-08-18 15:04 WA9PIE Note Added: 0000511
2014-08-18 15:04 WA9PIE Status resolved => closed
2015-09-30 12:38 WA9PIE Fix Build 256+ => (select)
2015-09-30 12:38 WA9PIE Proposed Release => TBD
2015-09-30 12:38 WA9PIE Summary Bug: Header sent to HRDLOG.net => Header sent to HRDLOG.net
2015-09-30 13:33 WA9PIE Category General => Bug
2017-06-19 20:37 WA9PIE Fixed in Version => 6.2.7