View Issue Details

IDProjectCategoryView StatusLast Update
0001449Ham Radio DeluxeBugpublic2019-01-16 22:05
ReporterSupportAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformNoneOSwindows 7OS Version
Product Version6.5.0.168 
Target VersionFixed in Version6.5.0.183 
Summary0001449: ALC/POWER/SWR Meters not working on FTDX-3000
DescriptionPlease see summary line
Additional InformationReported by k7khz
TagsFTDX-1200, FTDX-3000, Yaesu
ModuleRig Control
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

related to 0001976 closedK7ZCZ 4 - Closed w/o Action FTDX-3000 ALC/SWR/PWR meters not reading 

Activities

PD9FER

2017-12-16 13:09

viewer   ~0004290

Same for the FTDX-1200
Ticket 225337

PD9FER

2018-05-29 09:44

viewer   ~0005132

And FTDX-300
Ticket #846687

KB3NPH

2018-08-04 01:49

administrator   ~0005916

Ticket 593294 Has inquired about this issue. Any chances of taking a look at this code. It's only been going on 5 years since first reported.

K7ZCZ

2018-12-03 11:22

administrator   ~0006517

There's very little to go on in this issue. "See summary line" is of no help.

From what I'm able to gather from the tickets, customers believe the ALC, Power, and SWR meters should be active on the Rig Control radio view when user is transmitting with the radio. The meters in question are small horizontal bar indicators at the top left of the window; the screenshot shows them circled.

Do I have it right?

ThreeBars.png (18,885 bytes)
ThreeBars.png (18,885 bytes)

PD9FER

2018-12-03 11:26

viewer   ~0006518

Correct Mike...
We need to look into the CAT Reference manual to see if these are available within the CAT protocol

K7ZCZ

2018-12-03 11:27

administrator   ~0006519

Thanks for the confirmation.

K7ZCZ

2018-12-03 14:33

administrator   ~0006521

Values for these meters are queried from the radio when Rig Control knows the radio is in transmit mode. Rig Control occasionally polls the radio to see if it is transmitting; it is more likely to do so when a "TX" button is on the screen. But even when a TX button is configured, the polling might or might not happen, and might not work right.

Looks like the TX state polling for the Icom CI-V protocol implemnetaiton in our code works fine, so I've got to figure out why we're not polling correctly in the Kenwood/New Yaesu protocol implementation. This is certainly not an issue of the radio (or CAT itself) not supporting query access to the desired quantities. The problem is of correctly polling the values in the right context and in a timely manner.

K7ZCZ

2018-12-05 15:40

administrator   ~0006525

I've figured this out. The CRadioOptions class contains lists of commands and responses for the radios. There are different categories of commands -- on/off, choices (one from a list), simple values with ranges, and so on.

For Icom radios, the radio reports its TX status as on or off, simply. That works fine.

Modern Yaesu radios like the FTDX 3000 (and maybe some others) report their TX status as off, driven by a CAT command, or driven by the microphone. "Off" means that the radio isn't transmitting. "driven by CAT" means the radio is transmitting, but is doing so because it was instructed to by a CAT command. If the user clicks the Microphone (or activates VOX) then the radio is transmitting and a different code is returned when the radio is queried compared to when it was programatically set to transmit by CAT.

We want to detect both conditions. The radio might be transmitting because it's being driven by Rig Control via a CAT commmand ... DM780 is transmitting digital data, or the "TX" button in the Rig Control UI has been pressed. We still do want to show the TX meters in this case. The radio returns "TX1" for the CAT transmit mode.

The radio might be transmitting because the user pressed the Microphone button. "TX2" is returned in that case. "TX0" means not transmitting.

The tables in CRadioOptions don't provide for multiple settings, however. Rig Control, thus, doesn't completely understand the meaning of the response it gets.

I've modified the CRadioOptions table so that it can contain possibly contain a list of multiple responses indicating that an on/off setting is "on". With this fix, we're able to accommodate the FTDX 3000 responses correctly. We can apply this generic fix to any other radio that needs it.

K7ZCZ

2018-12-05 18:26

administrator   ~0006529

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4512

WA9PIE

2019-01-09 12:41

administrator   ~0006911

Customer via Facebook agreed to test this. He reports that the meters do not function during TX.

I collected a screenshot (attached) and verified he's got the 6.5.0.168 build running. If we have any additional questions for him, I can collect more information.

3000metersTX.png (35,290 bytes)
3000metersTX.png (35,290 bytes)

K7ZCZ

2019-01-09 14:23

administrator   ~0006922

The TX meter reading code works only when there's a TX button on the radio view. Users can customize the buttons to remove the "TX" button, and the default layout for the FTDX-3000 doesn't have a "TX" button.

The issue is that the code plays games with "simulating" buttons to activate or monitor radio features. I'll cook up some code so that the TX status of the radio is always queried, even if a "TX" button isn't visible in the current customization of the radio view.

K7ZCZ

2019-01-09 15:29

administrator   ~0006937

This fix checks TX status even when a TX button isn't visible on the radio view.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4683

WA9PIE

2019-01-11 12:22

administrator   ~0006964

Validated by customer

Issue History

Date Modified Username Field Change
2013-12-23 21:44 WA9PIE New Issue
2013-12-23 21:44 WA9PIE Status new => assigned
2013-12-23 21:44 WA9PIE Assigned To => Support
2013-12-24 09:30 WA9PIE Project 2 - Next Dev List (Holding Area) => @5@
2014-02-02 13:55 WA9PIE Release => (select)
2014-02-02 13:55 WA9PIE Module => (select)
2014-02-02 13:55 WA9PIE Sub-Module => (select)
2014-02-02 13:55 WA9PIE Report Build => (select)
2014-02-02 13:55 WA9PIE Assigned To Support =>
2014-02-02 13:55 WA9PIE Description Updated View Revisions
2014-02-02 14:42 WA9PIE Status assigned => acknowledged
2014-02-02 14:42 WA9PIE Summary ALC/POWER/SWR Meters not working on FT-3000 => Bug: ALC/POWER/SWR Meters not working on FT-3000
2014-02-02 16:39 WA9PIE View Status private => public
2015-09-17 13:09 WA9PIE Module (select) => Rig Control
2015-09-17 13:15 WA9PIE Category Rig Control => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-25 18:16 WA9PIE Fix Build => (select)
2015-09-25 18:16 WA9PIE Summary Bug: ALC/POWER/SWR Meters not working on FT-3000 => ALC/POWER/SWR Meters not working on FT-3000
2017-12-16 13:09 PD9FER Note Added: 0004290
2018-05-29 09:44 PD9FER Note Added: 0005132
2018-08-04 01:49 KB3NPH Note Added: 0005916
2018-11-27 21:42 WA9PIE Tag Attached: FTDX3000
2018-11-29 00:41 WA9PIE Tag Attached: Yaesu FTDX3000
2018-11-29 00:41 WA9PIE Tag Detached: FTDX3000
2018-11-30 18:27 WA9PIE Tag Attached: Yaesu
2018-11-30 18:27 WA9PIE Tag Attached: FTDX-3000
2018-11-30 18:28 WA9PIE Summary ALC/POWER/SWR Meters not working on FT-3000 => ALC/POWER/SWR Meters not working on FTDX-3000
2018-11-30 18:28 WA9PIE Testing => Not Started
2018-11-30 18:28 WA9PIE Tag Detached: Yaesu FTDX3000
2018-12-02 18:36 K7ZCZ Status acknowledged => assigned
2018-12-02 18:36 K7ZCZ Assigned To => K7ZCZ
2018-12-02 21:30 K7ZCZ Tag Attached: FTDX-1200
2018-12-02 22:50 K7ZCZ Relationship added related to 0001976
2018-12-03 11:22 K7ZCZ File Added: ThreeBars.png
2018-12-03 11:22 K7ZCZ Note Added: 0006517
2018-12-03 11:26 PD9FER Note Added: 0006518
2018-12-03 11:27 K7ZCZ Note Added: 0006519
2018-12-03 14:33 K7ZCZ Note Added: 0006521
2018-12-05 15:40 K7ZCZ Note Added: 0006525
2018-12-05 18:26 K7ZCZ Status assigned => resolved
2018-12-05 18:26 K7ZCZ Resolution open => fixed
2018-12-05 18:26 K7ZCZ Note Added: 0006529
2018-12-06 16:18 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-12-09 15:44 K7ZCZ Fixed in Version => 6.5.0.132
2019-01-09 12:41 WA9PIE File Added: 3000metersTX.png
2019-01-09 12:41 WA9PIE Note Added: 0006911
2019-01-09 12:42 WA9PIE Status resolved => feedback
2019-01-09 12:42 WA9PIE Resolution fixed => reopened
2019-01-09 12:42 WA9PIE Product Version => 6.5.0.168
2019-01-09 12:42 WA9PIE Fixed in Version 6.5.0.132 =>
2019-01-09 12:42 WA9PIE Sub-Module (select) => Appearance/UI
2019-01-09 12:42 WA9PIE Testing Not Started => Beta Failed
2019-01-09 14:23 K7ZCZ Note Added: 0006922
2019-01-09 15:29 K7ZCZ Status feedback => resolved
2019-01-09 15:29 K7ZCZ Resolution reopened => fixed
2019-01-09 15:29 K7ZCZ Note Added: 0006937
2019-01-10 21:53 WA9PIE Fixed in Version => 6.5.0.171
2019-01-11 12:22 WA9PIE Status resolved => closed
2019-01-11 12:22 WA9PIE Testing Beta Failed => Beta Successful
2019-01-11 12:22 WA9PIE Note Added: 0006964
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.171 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe