View Issue Details

IDProjectCategoryView StatusLast Update
0001465Ham Radio DeluxeBugpublic2018-05-13 15:26
ReporterSupport 
Assigned ToK7ZCZ 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformNoneOSEmptyOS Version
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0001465: Manual frequency entry requires period between thousands/hundreds
DescriptionWhen manually entering the frequency in ALE (Add log Entry) or ULE (Update Log
Entry), a period has to be entered between the thousand's and the hundred's
place. See below examples
21.050.760 is entered as 21.050.760
21.050760 is entered at 21.050.000
Seems that since the frequency is supposed to be MHz, then the second separator
is unnecessary. The software seems to be able to read ADIF formats fine which
have the frequency as <MHz><separator><decimal frequency>
Steps To ReproduceOpen up ALE or ULE
Enter a decimal frequency without the separator between the thousand's and the
hundred's place
Click on another field, note that the last three digits are set to zero.
Additional InformationReported by n5rb

Language set to English, location is US
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing Beta Successful

Relationships

Activities

WA9PIE

2014-01-19 21:59

administrator   ~0000115

This is a request to take the manual entry of frequency back to the way it was in 5.0b where one decimal was required and the frequency was entered in MHz.

Requiring users to manually enter 9 or 10 digits, when the least significant ones are normally zero, is a major pain-in-the-ass.

WA9PIE

2014-01-31 08:05

administrator   ~0000235

We do need to fix this. The requirement to enter a frequency in Hz is a pain-in-the-ass. It needs to be MHz.

WA9PIE

2017-07-08 21:52

administrator   ~0003594

Manual frequency entry in the ALE for Logbook (and DM-780) has been messed up since 2012.

This needs to be changed so that frequency entry is in Mhz. Done. Simple.

K7ZCZ

2017-07-11 08:17

manager   ~0003621

I'm sorry, but I'm not able to reproduce errant behaviour in the frequency edit control. I'm typing into the "Freq" control in the ALE after turning off the "Track" checkbox for frequency. I'm not connected to a radio (rig control isn't running)

I type "21050760", press TAB to move to the next control, and the control is left with "21.050.760"
I type "14.313593", press TAB, and and the control is left with "14.313.593".
I type "33222", press TAB, the control has "0.033.222"
I enter "455500000", press TAB, the control has "455.500.000"

What am I missing?

WA9PIE

2018-04-25 23:22

administrator   ~0004889

Users want to enter the frequency in MHz... rather than Hz. Using your examples, it would work like this:

I type "21.05076", press TAB to move to the next control, and the control is left with "21.050.760"
I type "14.313593", press TAB, and and the control is left with "14.313.593".
I type ".033222", press TAB, the control has "0.033.222"
I enter "455.5", press TAB, the control has "455.500.000" (This is actually the crux of the entire request. Folks operating at 1.2GHz don't wan to type 10 digits... when only 4 are necessary.
I enter "1242", press TAB, the control has "1.242.000.000"

This is another one of those things that was correct at one time... but someone changed it. Users complained.

K7ZCZ

2018-04-26 12:31

manager   ~0004901

Last edited: 2018-04-26 12:33

View 2 revisions

I can make it work that way. But what should happen if the user enters something invalid, like "21050760"? If they're entering Megahertz, that means they've tried to enter 21,050,760,000,000, or 21.05 terahertz (LOL).

The code looks like someone made a failed attempt to guess at the user's intention, but that didn't work out too well, so the problem is specifying what should really happen. Whatever we choose, I'm sure some users will complain.

The control that enters a frequency is used in at least 10 places in the suite. For example:

1) Open the Logbook
2) Connect to a DX Cluster
3) Press the "Spot" button
4) Set focus to the "Frequency" field
5) Enter "15". Press TAB to leave the field.

Note that the entry is interpreted as 15 Hz and not 15 MHz

6) Set focus to the frequency field again.
7) Enter "14.02". Pres TAB to leave the field.

Note that this is interpreted as 14.020 MHz.

8) Set focus to the frequency field again
9) Enter "18100000". Press TAB to leave the field.

Note that this is interpreted as 18100000 Hz, not 18100000 MHz.

What should the correct behavior be? Should _all_ uses of the control in the suite exhibit the same behaviour?

K7ZCZ

2018-04-26 19:09

manager   ~0004905

Attached is a doc with some notes about how the frequency control is used, and some recommendations for a fix.

HRD Frequency Control.docx (19,875 bytes)

WA9PIE

2018-04-26 23:15

administrator   ~0004907

Great thoughts in the doc. I’m in favor of the approach.

I wonder... is it possible - if someone enters 14235500000 when they should have entered 14.2355 that a popup could come up saying, “Please enter the frequency in Megahertz”?

People have been asking for this for so long that we don’t hear it much. But it’s a major pain for those who are transcribing paper logs or working without a rig.

K7ZCZ

2018-04-27 10:08

manager   ~0004909

I'm sure it's a pain in the butt, but it's also what the program has trained them to do. When we change that requirement, we have to untrain them -- and that's when they'll (rightly!) complain.

If we're willing to accept that consequence to amke things better in the long-run for some short term trouble, then I can code up what was described in the document.

K7ZCZ

2018-04-30 23:50

manager   ~0004912

Fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4067

Note that this fix applies to all uses of the frequency control in the product; about 12 different locations. Those locations are enumerated in the attached document.

WA9PIE

2018-05-12 00:53

administrator   ~0004995

Awesome. Folks are gonna love this. It was a pain to add the frequency in hertz with extra decimals.

WA9PIE

2018-05-12 01:08

administrator   ~0005009

Closed and waiting on May 2018 release.

Issue History

Date Modified Username Field Change
2013-12-23 21:44 WA9PIE New Issue
2013-12-23 21:44 WA9PIE Assigned To => Support
2013-12-24 09:30 WA9PIE Project 2 - Next Dev List (Holding Area) => @5@
2013-12-24 22:12 WA9PIE Status assigned => new
2014-01-19 21:59 WA9PIE Note Added: 0000115
2014-01-31 08:05 WA9PIE Release => 6.1
2014-01-31 08:05 WA9PIE Module => Logbook
2014-01-31 08:05 WA9PIE Sub-Module => ALE Window
2014-01-31 08:05 WA9PIE Report Build => 6.1.4.189
2014-01-31 08:05 WA9PIE Note Added: 0000235
2014-01-31 08:05 WA9PIE Assigned To Support =>
2014-01-31 08:05 WA9PIE Status new => confirmed
2014-02-02 11:26 WA9PIE Description Updated View Revisions
2014-02-02 11:26 WA9PIE Steps to Reproduce Updated View Revisions
2014-02-02 11:26 WA9PIE Additional Information Updated View Revisions
2014-02-02 16:40 WA9PIE View Status private => public
2014-03-26 12:45 WA9PIE Summary Manual frequency entry requires period between thousands/hundreds => Bug: Manual frequency entry requires period between thousands/hundreds
2015-09-17 13:17 WA9PIE Category Logbook => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-25 18:14 WA9PIE Fix Build => (select)
2015-09-25 18:14 WA9PIE Summary Bug: Manual frequency entry requires period between thousands/hundreds => Manual frequency entry requires period between thousands/hundreds
2017-07-08 21:52 WA9PIE Note Added: 0003594
2017-07-08 21:52 WA9PIE Project 1 - Backlog => Ham Radio Deluxe
2017-07-08 21:52 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2017-07-08 21:52 WA9PIE Assigned To => K7ZCZ
2017-07-08 21:52 WA9PIE Status confirmed => assigned
2017-07-11 08:17 K7ZCZ Note Added: 0003621
2017-07-11 08:18 K7ZCZ Assigned To K7ZCZ => WA9PIE
2017-09-18 00:14 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2018-04-25 23:22 WA9PIE Note Added: 0004889
2018-04-26 00:15 WA9PIE Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2018-04-26 00:15 WA9PIE Assigned To WA9PIE => K7ZCZ
2018-04-26 12:31 K7ZCZ Note Added: 0004901
2018-04-26 12:31 K7ZCZ Assigned To K7ZCZ => WA9PIE
2018-04-26 12:31 K7ZCZ Status assigned => feedback
2018-04-26 12:33 K7ZCZ Note Edited: 0004901 View Revisions
2018-04-26 19:09 K7ZCZ File Added: HRD Frequency Control.docx
2018-04-26 19:09 K7ZCZ Note Added: 0004905
2018-04-26 23:15 WA9PIE Note Added: 0004907
2018-04-26 23:15 WA9PIE Assigned To WA9PIE => K7ZCZ
2018-04-27 10:08 K7ZCZ Note Added: 0004909
2018-04-30 23:50 K7ZCZ Status feedback => resolved
2018-04-30 23:50 K7ZCZ Resolution open => fixed
2018-04-30 23:50 K7ZCZ Testing => Not Started
2018-04-30 23:50 K7ZCZ Note Added: 0004912
2018-05-03 20:10 K7ZCZ Fixed in Version => 6.4.0.837
2018-05-12 00:53 WA9PIE Testing Not Started => Beta Successful
2018-05-12 00:53 WA9PIE Note Added: 0004995
2018-05-12 01:08 WA9PIE Note Added: 0005009
2018-05-12 01:08 WA9PIE Status resolved => closed
2018-05-13 15:25 WA9PIE Fixed in Version 6.4.0.837 => 6.4.0.840
2018-05-13 15:26 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe