View Issue Details

IDProjectCategoryView StatusLast Update
0001500Ham Radio DeluxeBugpublic2018-04-09 14:37
ReporterSupport 
Assigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformHRD 6.0.133OSWindows 8OS Version
Product Version 
Target VersionFixed in Version6.4.0.806 
Summary0001500: ICOM 7600 - CI-V commands issue for ANT and AGC switching
DescriptionSome CI-V commands have to change to following commands

| Dropdown: AGC | Fast| Set = 16-12-01, Get = 16-12, On = 01
| Dropdown: AGC | Mid | Set = 16-12-02, Get = 16-12, On = 02
| Dropdown: AGC | Slow| Set = 16-12-03, Get = 16-12, On = 03

| Buttons: On/Off | Ant 1| Cmd = 12-FF, On = 00, Off = 00, Readable = Yes,
Tooltip = Select antenna 1 |
| Buttons: On/Off | Ant 2| Cmd = 12-FF, On = 01, Off = 00, Readable = Yes,
Tooltip = Select antenna 2
Steps To ReproduceHEX-Code for CI-V commands must change to commands as reported in my desciption.

There is no way to change it by myself.
Additional InformationReported by DM2RM

PLEASE, change the CI-V commands it is just 1 number what has to change in a
command line.

Many thanks!!!!!!!!!!
TagsIC7600, ICOM
ModuleRig Control
Sub-ModuleRadio Support
Testing Not Tested

Relationships

has duplicate 0001349 closedK7ZCZ Ham Radio Deluxe ICOM IC-7600 CI-V commands for ANT and AGC switching 
has duplicate 0001451 closedK7ZCZ Ham Radio Deluxe IC-7600 - Button 'Ant 2' wrong CAT-command 
has duplicate 0001360 closedK7ZCZ Ham Radio Deluxe Antenna switching problem with Icom 7600 
child of 0001568 acknowledged 1 - Backlog Icom 7600 (Parent) 

Activities

K7ZCZ

2018-03-09 15:40

manager   ~0004459

This shelf set is out for review. https://hrdsoftware.visualstudio.com/HRD/_versionControl/shelveset?ss=Fix%207600%20ATT%2C%20ANT%20%28Mantis%201500%29%3Bmikeblas%40msn.com

K7ZCZ

2018-03-22 11:06

manager   ~0004523

This was out for review and never checked in. It should not have been resolved; since it was marked "resolved", I almost deleted the shelf set without actually checking in the code.

K7ZCZ

2018-03-22 12:42

manager   ~0004524

this is now fixed, with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3985

K7ZCZ

2018-03-27 19:17

manager   ~0004584

setting "Fixed In Version" for changelist visibility

Issue History

Date Modified Username Field Change
2013-12-23 21:44 WA9PIE New Issue
2013-12-23 21:44 WA9PIE Assigned To => Support
2013-12-24 09:30 WA9PIE Project 2 - Next Dev List (Holding Area) => @5@
2014-02-02 14:00 WA9PIE Release => (select)
2014-02-02 14:00 WA9PIE Module => (select)
2014-02-02 14:00 WA9PIE Sub-Module => (select)
2014-02-02 14:00 WA9PIE Report Build => (select)
2014-02-02 14:00 WA9PIE Assigned To Support =>
2014-02-02 14:00 WA9PIE Status assigned => acknowledged
2014-02-02 14:00 WA9PIE Summary ICOM 7600 - CI-V commands issue for ANT and AGC switching => Bug: ICOM 7600 - CI-V commands issue for ANT and AGC switching
2014-02-02 14:00 WA9PIE Description Updated View Revisions
2014-02-02 14:00 WA9PIE Steps to Reproduce Updated View Revisions
2014-02-02 14:00 WA9PIE Additional Information Updated View Revisions
2014-02-02 16:25 WA9PIE Relationship added child of 0001568
2014-02-02 16:39 WA9PIE View Status private => public
2015-09-17 13:09 WA9PIE Module (select) => Rig Control
2015-09-17 13:15 WA9PIE Category Rig Control => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-23 00:07 WA9PIE Fix Build => (select)
2015-09-23 00:07 WA9PIE Summary Bug: ICOM 7600 - CI-V commands issue for ANT and AGC switching => ICOM 7600 - CI-V commands issue for ANT and AGC switching
2017-07-15 17:03 K7ZCZ Tag Attached: ICOM
2017-07-15 17:03 K7ZCZ Tag Attached: IC7600
2017-07-15 17:05 K7ZCZ Relationship added has duplicate 0001349
2018-03-09 14:47 K7ZCZ Relationship added has duplicate 0001451
2018-03-09 15:14 K7ZCZ Relationship added has duplicate 0001360
2018-03-09 15:40 K7ZCZ Note Added: 0004459
2018-03-09 16:14 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-03-09 16:15 WA9PIE Status acknowledged => resolved
2018-03-09 16:15 WA9PIE Testing => Not Started
2018-03-09 16:20 WA9PIE Assigned To => K7ZCZ
2018-03-09 16:20 WA9PIE Status resolved => assigned
2018-03-09 16:20 WA9PIE Status assigned => resolved
2018-03-13 14:22 WA9PIE Resolution open => @21@
2018-03-13 14:26 WA9PIE Resolution @21@ => @22@
2018-03-13 18:52 WA9PIE Resolution @22@ => fixed
2018-03-22 07:05 WA9PIE Target Version => 6.4.0.797
2018-03-22 07:06 WA9PIE Fixed in Version => 6.4.0.797
2018-03-22 11:06 K7ZCZ Status resolved => feedback
2018-03-22 11:06 K7ZCZ Resolution fixed => reopened
2018-03-22 11:06 K7ZCZ Note Added: 0004523
2018-03-22 11:16 K7ZCZ Fixed in Version 6.4.0.797 =>
2018-03-22 12:42 K7ZCZ Status feedback => resolved
2018-03-22 12:42 K7ZCZ Resolution reopened => fixed
2018-03-22 12:42 K7ZCZ Sub-Module (select) => Radio Support
2018-03-22 12:42 K7ZCZ Note Added: 0004524
2018-03-27 19:17 K7ZCZ Fixed in Version => 6.4.0.797
2018-03-27 19:17 K7ZCZ Note Added: 0004584
2018-04-04 15:27 WA9PIE Target Version 6.4.0.797 =>
2018-04-07 19:19 WA9PIE Status resolved => closed
2018-04-07 19:19 WA9PIE Testing Not Started => Not Tested
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:25 WA9PIE Fixed in Version 6.4.0.797 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806