View Issue Details

IDProjectCategoryView StatusLast Update
0001515Ham Radio DeluxeBugpublic2019-01-16 22:05
ReporterSupport 
Assigned ToK7ZCZ 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows8OS Version
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0001515: FTDX-3000 Buttons Inoperative
DescriptionThe buttons associated CAT Commands re: meter mode selection, i.e. M S P1 0:COMP
1:ALC 3:SWR 4:ID 5:VDD are not functional.
The pull down selection for CW PITCH results in erroneous pitch settings, i.e.
700 results in 386???.
Power Button CAT Command P S P1 0:POWER"OFF" causes HRD to crash(naturally!!).
NB1 and NB2 should be labeled "NB" and "NBW".
ANT1 ANT2 ANT3 should be a pull down selector, as individually they take up a
lot of real-estate and will seldom be needed as these ant input/outputs are Band
Switched.
Steps To ReproduceJust running HRD 6.0 with a FTDX-3000 is all that's needed to reproduce these
issues.
Additional InformationReported by VE3HMS

Note: There's a lot more checking to be done but I'm running out of time on my
Trial, hense someone else will have to do it
TagsFTDX-3000, Yaesu
ModuleRig Control
Sub-Module(select)
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-12-05 18:20

manager   ~0006527

Let's try to address these one-by-one:

<q>The buttons associated CAT Commands re: meter mode selection, i.e. M S P1 0:COMP 1:ALC 3:SWR 4:ID 5:VDD are not functional.</q>

There are no buttons for the meter selction. There is a slider, and that seems to be working fine. If you have specific repro steps that result in undesireable functionality, please share them.

<q>The pull down selection for CW PITCH results in erroneous pitch settings, i.e. 700 results in 386???.</q>

I've fixed this.

<q>Power Button CAT Command P S P1 0:POWER"OFF" causes HRD to crash(naturally!!).</q>

I am not able to reproduce a crash after pressing "power". If you are, please provide a minidump.

<q>NB1 and NB2 should be labeled "NB" and "NBW". </q>

I've renamed the "NB 1" and "NB 2" buttons to "NB" and "NBW", respectively.

<q>ANT1 ANT2 ANT3 should be a pull down selector, as individually they take up a lot of real-estate and will seldom be needed as these ant input/outputs are Band Switched.</q>

I think this is a matter of opinion. There are only a few spots for drop-down buttons, so there's also limited space there. I've added a drop-down button to select the antenna input and left the singular buttons. This allows the user a choice based on their own preference.

K7ZCZ

2018-12-05 18:25

manager   ~0006528

fixed as noted with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4513

WA9PIE

2019-01-11 13:18

administrator   ~0006965

Validated by customer

Issue History

Date Modified Username Field Change
2013-12-23 21:44 WA9PIE New Issue
2013-12-23 21:44 WA9PIE Status new => assigned
2013-12-23 21:44 WA9PIE Assigned To => Support
2013-12-24 09:29 WA9PIE Project 2 - Next Dev List (Holding Area) => @6@
2013-12-24 21:44 WA9PIE Project @6@ => @5@
2014-02-02 13:04 WA9PIE Release => (select)
2014-02-02 13:04 WA9PIE Module => (select)
2014-02-02 13:04 WA9PIE Sub-Module => (select)
2014-02-02 13:04 WA9PIE Report Build => (select)
2014-02-02 13:04 WA9PIE Assigned To Support =>
2014-02-02 13:04 WA9PIE Status assigned => acknowledged
2014-02-02 13:04 WA9PIE Summary FTDX-3000 Buttons Inoperative => Bug: FTDX-3000 Buttons Inoperative
2014-02-02 13:04 WA9PIE Description Updated View Revisions
2014-02-02 13:04 WA9PIE Steps to Reproduce Updated View Revisions
2014-02-02 13:04 WA9PIE Additional Information Updated View Revisions
2014-02-02 16:40 WA9PIE View Status private => public
2015-09-17 13:08 WA9PIE Module (select) => Rig Control
2015-09-17 13:17 WA9PIE Category Rig Control => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-23 00:06 WA9PIE Fix Build => (select)
2015-09-23 00:06 WA9PIE Summary Bug: FTDX-3000 Buttons Inoperative => FTDX-3000 Buttons Inoperative
2017-03-10 13:48 WA9PIE Severity feature => crash
2017-03-10 13:48 WA9PIE Reported in Release (select) => 6.0
2017-03-10 13:48 WA9PIE Reported in Build (ie. 377) (select) => 000
2017-03-10 13:48 WA9PIE Fixed in Build (ie. 377) (select) => tbd
2018-04-13 10:23 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-11-27 21:56 WA9PIE Tag Attached: FTDX3000
2018-11-29 00:41 WA9PIE Tag Attached: Yaesu FTDX3000
2018-11-29 00:41 WA9PIE Tag Detached: FTDX3000
2018-11-30 18:27 WA9PIE Tag Attached: Yaesu
2018-11-30 18:27 WA9PIE Tag Attached: FTDX-3000
2018-11-30 18:28 WA9PIE Tag Detached: Yaesu FTDX3000
2018-12-02 18:36 K7ZCZ Status acknowledged => assigned
2018-12-02 18:36 K7ZCZ Assigned To => K7ZCZ
2018-12-05 18:20 K7ZCZ Note Added: 0006527
2018-12-05 18:25 K7ZCZ Status assigned => resolved
2018-12-05 18:25 K7ZCZ Resolution open => fixed
2018-12-05 18:25 K7ZCZ Testing => Not Started
2018-12-05 18:25 K7ZCZ Note Added: 0006528
2018-12-09 15:49 K7ZCZ Fixed in Version => 6.5.0.132
2019-01-11 13:18 WA9PIE Status resolved => closed
2019-01-11 13:18 WA9PIE Testing Not Started => Beta Successful
2019-01-11 13:18 WA9PIE Note Added: 0006965
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe