View Issue Details

IDProjectCategoryView StatusLast Update
0001518Ham Radio DeluxeBugpublic2019-01-16 22:05
ReporterSupport 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows8OS Version
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0001518: FTDX-3000 CAT Commands - Buttons
DescriptionButton M>V should be labeled M>A for consistency with Transceiver Button
Att 06dB, Att 12dB, and Att 18dB should be a pull down selector, as individually
they take up a lot of real-estate.
Lock Button only locks both VFO's. By using a pull down selector for Lock would
allow complete flexibility for Lock functions.
VFO A and VFO B Buttons can be eliminated and RX A and RX B could toggle the
standby(mute) function.
Steps To ReproduceFTDX-3000 connection.
Additional InformationReported by VE3HMS

Previous report for V 6.0 apply to V 6.1
TagsFTDX-3000, Yaesu
ModuleRig Control
Sub-Module(select)
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-12-06 13:18

manager   ~0006533

It's almost always best to open individual issues instead of opening a single "fragmentation issue". Let's try to pick this one apart:


  1. Button M>V should be labeled M>A for consistency with Transceiver Button

  2. Att 06dB, Att 12dB, and Att 18dB should be a pull down selector, as individually they take up a lot of real-estate.

  3. Lock Button only locks both VFO's. By using a pull down selector for Lock would allow complete flexibility for Lock functions.

  4. VFO A and VFO B Buttons can be eliminated and RX A and RX B could toggle the standby(mute) function.



Here's what I've done:

  1. I've fixed the cosmetic issue. Thing is, there's also a V/M button. Turns out the M>V button was sending the V/M command. M>V should copy the memory to the VFO; V/M should switch from memory mode to VFO mode. This is fixed, too.

  2. I've added an attenuator drop-down. The individual buttons are not removed, and the user can choose which they prefer.

  3. To me, the Lock button for both VFOs seems quite adequate. The product only supports six drop-downs, and we've used them all for this radio. Until we enhance the UI so that more drop-down buttons can be used, we can't add more.

  4. I've left the buttons as is so as not to be inconsistent with the tranceiver's buttons. The RX A buttons has a slightly different function than the CAT commands sent by the VFO A button.

K7ZCZ

2018-12-06 13:22

manager   ~0006534

fixed (mostly) as above with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4515

WA9PIE

2019-01-11 13:25

administrator   ~0006966

Validated by customer

Issue History

Date Modified Username Field Change
2013-12-23 21:44 WA9PIE New Issue
2013-12-23 21:44 WA9PIE Status new => assigned
2013-12-23 21:44 WA9PIE Assigned To => Support
2013-12-24 09:30 WA9PIE Project 2 - Next Dev List (Holding Area) => @5@
2014-02-02 13:58 WA9PIE Release => (select)
2014-02-02 13:58 WA9PIE Module => (select)
2014-02-02 13:58 WA9PIE Sub-Module => (select)
2014-02-02 13:58 WA9PIE Report Build => (select)
2014-02-02 13:58 WA9PIE Assigned To Support =>
2014-02-02 13:58 WA9PIE Status assigned => acknowledged
2014-02-02 13:58 WA9PIE Summary 0000566: FTDX-3000 CAT Commands - Buttons => Bug: 0000566: FTDX-3000 CAT Commands - Buttons
2014-02-02 13:58 WA9PIE Description Updated View Revisions
2014-02-02 13:58 WA9PIE Steps to Reproduce Updated View Revisions
2014-02-02 13:58 WA9PIE Additional Information Updated View Revisions
2014-02-02 16:39 WA9PIE View Status private => public
2015-09-17 13:09 WA9PIE Module (select) => Rig Control
2015-09-17 13:15 WA9PIE Category Rig Control => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-23 00:06 WA9PIE Fix Build => (select)
2015-09-23 00:06 WA9PIE Summary Bug: 0000566: FTDX-3000 CAT Commands - Buttons => FTDX-3000 CAT Commands - Buttons
2018-11-27 21:59 WA9PIE Tag Attached: FTDX3000
2018-11-29 00:41 WA9PIE Tag Attached: Yaesu FTDX3000
2018-11-29 00:41 WA9PIE Tag Detached: FTDX3000
2018-11-30 18:27 WA9PIE Tag Attached: Yaesu
2018-11-30 18:27 WA9PIE Tag Attached: FTDX-3000
2018-11-30 18:28 WA9PIE Tag Detached: Yaesu FTDX3000
2018-12-02 18:36 K7ZCZ Status acknowledged => assigned
2018-12-02 18:36 K7ZCZ Assigned To => K7ZCZ
2018-12-06 13:18 K7ZCZ Note Added: 0006533
2018-12-06 13:22 K7ZCZ Status assigned => resolved
2018-12-06 13:22 K7ZCZ Resolution open => fixed
2018-12-06 13:22 K7ZCZ Testing => Not Started
2018-12-06 13:22 K7ZCZ Note Added: 0006534
2018-12-06 16:18 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-12-09 15:49 K7ZCZ Fixed in Version => 6.5.0.132
2019-01-11 13:25 WA9PIE Status resolved => closed
2019-01-11 13:25 WA9PIE Testing Not Started => Beta Successful
2019-01-11 13:25 WA9PIE Note Added: 0006966
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe