View Issue Details

IDProjectCategoryView StatusLast Update
0001546Ham Radio DeluxeBugpublic2017-06-19 20:47
ReporterWA9PIE 
Assigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.2.4 
Summary0001546: The Country field is not cleared after Save or Reset in ALE
DescriptionOnce a QSO is save in the ALE, or if the ALE is cleared (F4), the field does not get cleared. Not only is this confusing and looks bad, but it also increases the risk that bad data will get added to QSO records.

Because the country field is not cleared, numerous other fields in other tabs are not cleared. Clearing the country tab will resolve this.
Steps To Reproduce- Enter a call in the ALE
- Allow Logbook to do a lookup by tabbing out of the Callsign field
- Save or Reset the ALE
- Observe the status the "Country" field in the main section of the ALE; it is not cleared. As a result, all the fields in various tabs that key off this field are not cleared.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing

Relationships

Activities

WA9PIE

2014-01-20 09:40

administrator   ~0000134

Steps to replicate are documented.

WA9PIE

2014-01-28 20:03

administrator   ~0000165

Not fixed.

user10

2014-01-29 08:27

  ~0000172

Seems to be working with 212. Clears after add or reset

WA9PIE

2014-01-29 12:20

administrator   ~0000175

Tested good (this build isn't available yet; I tested from alpha code and assume that next build will be 213).

WA9PIE

2014-01-29 23:31

administrator   ~0000188

I confirmed the fix.

Issue History

Date Modified Username Field Change
2014-01-20 09:39 WA9PIE New Issue
2014-01-20 09:40 WA9PIE Note Added: 0000134
2014-01-20 09:40 WA9PIE Assigned To => WA9PIE
2014-01-20 09:40 WA9PIE Status new => confirmed
2014-01-20 09:42 WA9PIE Summary ALE does not reset the Country field after Save or Reset => The Country field is not cleared after Save or Reset in ALE
2014-01-28 00:20 W4PC Fix Build 6.2 => 6.2.211
2014-01-28 00:20 W4PC Status confirmed => resolved
2014-01-28 00:20 W4PC Resolution open => fixed
2014-01-28 20:03 WA9PIE Note Added: 0000165
2014-01-28 20:03 WA9PIE Status resolved => confirmed
2014-01-29 08:27 user10 Note Added: 0000172
2014-01-29 12:20 WA9PIE Fix Build 6.2.211 => 6.2.213
2014-01-29 12:20 WA9PIE Note Added: 0000175
2014-01-29 12:20 WA9PIE Status confirmed => resolved
2014-01-29 23:31 WA9PIE Note Added: 0000188
2014-01-29 23:31 WA9PIE Status resolved => closed
2014-03-26 19:39 WA9PIE Summary The Country field is not cleared after Save or Reset in ALE => Bug: The Country field is not cleared after Save or Reset in ALE
2014-10-08 22:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-10-08 22:13 WA9PIE Category Logbook => General
2015-09-30 12:08 WA9PIE Fix Build 6.2.213 => (select)
2015-09-30 12:08 WA9PIE Proposed Release => TBD
2015-09-30 12:08 WA9PIE Summary Bug: The Country field is not cleared after Save or Reset in ALE => The Country field is not cleared after Save or Reset in ALE
2015-09-30 13:35 WA9PIE Category General => Bug
2017-06-19 20:47 WA9PIE Fixed in Version => 6.2.4