View Issue Details

IDProjectCategoryView StatusLast Update
0001567Ham Radio DeluxeBugpublic2017-06-19 20:51
ReporterWA9PIE 
Assigned ToERIK 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.2.4 
Summary0001567: Filter unneeded spots from the DX Cluster
DescriptionPretty simple. Users are requesting that we provide an additional filter to the DX Cluster that would HIDE spots if they are not needed for DXCC. This is a common request and many of our competitors have this functionality.

More information in "Additional Information"
Additional InformationThe WSI for Band and Mode for DX Spots have three conditions:

- Green (Worked and Confirmed)
- Yellow (Worked and Not Confirmed)
- Red (Not Worked)

With this change GREEN spots would be filtered out of view when the user selects one of three new filters that would be applied to the existing band filter:

- Band (any spots where “Band” is green are “hidden”)
- Mode (any spots where “Mode” is green are “hidden”)
- Band OR Mode (any spots where “Band” OR “Mode” is green are “hidden”)

There would also be the following:

- All (no filter applied; default state)

==================

Note: Since the following condition is not possible:

Country = Red AND Band != Red

Then there is no need to create a "Country" filter. Those who need think they need such a thing should:

- Use the "Band" filter... AND
- Add Country (C) to their Cluster layout
TagsNo tags attached.
ModuleLogbook
Sub-ModuleDX Cluster
Testing

Relationships

Activities

WA9PIE

2014-02-02 09:50

administrator  

Filter Unneeded Spots.pdf (507,212 bytes)

WA9PIE

2014-05-01 22:23

administrator   ~0000414

tested and confirmed

Issue History

Date Modified Username Field Change
2014-02-02 09:50 WA9PIE New Issue
2014-02-02 09:50 WA9PIE File Added: Filter Unneeded Spots.pdf
2014-02-02 09:51 WA9PIE Assigned To => W4PC
2014-02-02 09:51 WA9PIE Status new => assigned
2014-02-02 09:51 WA9PIE Summary Filter unneeded spots from the DX Cluster => Enhancement: Filter unneeded spots from the DX Cluster
2014-02-02 23:21 WA9PIE Project @6@ => 2 - Next Dev List (Holding Area)
2014-03-26 20:02 WA9PIE Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2014-03-26 20:02 WA9PIE Assigned To W4PC => ERIK
2014-05-01 22:23 WA9PIE Fix Build TBD => 6.2 RC2
2014-05-01 22:23 WA9PIE Report Build 6.1.4.189 => 6.2
2014-05-01 22:23 WA9PIE Note Added: 0000414
2014-05-01 22:23 WA9PIE Status assigned => closed
2014-05-01 22:23 WA9PIE Resolution open => fixed
2014-10-08 22:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-10-08 22:13 WA9PIE Category Logbook => General
2015-09-30 12:07 WA9PIE Fix Build 6.2 RC2 => (select)
2015-09-30 12:07 WA9PIE Proposed Release => TBD
2015-09-30 12:07 WA9PIE Summary Enhancement: Filter unneeded spots from the DX Cluster => Filter unneeded spots from the DX Cluster
2015-09-30 13:35 WA9PIE Category General => Bug
2017-06-19 20:51 WA9PIE Fixed in Version => 6.2.4