View Issue Details

IDProjectCategoryView StatusLast Update
0001654Ham Radio DeluxeBugpublic2019-03-01 19:27
Reporteruser36Assigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0001654: Rotator - M2 AZ/EL setup incorrect
DescriptionWhen M2 Az/El is selected, the Az/El protocol options are set to either Hy-gain or Yaesu GS-232. M2 does not use those options.

*** M2 uses its own protocol. ***

Ref: Ticket 479391
Additional Information10:32:02 Connect Rotator ......: M2 Az/El
10:32:02 Connect Protocol .....: Hy-Gain
10:32:02 Connect Step size ....: Auto
10:32:02 Connect Min azimuth ..: 0
10:32:02 Connect Max azimuth ..: 360
10:32:02 Connect Elevation ....: Yes
10:32:02 Connect Port .........: COM5
10:32:02 Connect Speed ........: 9600
10:32:02 Connect DCB ..........: 9600,n,8,1
                      
10:32:02 COM5 Rotator M2 Az/El
10:32:02 COM5 Connecting to COM5
10:32:02 COM5 Setting I/O buffer queue sizes to 2048, 2048
10:32:02 COM5 Setting device control to 9600,n,8,1
10:32:02 COM5 Setting comms state
10:32:02 COM5 DTR control ..: 1
10:32:02 COM5 RTS control ..: 0
10:32:02 COM5 XON char .....: 11
10:32:02 COM5 XOFF char ....: 13
10:32:02 COM5 Error char ...: 3F
10:32:02 COM5 XON limit ....: 512
10:32:02 COM5 XOFF limit ...: 512
10:32:02 COM5 Setting timeouts
10:32:02 COM5 Read interval ............: 2000
10:32:02 COM5 Read total multiplier ....: 400
10:32:02 COM5 Read total constant ......: 2000
10:32:02 COM5 Write total multiplier ...: 200
10:32:02 COM5 Write total constant .....: 1000
10:32:02 COM5 Setting DTR, clearing RTS
10:32:03 COM5 Connected to COM5
TagsNo tags attached.
ModuleRotator
Sub-ModuleRotators
TestingNot Started

Activities

user36

2014-06-13 12:39

 

_bug- Rotator M2 Az-El.png (385,419 bytes)

JOSE

2019-01-30 15:27

developer   ~0007165

Looks like this bug has been fixed.
1. M2 Az/EL now has just 1 protocol which doesn't let the protocol combo box show up.
2. Attach is a screenshot of the log that shows the correct protocol when you try to connect.

M2 Az_EL.jpg (325,253 bytes)

Issue History

Date Modified Username Field Change
2014-06-13 12:39 user36 New Issue
2014-06-13 12:39 user36 File Added: _bug- Rotator M2 Az-El.png
2015-09-17 13:15 WA9PIE Category Rotator => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-23 00:01 WA9PIE Fix Build TBD => (select)
2015-09-23 00:01 WA9PIE Summary Bug: Rotator - M2 AZ/EL setup incorrect => Rotator - M2 AZ/EL setup incorrect
2018-03-04 00:53 WA9PIE Status new => assigned
2018-03-04 00:53 WA9PIE Assigned To => JOSE
2018-03-04 00:54 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-03-04 00:56 WA9PIE Testing => Not Started
2019-01-30 15:27 JOSE File Added: M2 Az_EL.jpg
2019-01-30 15:27 JOSE Note Added: 0007165
2019-01-30 15:28 JOSE Assigned To JOSE => WA9PIE
2019-02-12 21:08 JOSE Status assigned => resolved
2019-02-12 21:08 JOSE Resolution open => fixed
2019-02-12 21:08 JOSE Fixed in Version => 6.5.0.192
2019-02-24 14:35 WA9PIE Fixed in Version 6.5.0.192 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-03-01 19:26 WA9PIE Fixed in Version 6.5.0.196 => 6.5.0.199
2019-03-01 19:27 WA9PIE Fixed in Version 6.5.0.199 => 6.5.0.196