View Issue Details

IDProjectCategoryView StatusLast Update
0001659Ham Radio DeluxeBugpublic2018-07-25 20:47
ReporterWA9PIE 
Assigned ToARMAN 
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.873 
Summary0001659: Label problem
DescriptionTicket #604093

Nothing in the "Print -> Label" setup is working.
When I try to setup my own sheetsize and want to save it - the logbook hang - nothing to do except form kill the program.
When I try to print some QSO' from the loogbook, they all comes out in one row - and dosent fit the specified labels.
Cant delete my own label-types....
Cant find any documentation about this issue - please help.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleLabel
Testing Not Tested

Relationships

related to 0001684 assignedARMAN 3 - Current Dev List Label Printing on sheet fed labels 

Activities

WA9PIE

2014-06-23 22:08

administrator  

print-error.jpg (179,918 bytes)
print-error.jpg (179,918 bytes)

user36

2014-07-30 12:01

  ~0000446

After some research, the label column printing issue appears to be related to the size of the label widths.

For example: On a Brother HL-5470DW, the label in the last column is shifted down to the first column of the next row. Measuring the printed border on the hard copy (with "Draw Page Outlines" on) yields a width of 2.656" - much greater than the 2.625" specified. Reducing the border width to 2.594" yields a printed width of 2.625" and allows the borders to print correctly.

The difference, .062" per label, is enough to throw everything off.

ARMAN

2018-06-09 11:42

developer   ~0005230

Could you please explain what you mean by saying "sheetsize"? Is it same as page size? if so I can't reproduce the problem.
Also I don't see how QSO labels come out in one row, in the attached photo they are printed in two columns, if you change the label size width or horizontal gap the labels will print out in one column. Did you need that? Do I understand everything correct?
Thanks in advance.

ARMAN

2018-06-22 08:26

developer   ~0005379

This changeset contain fix concerning to the deletion of your own label type. https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4179
I was not able to reproduce the other issues.

WA9PIE

2018-06-30 17:08

administrator   ~0005575

We'll get into the "sheet-size" thing when we can have a call soon.

Suffice it to say... there are a number standard sheet sizes. Those work fine.

When using a standard sheet size, there's no need to confuse the user with a bunch of parameters about measurements there. But in order to create custom sheet sizes (for QSL cards), we have work to do.

g3ucq

2018-07-13 16:00

viewer   ~0005687

Cannot test this

WA9PIE

2018-07-18 23:55

administrator   ~0005740

I'm going to pass this, though it wasn't fully tested. It's an improvement and we're replacing the QSL feature.

Issue History

Date Modified Username Field Change
2014-06-23 22:08 WA9PIE New Issue
2014-06-23 22:08 WA9PIE File Added: print-error.jpg
2014-07-30 12:01 user36 Note Added: 0000446
2014-08-07 15:00 WA9PIE Summary Bug: Label problem (Ticket #604093) => Bug: Label problem
2014-08-07 15:00 WA9PIE Description Updated View Revisions
2014-08-12 17:14 user36 Project @5@ => 3 - Current Dev List
2014-08-12 17:14 user36 Proposed Release => 6.2.8
2014-08-12 17:15 user36 Relationship added related to 0001684
2014-08-12 19:41 user36 Priority normal => high
2014-10-08 22:06 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2015-09-17 13:40 WA9PIE Category Logbook => Bug
2015-09-22 16:38 WA9PIE Fix Build TBD => (select)
2015-09-22 16:38 WA9PIE Report Build 6.2.3.271 => (select)
2015-09-22 16:38 WA9PIE Proposed Release 6.2.8 => (select)
2015-09-22 16:38 WA9PIE Summary Bug: Label problem => Label problem
2018-03-04 00:49 WA9PIE Status new => assigned
2018-03-04 00:49 WA9PIE Assigned To => ARMAN
2018-03-04 00:49 WA9PIE Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2018-03-04 00:52 WA9PIE Testing => Not Started
2018-06-09 11:42 ARMAN Assigned To ARMAN => WA9PIE
2018-06-09 11:42 ARMAN Status assigned => feedback
2018-06-09 11:42 ARMAN Note Added: 0005230
2018-06-22 08:26 ARMAN Assigned To WA9PIE => ARMAN
2018-06-22 08:26 ARMAN Status feedback => resolved
2018-06-22 08:26 ARMAN Resolution open => fixed
2018-06-22 08:26 ARMAN Note Added: 0005379
2018-06-30 05:51 ARMAN Fixed in Version => 6.4.0.858
2018-06-30 17:08 WA9PIE Note Added: 0005575
2018-07-13 16:00 g3ucq Note Added: 0005687
2018-07-18 23:55 WA9PIE Status resolved => closed
2018-07-18 23:55 WA9PIE Testing Not Started => Not Tested
2018-07-18 23:55 WA9PIE Note Added: 0005740
2018-07-23 22:54 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-07-24 15:35 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2018-07-25 08:00 WA9PIE Fixed in Version 6.4.0.858 => 6.4.0.873
2018-07-25 20:47 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe