View Issue Details

IDProjectCategoryView StatusLast Update
00016645 - Closed w/o ActionBugpublic2019-09-14 02:13
Reporteruser36Assigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Summary0001664: Logbook - ALE window "W" worked status icon logic wrong.
DescriptionIn the ALE window, the "W" icon shows up for fields that have NOT been worked. It extinguishes when there is a match in the logbook for that field.
Steps To Reproduce- Open Logbook
- Open ALE window
- Observe blank fields with "W" icon
- Enter information for a previously logged QSO
- Observe status goes out

- Also observe DX Cluster - WSI's report correctly (i.e. worked indications for worked countries/stations
Additional InformationRef Ticket #657900
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
TestingNot Started

Relationships

duplicate of 0002801 assignedK7ZCZ 3 - Current Dev List Logbook: ALE "worked" indicators don't appear predictably 

Activities

WA9PIE

2017-03-05 21:13

administrator   ~0003105

Confirmed in 633

WA9PIE

2018-06-13 22:41

administrator   ~0005272

This actually should change to match the WSI values.

K7ZCZ

2018-07-04 16:55

administrator   ~0005608

It's not clear what these indicators should do, or what they mean.

There are indicators associated with these controls:

Main ALE: Callsign
Main ALE: LoTW
Main ALE: Locator
Main ALE: Country
Location Tab in ALE: Locator

Some of these have the same name as rows in the "Worked" tab, so maybe they're somehow meant to be related. But there are only single controls, and the "Worked" tab has (or can have) multiple columns.

There's also poor discoverability; the symbols in locator controls (and the Locator tab, too) don't have a key that explains what they mean.

Given some design work, it shouldn't be hard to get something useful working here. Thus issue is blocked on the completion of that design work.

K7ZCZ

2019-08-29 15:48

administrator   ~0008467

In the 2019-08-29 call, we agreed that we'd remove the [W] icons from the ALE since there's no clear way to implement "worked" for t he different combinations of data which might or might not be entered at the moment.

I'll remove the icons (and the backing code) for now. If we want to implement a feature that looks like this, we should invest the time in writing it up and discussing it.

Issue History

Date Modified Username Field Change
2014-07-03 16:10 user36 New Issue
2015-09-17 13:17 WA9PIE Category Logbook => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-23 00:00 WA9PIE Fix Build TBD => (select)
2015-09-23 00:00 WA9PIE Summary Bug: Logbook - ALE window "W" worked status icon logic wrong. => Logbook - ALE window "W" worked status icon logic wrong.
2017-03-05 21:13 WA9PIE Note Added: 0003105
2018-06-13 22:41 WA9PIE Note Added: 0005272
2018-07-04 16:55 K7ZCZ Assigned To => WA9PIE
2018-07-04 16:55 K7ZCZ Status new => feedback
2018-07-04 16:55 K7ZCZ Note Added: 0005608
2018-07-04 17:17 K7ZCZ Relationship added related to 0002801
2019-08-29 15:48 K7ZCZ Note Added: 0008467
2019-08-29 15:48 K7ZCZ Status feedback => resolved
2019-08-29 15:48 K7ZCZ Resolution open => duplicate
2019-08-29 15:48 K7ZCZ Testing => Not Started
2019-08-29 15:48 K7ZCZ Relationship replaced duplicate of 0002801
2019-08-30 13:35 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2019-09-14 02:12 WA9PIE Status resolved => closed
2019-09-14 02:13 WA9PIE Project 3 - Current Dev List => 5 - Closed w/o Action