View Issue Details

IDProjectCategoryView StatusLast Update
00017053 - Current Dev ListEnhancementpublic2019-07-17 17:13
Reporteruser36Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status feedbackResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0001705: Kenwood Radios (TS-480, 590, etc) do not display TX meters properly
DescriptionMeter only shows SWR on TX on Kenwood radios:

The meter select slider does not work. Selecting other than the default setting results in reversion back to the default setting upon refresh. (Note: it was verified on the TS-590S that the RMx; command to select the active meter does not work and results in a ?; error code. The published specs seem to be wrong.

*** Recommend changing the Layout for newer Kenwood radios to show SWR, ALC and Comp, similar to Yaesu. The RM; interrogation command returns the levels for all three in the same response. ***
Steps To ReproduceUsing a Kenwood TS-590S (or 480; other radios likely too):
- Open Rig Control and connect to the radio
- Select TX
- Observe the power meter shows SWR
- Go to Tools->Customize Layout, then open the Sliders: Layout tab
- On a blank slider option, select Meters
- Close the Options Tab
- Try to select a meter setting different than the default using the slider
Additional Information*** May also apply to all Kenwood radios with RM; commands, such as TS-570, TS-2000, TS-990 ***
TagsKenwood, TS-2000, TS-480, TS-590, TS-890S, TS-990
ModuleRig Control
Sub-ModuleRig Control
TestingNot Started

Relationships

has duplicate 0001495 closedK7ZCZ Ham Radio Deluxe Meters in TX mode not working on Kenwood TS-480 
has duplicate 0001320 closedK7ZCZ Ham Radio Deluxe TS-480 SAT - S-Meter TX Mode not showing for 
has duplicate 0001882 closedKB3NPH 5 - Closed w/o Action TS-590s s meter in rig cntrl not showing swr or alc in xmt 
related to 0002305 assignedK7ZCZ 1 - Backlog Ticket #661941 Modification request of current feature in TS-590SG 

Activities

K7ZCZ

2017-09-20 10:35

administrator   ~0004248

This issue turns out to be pretty involved, and is the intersection of three different problems.

Problem #1: No round-trip of visible meters state disrupts the "Meter" slider

The "Meter" slider lets the user select of the available secondary meter settings on a radio. For some Kenwood radios (like the TS-480 and TS-590), the physical meter on the radio shows signal strength ("S meter"), and a secondary meter shows any one of a few configurable settings: SWR, compression, or ALC. Some radios have more choices; the TS-990 additionally offers ID, VD, and Temperature, for example.

The architecture of the rig control app is such that it handles sliders by sending a command to make a setting, then send another command to read the same setting back from the radio. This is a sensible approach becaue reading the actual state back from the radio confirms that the screen represents the actual state of the radio. If the radio misses the command, or the user physically interacts with the radio to change the state, then the visible state in the UI is corrected on the next update. More specifically, the design is such that the rig control application doesn't maintain it's own copy of the state of the radio.

The Kenwood radios use the "RM" command to set the state of the meter. RM accepts an integer parameter to turn the radio to a particular meter type; RM1 sets the TS-480 radios to SWR, for example. Rig Control would send "RM1" if the user moved the "Meter" slider to the "SWR" position.

On the next update of the radio status, Rig Control will use the "RM" command to query the radio to see which meter mode has been selected. Unfortunately, the "RM" command does not report the currently selected meter mode. Instead, it sends a series of replies that indicate the value of each meter reading. On a TS-480, the single "RM;" query command gets a response like this:

RM10010;RM20005;RM30002;

which indicates readings of 10/10 for SWR, 5/10 for compression, and 2/10 for ALC.

The RM query response gives the meter readings, but does NOT give the state of the meter display. Nothing in the response indicates that the physical radio is presently showing the "compression" reading, for example.

Thus, when Rig Control reads this command's output, it doesn't know what the display is showing. It misinterprets the response as "1" and the visible meter slider reverts to the corresponding "SWR" setting even though the radio might be showing something else. Notably, some Kenwood radios (like the TS-990) provide the MT; command, which reads and sets the displayed meter type.

Note further that the meters involved are mostly transmit-only parameters. When not transmitting, the values are 0 -- no power, no compression, no ALC is active when listening. In TX, these values are dynamic with the input signal.



Problem #2: One or Two S meter displays in Rig Control?

While the radio displays two meters, only one is shown in Rig Control. Some radios DO show two meters, but these radios have dual front-ends (not dual VCOs) and can simultaneously show two S meters. The request that two meters be shown (Mantis 1320) is possible, but it doesn't match the general architecture of Rig Control, which shows two meters only for radios with two S-meters.

There's at least a little bit of confusion in the UI about "two meters" meaning two S-meters, or one S-meter and one selectable TX-parameter meter. Conceivably, we should offer two or three meters in the UI to display one (or two) S-meters, plus one of the confgurable TX-parameter meters.


Problem #3: Representation of TX-only parameters

Since the secondary meters are mostly TX-only parameters, a setting in the software allows the configuration of the two displayed meters. The setting in question is reachable using the "Customize" button in Rig Control, then activating the "Meters" tab in the resulting "Customize Layout" dialog. In that window, a "S Meter - TX mode" group box contains two drop down controls for the "Main" and "Sub" meters, and offers various choices for the parameter to be displayed in each meter.

This UI is problematic for a few reasons. First, it is global; it affects all radio connections, and isn't set on a per-radio or per-connection basis. Because of its global scope, the next problem is that the dialog isn't aware of the connected radio and implies that there will always be two visible meters in the UI of the radio.

The description in the UI says that the secondary display, for TS-2000 and TS-480 radios, will be based on the setting of the "Meter" slider. However, since the meter slider state isn't reliable because of the missing query command (Problem #1 above), this scheme simply doesn't work. And it's also not too practical for users who have radios (like the TS-480 )


Possible solutions:

Note that the architecture of Rig Control works fine for radios which do allow the reading of the selected, visible meter type. (I don't have a TS-990 to test with, but even if it doesn't work, it could be made to do so by using its MT command instead of the RM command to read the state of the radio.) Radios like the Yaesu FT-450D have a secondary meter and the meter slider works correctly, since the state of the radio's selected secondary meter is both settable and readable using CAT commands.

For radios without CAT command support to query the configured meter, I think we have two choices:

Solution #1: Modify Rig Control to NOT support the meter slider for these radios -- it can't be made to work without the required CAT command. Instead, we can offer one or more configurable secondary meters. The user can choose one in the Rig Control UI, but it won't follow the physical setting in the radio. This does resolve the customer request of showing the dynamic, transmit-only measurement from the radio.

Solution #2: Modify Rig Control to show any number of additional meters at the user's discretion. The user can then configure whatever they want (that the radio supports) and dynamically show multiple TX parameters at the same time. Kenwood's own ARCP-480 software does something like this; it displays meters for all three TX parameters, plus the S-meter.

Solution #3: Maybe there are other ideas ... ?

The two identified solutions don't rely on being able to read the selected meter state from the radio, so they're implementable for any radio. A decision would need to be made about applying the solution to all radios, only some (just the radios without readable meter type settings).

K7ZCZ

2019-02-02 22:59

administrator   ~0007230

setting to feedback to see if we can make some progress on the decisions outlined here. It's been more than four months ...

K7ZCZ

2019-03-16 20:05

administrator   ~0007689

Nobody to assign for feedback because the reporter is a strike-through account. It's been sitting around for several months.

WA9PIE

2019-03-24 23:23

administrator   ~0007732

If a given rig doesn't have a command to support the query of a configured meter, then I think solution #1 is the right approach. It solves the problem and (I think) solution #2 introduces complexity we don't need right now.

K7ZCZ

2019-07-17 17:12

administrator   ~0008245

The work I've done on the TS-890 has revealed some more information.

Unlike the TS-480, the TS-890 does *not* give multiple responses to a single "RM" command, even though the manuals for both radios imply that they would work the same way. I've added some code to the Rig Control application to make the TS-890 work mostly as expected: rig control will show the meter selected on the front panel. This is facilitated by the availability of an "MT" command on the TS-890 and TS-990. The MT commnad reports identity of the selected meter. It appears that other TS-model radios from Kenwood don't support this feature, so for those radios we're in the same boat.

One next step for this issue woudl be to remove the "transmit meter" buttons from the options screen. They're not actually connected to anything -- or, more accurately, they're connected to code that doesn't actually work.

The changes for the TS-890 and TS-990 are in this change list, in the 6.7 branch of the product:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5077

Issue History

Date Modified Username Field Change
2014-08-22 13:07 user36 New Issue
2014-08-22 13:08 user36 Relationship added related to 0001495
2015-09-17 13:17 WA9PIE Category Rig Control => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-22 23:41 WA9PIE Fix Build TBD => (select)
2015-09-22 23:41 WA9PIE Summary Bug: Kenwood Radios (TS-480, 590, etc) do not display TX meters properly => Kenwood Radios (TS-480, 590, etc) do not display TX meters properly
2017-07-09 03:30 K7ZCZ Tag Attached: Kenwood
2017-07-09 03:30 K7ZCZ Tag Attached: TS480
2017-07-09 03:30 K7ZCZ Tag Attached: TS590
2017-07-26 19:09 K7ZCZ Relationship added child of 0001569
2017-09-19 01:30 K7ZCZ Relationship added related to 0001320
2017-09-20 10:35 K7ZCZ Note Added: 0004248
2017-09-20 10:39 K7ZCZ Relationship replaced has duplicate 0001320
2017-09-20 10:45 K7ZCZ Relationship replaced has duplicate 0001495
2018-03-04 01:13 WA9PIE Status new => resolved
2018-03-04 01:13 WA9PIE Resolution open => fixed
2018-03-04 01:13 WA9PIE Testing => Not Started
2018-03-04 01:13 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-03-04 01:14 WA9PIE Fixed in Version => 6.4.0.788
2018-03-04 01:19 WA9PIE Assigned To => K7ZCZ
2018-03-04 13:49 WA9PIE Status resolved => assigned
2018-03-04 13:49 WA9PIE Resolution fixed => open
2018-03-04 13:49 WA9PIE Fixed in Version 6.4.0.788 =>
2018-04-06 11:22 K7ZCZ Relationship added related to 0002305
2018-07-12 18:38 K7ZCZ Relationship added has duplicate 0001882
2018-11-29 00:30 WA9PIE Tag Attached: Kenwood TS-480
2018-11-29 00:30 WA9PIE Tag Detached: Kenwood
2018-11-29 00:30 WA9PIE Tag Detached: TS480
2018-11-29 00:30 WA9PIE Tag Attached: Kenwood TS-590SG
2018-11-29 00:30 WA9PIE Tag Detached: TS590
2018-11-30 23:03 WA9PIE Tag Attached: Kenwood
2018-11-30 23:03 WA9PIE Tag Attached: TS-480
2018-11-30 23:04 WA9PIE Tag Detached: Kenwood TS-480
2018-11-30 23:04 WA9PIE Tag Attached: TS-590
2018-11-30 23:04 WA9PIE Tag Detached: Kenwood TS-590SG
2018-11-30 23:59 WA9PIE Tag Attached: TS-2000
2018-12-21 10:26 K7ZCZ Relationship deleted child of 0001569
2019-02-02 22:59 K7ZCZ Status assigned => feedback
2019-02-02 22:59 K7ZCZ Note Added: 0007230
2019-03-16 20:05 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-03-16 20:05 K7ZCZ Note Added: 0007689
2019-03-24 23:23 WA9PIE Note Added: 0007732
2019-03-24 23:23 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-06-06 14:51 WA9PIE Category Bug => Enhancement
2019-07-17 17:12 K7ZCZ Note Added: 0008245
2019-07-17 17:12 K7ZCZ Tag Attached: TS-990
2019-07-17 17:13 K7ZCZ Tag Attached: TS-890S