View Issue Details

IDProjectCategoryView StatusLast Update
0001728Ham Radio DeluxeBugpublic2019-02-24 15:12
Reporteruser36 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0001728: IC-7700 add on/off functionality to Rig Control
DescriptionCustomer requests ability to turn IC-7700 on/off (or perhaps standby) via Rig Control. Please investigate if this is possible.

May be an undocumented feature - see below:

Dear Sir,
           Thank you for your very prompt reply, I select my Transceiver in the drop down list of Transceiver manufacturers
"Icom", then I select the model, ic7700 I make sure all the connections match in both the Transceiver settings and ham radio deluxe, correct baud connection, correct civ address 74h then press "connect", failed to read frequency message appears. I then close ham radio deluxe and try another program called TRX Manager press the software button marked power in TRX Manager, which I assume is the same as "connect", in Ham Radio Deluxe.
If the Icom Transceiver is already switched on then Ham Radio Deluxe goes straight to the frequency that is displayed by the Transceiver icom ic7700. if I put the Icom into standby mode re run ham radio deluxe it will not connect, it just displays the message "failed to read frequency",
hope this is of some help to you so the issue here is you select your transceiver manufacturer, then you select your version (in this case ic7700, check that the settings of ham radio deluxe match the transceivers settings and press "connect", nothing happens !
Additional InformationCheck out TRX from Hosenose software.

http://www.trx-manager.com/whatsnew.htm
(See notes for ver 5.2.4)
TagsIC-7700, ICOM
ModuleRig Control
Sub-ModuleRig Control
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-12-01 15:30

manager   ~0006510

The IC-7700 manual says that the 0x18-00 and 0x18-01 commands are supported, but doesn't provide the details that manuals for other models provide. I've added code to enable the on/off feature in the same way we work the feature for other Icom models. It will need to be tested by someone with access to an IC-7700.

K7ZCZ

2018-12-01 15:33

manager   ~0006511

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4503

K7ZCZ

2018-12-01 18:33

manager   ~0006513

Fixed in the 6.5 branch with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4504

I didn't mean to fix it for 6.4; I just wasn't paying attention. Doesn't seem worth it to revert the change, so ...

WA9PIE

2019-01-11 19:32

administrator   ~0006970

Bill Morton (W4ASE) has agreed to test this within the next week.

WA9PIE

2019-01-16 22:05

administrator   ~0007017

We've got one user who will test this after the release.

WA9PIE

2019-01-17 21:31

administrator   ~0007024

Last edited: 2019-01-17 21:33

View 2 revisions

Word I got back from two users who tested this was that it didn't work. I'm collecting more info.

K7ZCZ

2019-01-19 15:52

manager   ~0007035

Another speculative fix in this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4741

WA9PIE

2019-02-03 19:25

administrator   ~0007251

We'll call this validated for the IC-7700.

============

Report by Bill Morton (W4ASE)

Here are my findings.

You have two radios definitions listed for the 7700 – a plain 7700 and a 7700v2 – I have always used the 7700 v2 since it was released – I can’t remember now what the v2 was supposed to fix??? But I have always used it.

The plain 7700 does ask to switch off the radio upon close – and both options work - so it is working

The 7700 v2 DOES NOT ask.

So just apply the change to the 7700 v2 definition and you are set – or think about just having one 7700 definition available so it cuts down on confusion.

Issue History

Date Modified Username Field Change
2014-09-26 19:15 user36 New Issue
2015-09-17 13:17 WA9PIE Category Rig Control => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-22 23:40 WA9PIE Fix Build TBD => (select)
2015-09-22 23:40 WA9PIE Summary Enhancement: IC-7700 add on/off functionality to Rig Control => IC-7700 add on/off functionality to Rig Control
2018-11-28 01:43 WA9PIE Tag Attached: Icom IC-7700
2018-11-30 16:53 WA9PIE Tag Attached: ICOM
2018-11-30 16:53 WA9PIE Tag Attached: IC-7700
2018-11-30 16:53 WA9PIE Tag Detached: Icom IC-7700
2018-12-01 15:30 K7ZCZ Note Added: 0006510
2018-12-01 15:33 K7ZCZ Assigned To => K7ZCZ
2018-12-01 15:33 K7ZCZ Status new => resolved
2018-12-01 15:33 K7ZCZ Resolution open => fixed
2018-12-01 15:33 K7ZCZ Testing => Not Started
2018-12-01 15:33 K7ZCZ Note Added: 0006511
2018-12-01 18:33 K7ZCZ Note Added: 0006513
2018-12-05 11:24 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-12-09 15:49 K7ZCZ Fixed in Version => 6.5.0.132
2019-01-11 19:32 WA9PIE Note Added: 0006970
2019-01-16 22:05 WA9PIE Status resolved => closed
2019-01-16 22:05 WA9PIE Testing Not Started => Not Tested
2019-01-16 22:05 WA9PIE Note Added: 0007017
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-01-16 22:07 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-17 21:31 WA9PIE Status closed => feedback
2019-01-17 21:31 WA9PIE Resolution fixed => reopened
2019-01-17 21:31 WA9PIE Fixed in Version 6.5.0.183 =>
2019-01-17 21:31 WA9PIE Testing Not Tested => Beta Failed
2019-01-17 21:31 WA9PIE Note Added: 0007024
2019-01-17 21:33 WA9PIE Note Edited: 0007024 View Revisions
2019-01-17 21:33 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2019-01-19 15:52 K7ZCZ Status feedback => resolved
2019-01-19 15:52 K7ZCZ Resolution reopened => fixed
2019-01-19 15:52 K7ZCZ Note Added: 0007035
2019-01-20 21:04 K7ZCZ Fixed in Version => 6.5.0.186
2019-02-03 19:25 WA9PIE Note Added: 0007251
2019-02-03 19:25 WA9PIE Status resolved => closed
2019-02-03 19:25 WA9PIE Testing Beta Failed => Beta Successful
2019-02-24 14:40 WA9PIE Fixed in Version 6.5.0.186 => 6.5.0.196
2019-02-24 15:12 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe