View Issue Details

IDProjectCategoryView StatusLast Update
0001771Ham Radio DeluxeBugpublic2018-06-23 16:17
Reporteruser36 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.846 
Summary0001771: ALE window does not display certain characters properly
DescriptionCertain non-English characters in ALE window do no display correctly.

Possible Unicode issue.

Example: accented "e" becomes careted "c".

Steps To Reproduce- Launch Logbook
- Ensure that Logbook is configured for callsign lookup
- Open the ALE Window
- Enter the callsign F5JD
- Hit tab or click QRZ to perform a lookup
- Observe the name populates as "José DUMOULIN"
- Launch DM-780
- Ensure that DM is connected to LB
- Open the DM ALE window
- Enter the callsign F5JD
- Hit tab to perform a lookup
- Observe the name populates as "Josc DUMOULIN" (the c has a caret on top)
  (see attached image)
TagsNo tags attached.
ModuleDM780
Sub-ModuleALE Window
Testing Beta Successful

Relationships

duplicate of 0002632 closedK7ZCZ Logbook: QRZ lookup doesn't handle non ASCII characters at QRZ lookup 
related to 0001772 closedK7ZCZ DM-780 - The callsign XE1USG does not carry over to Logbook 

Activities

user36

2015-01-07 14:37

 

2015-01-07_12-24-17.png (22,087 bytes)
2015-01-07_12-24-17.png (22,087 bytes)

K7ZCZ

2018-04-17 07:22

manager   ~0004853

0002632 was the root cause of this issue. Once Logbook correctly handles the Unicode encoding from QRZ, it manages non-ASCII characters fine.

I'm surprised that it's true, but I've verified with the excellent repro steps provided here that, in current builds, communication between DM780 and Logbook maintains the Unicode encoding and the desired accented character appears in a DM780 lookup of F5JD's info.

WA9PIE

2018-06-05 17:50

administrator   ~0005210

This doesn't look correct to me. When looking up F5JD with the test function in Callsign Lookup, the name comes back correctly as "<Fname>José</Fname>"... but it's displayed as "Josĉ Dumoulin"

WA9PIE

2018-06-13 20:49

administrator   ~0005260

Still exists in the 943 release. Changing the status back to assigned

K7ZCZ

2018-06-23 10:44

manager  

AccentAigu.png (16,018 bytes)
AccentAigu.png (16,018 bytes)

K7ZCZ

2018-06-23 10:44

manager   ~0005393

I assume that "943" really means "843".

The issue as described doesn't repro for me. In DM-780, I see "José DUMOULIN" as expected.

K7ZCZ

2018-06-23 13:06

manager   ~0005395

In Chat, WA9PIE reported that he can always reproduce this issue.

With that information, we need to focus on how you his settings or configuration might be different.

Here are some relevant questions:

Have you tried reproducing the issue with other callsigns?

Does the issue affect only the name field, or the address information, too? Any other fields?

Do you have multiple sources for callsign resolution configured? Which one is being used to satisfy the erroneous lookup in your repro case?

Is it possible that the misspelled name is in your logbook, and it's not actually coming from QRZ?

K7ZCZ

2018-06-23 14:56

manager   ~0005398

I think the primary configuration setting to focus on are the Callsign Lookup settings in the logbook. The repro steps here don't mention them, and don't mention the state of the logbook database in use when the repro steps are executed.

If the Callsign Lookup settings in the Logbook consider previous QSOs in the Logbook, and the used database has an entry for the callsign being retrieved, the entry from the Logbook database is used. If no Logbook database entry is a match, then other sources are considered in the order that they're configured in the Logbook Callsign Lookup settings.

The default Callsign Lookup settings are shown below. We can see the Logbook database is used first, then the Country List (?), then the QRZ.com settings. The assumption in this bug is that correct data is retrieved from QRZ, but the accents lost due to a bug in character translation in the Logbook (or between the Logbook and Digital Master) and the accented characters are lost. I contend that representation translations in the Logbook's code were a problem, but have since been fixed; and further that this issue appears to reproduce when it's really just getting bad data previously stored in the Logbook database.

Let's demonstrate that scenario with some very specific repro steps.

1) Start up the Logbook
2) Configure only a new database. No otehr databases should be configured; that is, not only not opened, but not set up for the logbook to open.
3) Use the "Callsign Lookup" command to edit the Callsign Lookup settings so that the methods enabled match the defaults shown in the attached screenshot.
4) In the Empty database, use the ALE to add a new entry
5) In the ALE window, enter the callsign "F5JD". Press TAB (or click the "Lookup" button) to lookup the callsign. At this point, the database is empty, so the lookup will end up being resolved by QRZ. Note that the lookup correctly finds "Jose", with accent aigu on the E.

6) Before saving the entry, edit it so that Jose's name is incorrectly spelled. I guess we could make it exactly match the c-circumflex reported here, but it's easy enough to enter "Josxxx". Remember to edit Jose's mailing address on the "Location" tab, too. When you're done, the ALE should look something like the attached screen shot (with different dates and times)

7) Press "add" to save that entry

8) Start DM780
9) Get the ALE in DM780 open.
10) Enter Jose's callsign, "F5JD", and press TAB to look it up.

11) At this point, you'll find that DM780 has retrieved "Josxxx" from the Logbook. The Logbook had the result locally, and never went to QRZ, since that's exactly what it is configured to do. Thus, in order to falsely repro this issue, I think we can conclude that the user's database must have had an entry in it with Jose's name mispelled and that entry satisfied the DM780 lookup request, just as demonstrated here.

CallsignLookupConfig.png (26,165 bytes)
CallsignLookupConfig.png (26,165 bytes)

K7ZCZ

2018-06-23 14:57

manager  

JoseXXX.png (44,659 bytes)
JoseXXX.png (44,659 bytes)

WA9PIE

2018-06-23 16:16

administrator   ~0005399

My previous note said it was not fixed in the "943" build. That was a typo and should have been "843" build. I didn't edit the comment because it changes the date/time of all subsequent comments.

But I just tested this on the 846 build and the problem has been fixed.

Issue History

Date Modified Username Field Change
2015-01-07 14:37 user36 New Issue
2015-01-07 14:37 user36 File Added: 2015-01-07_12-24-17.png
2015-01-07 15:01 user36 Relationship added related to 0001772
2015-09-17 13:17 WA9PIE Category DM-780 => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-22 23:37 WA9PIE Fix Build TBD => (select)
2015-09-22 23:37 WA9PIE Summary Bug - ALE window does not display certain characters properly => ALE window does not display certain characters properly
2018-04-17 07:15 K7ZCZ Assigned To => K7ZCZ
2018-04-17 07:15 K7ZCZ Status new => assigned
2018-04-17 07:19 K7ZCZ Relationship added related to 0002632
2018-04-17 07:20 K7ZCZ Relationship deleted related to 0002632
2018-04-17 07:22 K7ZCZ Status assigned => resolved
2018-04-17 07:22 K7ZCZ Resolution open => duplicate
2018-04-17 07:22 K7ZCZ Testing => Not Started
2018-04-17 07:22 K7ZCZ Note Added: 0004853
2018-04-17 07:22 K7ZCZ Relationship added duplicate of 0002632
2018-04-17 07:26 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-05-03 20:10 K7ZCZ Fixed in Version => 6.4.0.837
2018-06-05 17:50 WA9PIE Note Added: 0005210
2018-06-13 20:49 WA9PIE Note Added: 0005260
2018-06-13 20:49 WA9PIE Status resolved => assigned
2018-06-13 20:49 WA9PIE Resolution duplicate => reopened
2018-06-13 20:49 WA9PIE Fixed in Version 6.4.0.837 =>
2018-06-23 10:44 K7ZCZ File Added: AccentAigu.png
2018-06-23 10:44 K7ZCZ Note Added: 0005393
2018-06-23 10:44 K7ZCZ Status assigned => resolved
2018-06-23 10:44 K7ZCZ Resolution reopened => unable to reproduce
2018-06-23 13:06 K7ZCZ Note Added: 0005395
2018-06-23 14:56 K7ZCZ File Added: CallsignLookupConfig.png
2018-06-23 14:56 K7ZCZ Note Added: 0005398
2018-06-23 14:57 K7ZCZ File Added: JoseXXX.png
2018-06-23 16:16 WA9PIE Status resolved => closed
2018-06-23 16:16 WA9PIE Resolution unable to reproduce => fixed
2018-06-23 16:16 WA9PIE Fixed in Version => 6.4.0.846
2018-06-23 16:16 WA9PIE Testing Not Started => Beta Successful
2018-06-23 16:16 WA9PIE Note Added: 0005399
2018-06-23 16:17 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe