View Issue Details

IDProjectCategoryView StatusLast Update
0001772Ham Radio DeluxeBugpublic2018-06-05 17:51
Reporteruser36Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0001772: DM-780 - The callsign XE1USG does not carry over to Logbook
DescriptionWhen entered in the DM ALE, the callsign XE1USG will not carry over to Logbook. All other callsigns work fine.

Steps To Reproduce- Open Logbook
- Open DM-780
- Ensure that DM is connected to LB
- Open the DM ALE window
- Enter XE1USG in the callsign
- Click the Add button
- Observe that the entry is not in Logbook
Additional InformationRef Ticket 325370.

Customer reported the discrepancy (builds 285, 294, and 316) and WY7YL verified the same results in build 322. N6EY also verified it with W4PC using build 322.

WY7YL is running Access database. She observed that it would not carry over if the mode was set to CW, but would carry over if the mode was set to PSK.

N6EY is running a MySQL database and observed similar results. However, the mode made no difference. The entry would not show up in Logbook.
When the DB was switched to Access, the callsign carried over regardless of mode.

TagsNo tags attached.
ModuleDM780
Sub-ModuleALE Window
TestingNot Started

Relationships

duplicate of 0002632 closedK7ZCZ Logbook: QRZ lookup doesn't handle non ASCII characters at QRZ lookup 
related to 0001771 closedK7ZCZ ALE window does not display certain characters properly 

Activities

user36

2015-01-07 15:03

  ~0000611

Last edited: 2015-01-07 15:40

View 2 revisions

Update: PROBABLE CAUSE

XE1USG's middle name is Guzmán. The accented "a" does not appear the same in the DM-780 ALE when the lookup is performed - it is an "a" with a tilde "~" above it.

When the "a" is eliminated from the middle name, the logbook entry is made correctly.

Possible Unicode Issue.

K7ZCZ

2018-04-17 07:24

administrator   ~0004854

Fixed with 0002632.

In current builds (around 806) the XE1USG lookup results in the name "Salvador Guzmān Tejeda" as expected; a with macron is intact.

WA9PIE

2018-06-05 17:45

administrator   ~0005209

I tested this myself and the issue is fixed.

Issue History

Date Modified Username Field Change
2015-01-07 14:47 user36 New Issue
2015-01-07 14:47 user36 Status new => assigned
2015-01-07 14:47 user36 Assigned To => ERIK
2015-01-07 15:01 user36 Relationship added related to 0001771
2015-01-07 15:03 user36 Note Added: 0000611
2015-01-07 15:39 user36 Reproducibility sometimes => always
2015-01-07 15:40 user36 Note Edited: 0000611 View Revisions
2015-09-17 13:01 WA9PIE Report Build 6.2.72 => (select)
2015-09-17 13:01 WA9PIE Category Logbook => DM-780
2015-09-17 13:17 WA9PIE Category DM-780 => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-22 23:37 WA9PIE Fix Build TBD => (select)
2015-09-22 23:37 WA9PIE Summary Bug: DM-780 - The callsign XE1USG does not carry over to Logbook => DM-780 - The callsign XE1USG does not carry over to Logbook
2017-03-08 10:40 WA9PIE Assigned To ERIK => WA9PIE
2018-04-17 07:14 K7ZCZ Assigned To WA9PIE => K7ZCZ
2018-04-17 07:24 K7ZCZ Status assigned => resolved
2018-04-17 07:24 K7ZCZ Resolution open => duplicate
2018-04-17 07:24 K7ZCZ Testing => Not Started
2018-04-17 07:24 K7ZCZ Note Added: 0004854
2018-04-17 07:24 K7ZCZ Relationship added duplicate of 0002632
2018-04-17 07:25 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-05-03 20:10 K7ZCZ Fixed in Version => 6.4.0.837
2018-06-05 17:45 WA9PIE Note Added: 0005209
2018-06-05 17:45 WA9PIE Status resolved => closed
2018-06-05 17:45 WA9PIE Fixed in Version 6.4.0.837 => 6.4.0.840
2018-06-05 17:51 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe