View Issue Details

IDProjectCategoryView StatusLast Update
00018303 - Current Dev ListBugpublic2019-03-01 17:08
ReporterKB3NPHAssigned ToKB3NPH 
PriorityhighSeveritymajorReproducibilityhave not tried
Status assignedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0001830: Yaesu Rotor CAT not working
DescriptionTicket #404078
11/23/2015 5:38 pm Ari Paananen

Hello,
I have a Yeasu FT-2000 rig and a Yaesu G-1000DXC rotator. They are connected together with a mini-DIN6 cable. The rotator turns perfectly with both the control unit and the FT-2000 function keys so the connection between the rig and rotator control unit seem to be fine.

The rig is connected to my computer via microHAM micro Keyer II and normal CAT and digital operations with it work just fine. When I open the HRD Locator software, select "Yeasu Rotor CAT" and press "Connect" I seem to get a connection, but the software fails to show the current bearing correctly and it also doesn't seem to respond when I try to turn the rotator with it.

Sometimes when I leave it on for a longer time (several minutes) it suddenly responds and starts turning the motor but there is no logic in what it does. Usually in these cases the motor turns all the way to the maximum 360+90 degrees and then stops there. Also at this point looking at the Windows Task Manager, the rotator software is hogging as much of CPU as it can.

When I start the HRD Locator and connect, the Logfile tab shows this:

00:30:43 DDE Server DDE Initialized, ID = 01000080

00:30:43 General Loading layout from C:\Users\apa\AppData\Roaming\HRDLLC\HRD Rotator\WindowLayout001.xml

00:30:43 Zoom Mercator X = 0, Y = 0, ZoomLat = -1.$, ZoomLon = 100.0
00:30:43 Zoom Mercator X = 253, Y = 127, ZoomLat = 99.6, ZoomLon = 100.0
00:30:43 Zoom Mercator X = 444, Y = 222, ZoomLat = 100.0, ZoomLon = 100.0

00:30:43 DDE Server Registered service HRDRotator
00:30:43 DDE Server ---
00:30:43 DDE Server Callback:Type:000080A2
00:30:43 DDE Server Callback:Conv:00000000
00:30:43 DDE Server Callback:Data:00000000
00:30:43 DDE Server Callback:String1:HRDRotator
00:30:43 DDE Server Callback:String2:HRDRotator(0X00081580)
00:30:43 DDE Server Callback:Register

00:30:43 Zoom Mercator X = 444, Y = 222, ZoomLat = 100.0, ZoomLon = 100.0

00:30:48 Connect Rotator ......: Yaesu Rotor CAT
00:30:48 Connect Protocol .....: Yaesu Radio Ca Az
00:30:48 Connect Step size ....: Auto
00:30:48 Connect Min azimuth ..: -180
00:30:48 Connect Max azimuth ..: 540
00:30:48 Connect Elevation ....: No

00:30:48 Zoom Mercator X = 444, Y = 222, ZoomLat = 100.0, ZoomLon = 100.0
00:30:53 Zoom Mercator X = 253, Y = 127, ZoomLat = 99.6, ZoomLon = 100.0
00:31:00 Zoom Mercator X = 444, Y = 222, ZoomLat = 100.0, ZoomLon = 100.0
00:34:07 Zoom Mercator X = 253, Y = 127, ZoomLat = 99.6, ZoomLon = 100.0

At least the Min and Max azimuth readings are totally wrong, they should be from 0 to 450.
 
TagsNo tags attached.
ModuleRotator
Sub-Module
TestingNot Started

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2015-11-25 07:58 KB3NPH New Issue
2018-03-04 00:53 WA9PIE Status new => assigned
2018-03-04 00:53 WA9PIE Assigned To => JOSE
2018-03-04 00:54 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-03-04 00:56 WA9PIE Testing => Not Started
2019-03-01 17:08 WA9PIE Assigned To JOSE => KB3NPH