View Issue Details

IDProjectCategoryView StatusLast Update
00018351 - BacklogBugpublic2018-08-06 01:50
Reporteruser51Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformWindowsOSWindowsOS Version8.1
Summary0001835: WINKEY 2.3 needs at least 9 characters in send buffer
DescriptionIf you try to send less then 9 characters using WINKEY (cw(winkey)), it will key radio and send only one character and stop .. doesn't hang program, just stops sending ...

CW(SSB) works fine .. no issues

did not try other CW modes ...
Steps To Reproducew3rjw w3rjw<stop> works every time

w3rjw w3rj<stop> works

w3rjw w3r<stop> works

w3rjw w3<stop> sends only 'w' or nothing

Additional InformationOLD, old problem, must be in Mantis somewhere but I could not find it . A real pain if you want to send your call only once ....
TagsNo tags attached.
ModuleDM780
Sub-Module
Testing

Activities

user51

2015-12-05 08:06

 

w3rjw Logfile.txt (2,573 bytes)
Ignored ..: 000000FF (Char �)
Queued ...: 00000057 (Char W)
Writing byte 57 (W) - status OK
Queued ...: 00000033 (Char 3)
Writing byte 33 (3) - status OK
Queued ...: 00000052 (Char R)
Writing byte 52 (R) - status OK
Queued ...: 0000004A (Char J)
Writing byte 4A (J) - status OK
Recv: C4
Status 1 ...: x04
Recv: 57
Echo char ..: W (x57)
Queued ...: 00000057 (Char W)
Writing byte 57 (W) - status OK
Queued ...: 00000020 (Char  )
Writing byte 20 ( ) - status OK
Queued ...: 00000057 (Char W)
Writing byte 57 (W) - status OK
Queued ...: 00000033 (Char 3)
Writing byte 33 (3) - status OK
Queued ...: 00000052 (Char R)
Writing byte 52 (R) - status OK
Recv: 33
Echo char ..: 3 (x33)
Queued ...: 0000004A (Char J)
Writing byte 4A (J) - status OK
Queued ...: 00000057 (Char W)
Writing byte 57 (W) - status OK
Recv: 52
Echo char ..: R (x52)
Recv: 4A
Echo char ..: J (x4A)
Recv: 57
Echo char ..: W (x57)
Recv: 20
Echo char ..:   (x20)
Recv: 57
Echo char ..: W (x57)
Recv: 33
Echo char ..: 3 (x33)
Recv: 52
Echo char ..: R (x52)
Recv: 4A
Echo char ..: J (x4A)
Recv: 57
Echo char ..: W (x57)
Recv: C0
Status 1 ...: x00
Ignored ..: 000000FF (Char �)
Queued ...: 00000057 (Char W)
Writing byte 57 (W) - status OK
Queued ...: 00000033 (Char 3)
Writing byte 33 (3) - status OK
Queued ...: 00000052 (Char R)
Writing byte 52 (R) - status OK
Queued ...: 0000004A (Char J)
Writing byte 4A (J) - status OK
Recv: C4
Status 1 ...: x04
Recv: 57
Echo char ..: W (x57)
Queued ...: 00000057 (Char W)
Writing byte 57 (W) - status OK
Queued ...: 00000020 (Char  )
Writing byte 20 ( ) - status OK
Queued ...: 00000057 (Char W)
Writing byte 57 (W) - status OK
Queued ...: 00000033 (Char 3)
Writing byte 33 (3) - status OK
Queued ...: 00000052 (Char R)
Writing byte 52 (R) - status OK
Recv: 33
Echo char ..: 3 (x33)
Queued ...: 0000004A (Char J)
Writing byte 4A (J) - status OK
Queued ...: 00000057 (Char W)
Writing byte 57 (W) - status OK
Recv: 52
Echo char ..: R (x52)
Recv: 4A
Echo char ..: J (x4A)
Recv: 57
Echo char ..: W (x57)
Recv: 20
Echo char ..:   (x20)
Recv: 57
Echo char ..: W (x57)
Recv: 33
Echo char ..: 3 (x33)
Recv: 52
Echo char ..: R (x52)
Recv: 4A
Echo char ..: J (x4A)
Recv: 57
Echo char ..: W (x57)
Recv: C0
Status 1 ...: x00
Ignored ..: 000000FF (Char �)
Queued ...: 00000057 (Char W)
Writing byte 57 (W) - status OK
Stop Called
Queued ...: 0000000A (Data)
Writing byte 0A (?) - status OK
Recv: C4
Status 1 ...: x04
Recv: C0
Status 1 ...: x00
Recv: 57
Echo char ..: W (x57)
w3rjw Logfile.txt (2,573 bytes)

user51

2015-12-05 08:08

  ~0000683

Logfile attached:

w3rjw w3rjw OK

w3rjw w3rjw OK

w3rjw w failed just sends w

PD9FER

2018-08-06 01:50

updater   ~0005943

The replication steps are to open DM780 in its default state using Winkeyer for CW. The macro I’m sending is “KD6X ”. The first time I press the macro to send, it usually sends. However pressing it in semi-rapid succession such as when calling a DX station in a pile-up will fail. Many of the subsequent attempts to send the macro just never happen. Occasionally, the macro will work again after a number of seconds, but then only for a single time and then it will fail again.

The related failure is when trying to type using the “Break-in” capability by typing in the Transmit window pane. I press and activate the “Break-in” button above the Transmit pane, and then move the cursor into the Transmit pane and start typing. An occasional character will succeed and be sent, but for the most part this capability is not usable due to dropped characters.

Think this is related to this Mantis report

Issue History

Date Modified Username Field Change
2015-12-04 11:01 user51 New Issue
2015-12-05 08:06 user51 File Added: w3rjw Logfile.txt
2015-12-05 08:08 user51 Note Added: 0000683
2018-08-06 01:50 PD9FER Note Added: 0005943