View Issue Details

IDProjectCategoryView StatusLast Update
0001898Ham Radio DeluxeBugpublic2019-01-16 22:04
ReporterKB3NPHAssigned ToKB3NPH 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0001898: DM-780 ALE Malfunction
DescriptionWhen the Logbook is CLOSED, the ALE in the DM-780 module is grayed out, however, it will still accept data when you right-click on data in the RX pane and use the "context" menu to send the data to the ALE. This is generating support requests because the customer enters the data using the above method into the ALE then they CAN'T save the information to the logbook.
Steps To ReproduceRun HRD RC and DM-780 ONLY. Leave the Logbook closed

Right-click on a callsign in the RX Pane - Click on "Callsign" in the context menu and the callsign is transferred to the Call field in the Grayed-Out ALE

Highlight any text in the RX Pane and right-click - Select ANY ALE option from the context menu and the highlighted data will be sent to the Grayed-Out ALE.

See the attached image of the grayed out ALE with data entered in it using the method above.
TagsNo tags attached.
ModuleDM780
Sub-ModuleALE Window
Testing Beta Successful

Activities

KB3NPH

2016-04-11 04:53

administrator  

K7ZCZ

2018-10-22 18:17

manager   ~0006330

When I try this in Build 899, I find that the "Add" pushbutton is disabled. Seems like it was fixed somewhere along the way.

Please let me know if you can still repro it. Otherwise, we should close this issue.

KB3NPH

2018-11-05 13:16

administrator  

DM Log Bug.jpg (124,040 bytes)
DM Log Bug.jpg (124,040 bytes)

KB3NPH

2018-11-05 13:16

administrator   ~0006388

This is NOT resolved in 6.4.0.900. Anything that you right-click on in the DM-780 RX window can be sent to the selected field in the ALE when the Logbook is closed. See the image I added displaying this. This should not be able to be done with the Logbook closed.

K7ZCZ

2018-11-05 14:49

manager   ~0006389

In comparing the two screenshots, we see that in newer builds the user is given the visual cue of the "Add" button being disabled, in addition to all of the controls in the "Add Logbook Entry" pane being disabled.

What specific functionality is desired? Is the request that the data not be copied to the ALE pane at all? That an error be shown to the user in a message box? That the items in the context menu of the TX/RX window be disabled when the Logbook isn't connected? Maybe something else ...?

If the desired behaviour can be described, we can take a look at implementing it.

WA9PIE

2018-11-10 19:35

administrator   ~0006419

While some changes have been made in support of this item, it doesn't seem like there's agreement about its resolution. I'm moving forward with the current release without including this in the release notes.

Tim - please help clarify by answering Mike's questions. (Changing status to Feedback and assigning it to Tim.)

WA9PIE

2018-11-10 19:36

administrator   ~0006420

Need Tim to answer MB's questions.

WA9PIE

2018-12-06 15:26

administrator   ~0006535

During the triage call, we decided that - so long as there aren't any non-ALE items in this menu - we'll cause a prompt that tells the user that "This function is disabled when Logbook is not running. Would you like to launch it now?"

K7ZCZ

2018-12-06 15:39

manager   ~0006537

The context menu does have other items in it: there's a "Copy" command, which lets users copy text off the receiver (uh, "decode output"?) window and onto the clipboard. Given this, the triage-provided recommendation isn't exactly feasible.

We could remove the Copy command.

Or, we could ignore the fact that the Copy command is there and forge ahead.

Or, we could choose to do something else.

Offering to launch Logbook might not be appropriate wording. It might be that Logbook is already running, but DM780 can't communicate with it -- firewall problem, maybe it's not got a database open, maybe the IP Server is not turned on, and so on.

WA9PIE

2018-12-06 15:41

administrator   ~0006538

Let the context menu show only "Copy" as an active (ungray) item. Grey the others. If someone clicks it, then pop up the message box referenced in the last note.

K7ZCZ

2018-12-08 12:29

manager   ~0006549

It's not clear what "it" is in "if someone clicks it". It can't be disabled menu items, since disabled menu items can't be clicked. It can't be "Copy" because there's no reason to display a message box in that case.

Here's what I've implemented:

1) I added some red text to the "Add" tab of the ALE pane. It says that the logbook is disconnected. When the logbook is connected, the text disappears.

2) When the logbook is disconnected, the context menu items that copy data to a field are disabled in the context menu. The Copy command (which copies to the clipboard) remains enabled.

I believe these changes make the connection state of the logbook abundantly clear. If something else is desired, please provide a clear description and I can hook it up.

WA9PIE

2018-12-08 12:57

administrator   ~0006550

Does this change prevent the grey'd out fields from being populated then?

K7ZCZ

2018-12-08 16:03

manager   ~0006551

Yes, it does.

K7ZCZ

2018-12-08 16:05

manager   ~0006552

Sorry, I thought I resolved this already. This change set was checked in earlier today.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4524

WA9PIE

2018-12-22 00:24

administrator   ~0006795

Validated

Issue History

Date Modified Username Field Change
2016-04-11 04:53 KB3NPH New Issue
2016-04-11 04:53 KB3NPH File Added: 2016-04-11 05_51_09-Digital Master 780 - [BPSK-31].jpg
2017-03-08 00:07 WA9PIE Project 3 - Current Dev List => 1 - Backlog
2018-10-22 18:17 K7ZCZ Assigned To => K7ZCZ
2018-10-22 18:17 K7ZCZ Status new => resolved
2018-10-22 18:17 K7ZCZ Resolution open => unable to reproduce
2018-10-22 18:17 K7ZCZ Testing => Not Started
2018-10-22 18:17 K7ZCZ Note Added: 0006330
2018-11-04 07:48 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-11-04 07:49 K7ZCZ Fixed in Version => 6.4.0.900
2018-11-05 13:16 KB3NPH File Added: DM Log Bug.jpg
2018-11-05 13:16 KB3NPH Note Added: 0006388
2018-11-05 14:48 K7ZCZ Assigned To K7ZCZ => KB3NPH
2018-11-05 14:49 K7ZCZ Note Added: 0006389
2018-11-10 19:35 WA9PIE Note Added: 0006419
2018-11-10 19:36 WA9PIE Status resolved => feedback
2018-11-10 19:36 WA9PIE Resolution unable to reproduce => reopened
2018-11-10 19:36 WA9PIE Note Added: 0006420
2018-12-06 15:26 WA9PIE Note Added: 0006535
2018-12-06 15:39 WA9PIE Assigned To KB3NPH => K7ZCZ
2018-12-06 15:39 K7ZCZ Note Added: 0006537
2018-12-06 15:41 WA9PIE Note Added: 0006538
2018-12-08 12:29 K7ZCZ Note Added: 0006549
2018-12-08 12:57 WA9PIE Note Added: 0006550
2018-12-08 16:03 K7ZCZ Note Added: 0006551
2018-12-08 16:05 K7ZCZ Status feedback => resolved
2018-12-08 16:05 K7ZCZ Resolution reopened => fixed
2018-12-08 16:05 K7ZCZ Fixed in Version 6.4.0.900 =>
2018-12-08 16:05 K7ZCZ Note Added: 0006552
2018-12-09 15:48 K7ZCZ Fixed in Version => 6.5.0.132
2018-12-20 15:26 K7ZCZ Assigned To K7ZCZ => KB3NPH
2018-12-22 00:24 WA9PIE Status resolved => closed
2018-12-22 00:24 WA9PIE Testing Not Started => Beta Successful
2018-12-22 00:24 WA9PIE Note Added: 0006795
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe