View Issue Details

IDProjectCategoryView StatusLast Update
0001959Ham Radio DeluxeBugpublic2019-11-08 02:32
ReporterNT9EAssigned ToPD9FER 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindowsOS Version10, 7
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0001959: Data Controller comport is enabled when 1st installed
DescriptionCurrent versions of HRD has Auto connect enabled in the Data Controller window within DM.
Steps To ReproduceInstall HRD, go to DM and open Data Controller window.
TagsNo tags attached.
ModuleDM780
Sub-ModuleData
Testing Beta Successful

Relationships

has duplicate 0002960 closedK7ZCZ DM-780 Data Controller 
related to 0001780 closedK7ZCZ In Data Contoller Mode Wrong Mode Sent to TNC 
related to 0001781 closedK7ZCZ In Data Controller Mode, unable to reconnect to TNC after Disconnect 
related to 0001782 closedK7ZCZ In Data Controller Mode still shows normal SC in Waterfall 

Activities

KB3NPH

2017-03-12 10:31

administrator   ~0003139

Last edited: 2017-03-21 01:21

View 2 revisions

As of v6.4.0.638 this issue has not been resolved, or it was resolved and came back. It needs to be done as soon as possible so people don't get an error every time they install an update and start DM-780.

PD9FER

2017-07-26 12:48

viewer   ~0003746

Also getting annoyed with all the tickets coming in about this.

We should
A: disable the auto connect or
B: remove it at all until we get a good integration with TNC > 3rd party program and DM780

K7ZCZ

2019-06-06 13:26

administrator   ~0008002

I'm not able to reproduce this.

Here's what I tried:

1) Start up DM780
2) Use the "Data Controller" command in the "View" menu
3) The app now has a "Data Controller" pane. The "Connect" tab in that pane shows a list of COM ports.

For me, none are connected; maybe "enabled" means something different than "connected". But if so, it's not clear to me what it means.


If this is still a problem, please provide a detailed explanation and repro steps describing the issue. It might help to quote the error given when an update is installed and DM-780 is restarted.

PD9FER

2019-06-19 16:09

viewer   ~0008133

I would like to "as long this is a non functional feature" getting hidden to select it as an option
As long it is not defaulting to have Auto Connect selected.

In other words, do not give the customer the chance selecting Data controller.

PD9FER

2019-07-18 13:20

viewer   ~0008246

Why is Data Controller option still visible?
It confuses many customers and they still reporting DM-780 issues when the use the settings in that module.
Please Hide that option or remove it... rather yesterday then Tomorrow

KB3NPH

2019-08-01 10:12

administrator   ~0008315

This is still an occasional issue where the customer believes he has a TNC and sets the auto-connect option. This is going to continue being a problem either until we get Randy and Erik to get that software completed for the PK232 TNCs or decides it's not going to be completed and take this option out of DM-780 completely.

K7ZCZ

2019-08-01 14:56

administrator   ~0008321

In the 2019-08-01 call. Tim and Ferry explained that they wanted to make these changes:

1) Remove the "DataController" drop-down menu from the DM780 application
2) Remove the "Data Controller" button from the main tool bar in the DM780 application
3) Remove the "Data Controller" command from the View menu in the DM780 application
4) Disable "Data Controller" window from reappearing if it was saved in a previous layout

K7ZCZ

2019-08-09 12:30

administrator   ~0008347

When the four visible feature in note 8321 are removed, what becomes of the "Let The Data Controller key the radio via interface." option in the PTT page of the program options?

K7ZCZ

2019-08-09 16:46

administrator   ~0008350

Fixed in the 6.7 tree with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/5114

g3ucq

2019-09-23 06:02

viewer   ~0008603

I do not see Data Controller in the DM View drop down menu. Beta 6.7.0.227

PD9FER

2019-09-23 13:27

viewer   ~0008612

Confirmed

WA9PIE

2019-09-24 00:17

administrator   ~0008627

Validated

Issue History

Date Modified Username Field Change
2016-11-04 09:57 NT9E New Issue
2017-03-08 00:06 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2017-03-12 10:31 KB3NPH Note Added: 0003139
2017-03-21 01:21 KB3NPH Note Edited: 0003139 View Revisions
2017-07-26 12:48 PD9FER Note Added: 0003746
2018-11-30 09:26 K7ZCZ Relationship added related to 0002960
2019-02-27 20:26 WA9PIE OS Windoze => Windows
2019-02-27 20:26 WA9PIE Testing => Not Started
2019-06-06 13:21 K7ZCZ Summary Dat Controller comport is enabled when 1st installed => Data Controller comport is enabled when 1st installed
2019-06-06 13:26 K7ZCZ Assigned To => KB3NPH
2019-06-06 13:26 K7ZCZ Status new => resolved
2019-06-06 13:26 K7ZCZ Resolution open => unable to reproduce
2019-06-06 13:26 K7ZCZ Note Added: 0008002
2019-06-19 16:09 PD9FER Note Added: 0008133
2019-07-18 13:20 PD9FER Note Added: 0008246
2019-07-18 13:21 PD9FER Status resolved => assigned
2019-08-01 10:12 KB3NPH Note Added: 0008315
2019-08-01 14:56 K7ZCZ Note Added: 0008321
2019-08-01 14:56 K7ZCZ Assigned To KB3NPH => K7ZCZ
2019-08-09 12:30 K7ZCZ Note Added: 0008347
2019-08-09 12:30 K7ZCZ Assigned To K7ZCZ => PD9FER
2019-08-09 16:46 K7ZCZ Status assigned => resolved
2019-08-09 16:46 K7ZCZ Resolution unable to reproduce => fixed
2019-08-09 16:46 K7ZCZ Note Added: 0008350
2019-08-30 13:35 K7ZCZ Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2019-08-30 16:23 K7ZCZ Fixed in Version => 6.7.0.226
2019-09-23 06:02 g3ucq Note Added: 0008603
2019-09-23 13:27 PD9FER Note Added: 0008612
2019-09-24 00:17 WA9PIE Status resolved => closed
2019-09-24 00:17 WA9PIE Testing Not Started => Beta Successful
2019-09-24 00:17 WA9PIE Note Added: 0008627
2019-10-05 11:07 K7ZCZ Relationship replaced has duplicate 0002960
2019-10-05 11:07 K7ZCZ Relationship added related to 0001780
2019-10-05 11:08 K7ZCZ Relationship added related to 0001781
2019-10-05 11:09 K7ZCZ Relationship added related to 0001782
2019-11-08 02:16 WA9PIE Fixed in Version 6.7.0.226 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe