View Issue Details

IDProjectCategoryView StatusLast Update
00020275 - Closed w/o ActionBugpublic2018-06-05 17:36
ReporterPD9FERAssigned ToPD9FER 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Summary0002027: HRDSerialPortSvr.exe stays active as task
DescriptionHRDSerialPortSvr.exe keeps running as an process even after HRD is closed
Steps To ReproduceStart HRD
Close it
open Taskmgr
Look for HRDSerialPortSvr.exe to still be active
TagsHRDSerialPortSvr.exe
ModuleRig Control
Sub-ModuleRig Control
TestingNot Started

Relationships

related to 0002650 closedK7ZCZ Ham Radio Deluxe HRD Serial Port Server not able to Install / Run 

Activities

K7ZCZ

2017-06-08 22:16

administrator   ~0003205

This reproduces for me readily. Thanks for the report!

K7ZCZ

2017-08-17 18:58

administrator   ~0004013

Isn't this by design? The SerialPortSvr is the serial port service. Is it meant to be stopped when the application stops? (If so, why is it implemented as a service?)

PD9FER

2017-09-19 06:02

updater   ~0004242

Did some investigation,
It NEEDS to run when HRD is closed (for remote services)
For remote to work, HRD must be closed, else Comport conflicts are happening.

So this is by design.

Mike, you can close this one W/O further action.

KB3NPH

2018-01-03 09:09

administrator   ~0004296

Ticket #340340 Serial port server service indicates it is running. I can start and stop it from the services menu. However, in HRD when you attempt to connect to the server it says "service is not installed on this system.

K7ZCZ

2018-05-21 17:10

administrator   ~0005072

This application is a service; it is meant to run (and keep running) in the background.

Users who wish to stop it can do so with the sc command or the Services applet.

Issue History

Date Modified Username Field Change
2017-06-08 11:20 PD9FER New Issue
2017-06-08 11:20 PD9FER Tag Attached: HRDSerialPortSvr.exe
2017-06-08 22:16 K7ZCZ Assigned To => K7ZCZ
2017-06-08 22:16 K7ZCZ Status new => confirmed
2017-06-08 22:16 K7ZCZ Note Added: 0003205
2017-08-17 18:58 K7ZCZ Status confirmed => feedback
2017-08-17 18:58 K7ZCZ Sub-Module => (select)
2017-08-17 18:58 K7ZCZ Note Added: 0004013
2017-09-14 22:43 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-09-14 22:43 K7ZCZ Assigned To K7ZCZ => PD9FER
2017-09-18 00:14 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2017-09-19 06:02 PD9FER Note Added: 0004242
2018-01-03 09:09 KB3NPH Note Added: 0004296
2018-04-22 19:09 K7ZCZ Relationship added related to 0002650
2018-05-21 17:10 K7ZCZ Status feedback => resolved
2018-05-21 17:10 K7ZCZ Resolution open => no change required
2018-05-21 17:10 K7ZCZ Sub-Module (select) => Rig Control
2018-05-21 17:10 K7ZCZ Testing => Not Started
2018-05-21 17:10 K7ZCZ Note Added: 0005072
2018-05-23 09:49 K7ZCZ Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2018-06-05 17:36 WA9PIE Status resolved => closed
2018-06-05 17:36 WA9PIE Project 3 - Current Dev List => 5 - Closed w/o Action