View Issue Details

IDProjectCategoryView StatusLast Update
0002028Ham Radio DeluxeBugpublic2018-07-25 20:47
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version1703
Product Version 
Target VersionFixed in Version6.4.0.873 
Summary0002028: "New Window" command in Logbook list doesn't do anything
DescriptionThere's a "New Window" command in the context menu of the main Logbook app's log entry list that doesn't do anything.

Should it be hooked up to something in particular? Maybe it should just be removed. What was it meant to do?
Steps To Reproduce1) Start the Logbook
2) Right-click on any item in the log list
3) This results in a context menu. Choose "New Window", which is the first entry in the context menu
4) Nothing happens.

Additional InformationLooks like this menu item fires ID_LOGBOOK_NEW, which calls the OnLogbookNew() method in the CHRDLogbookView class.

The implementation of that method posts an ID_FILE_NEW command message to the application's main frame window.

ID_FILE_NEW is handled by CHRDLogbookApp's OnFileNew() method, which has an empty implementation.

Looks like there might have been a handler for this command message in the Logbook CMainFrame class. The map entry for that handler is commented out. There's no implementation, though there is a declaration for the handler in the header file for the class.

Can this be cleaned up? Or was it meant to do something?

TagsNo tags attached.
ModuleLogbook
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

Activities

WA9PIE

2017-07-08 23:11

administrator   ~0003599

I think what this was supposed to do is...

Open a new ALE... with the callsign from the selected log entry... but now read the frequency and mode from the radio... date/time from the computer.

WA9PIE

2018-06-13 23:45

administrator   ~0005291

Last edited: 2018-06-13 23:46

View 2 revisions

If it's simple enough to do, I'd kill this. You're right. It does nothing and it's not clear what it was intended to do.

K7ZCZ

2018-06-22 08:37

manager   ~0005381

This shelf is out for review. https://hrdsoftware.visualstudio.com/HRD/_versionControl/shelveset?ss=Logbook%20New%20Window%20cleanup%20%28Mantis%202028%29%3Bmikeblas%40msn.com

K7ZCZ

2018-06-24 21:26

manager   ~0005464

fixed with this changeset:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4183

g3ucq

2018-06-28 11:45

viewer   ~0005519

If this is referring to the Logbook/File/open logbook/select database window then this is fixed

WA9PIE

2018-06-30 00:48

administrator   ~0005570

It works for me!

Issue History

Date Modified Username Field Change
2017-06-09 01:06 K7ZCZ New Issue
2017-07-08 23:11 WA9PIE Note Added: 0003599
2018-06-13 23:45 WA9PIE Note Added: 0005291
2018-06-13 23:46 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-06-13 23:46 WA9PIE Assigned To => K7ZCZ
2018-06-13 23:46 WA9PIE Status new => assigned
2018-06-13 23:46 WA9PIE Note Edited: 0005291 View Revisions
2018-06-22 08:37 K7ZCZ Note Added: 0005381
2018-06-24 21:26 K7ZCZ Status assigned => resolved
2018-06-24 21:26 K7ZCZ Resolution open => fixed
2018-06-24 21:26 K7ZCZ Sub-Module => Appearance/UI
2018-06-24 21:26 K7ZCZ Testing => Not Started
2018-06-24 21:26 K7ZCZ Note Added: 0005464
2018-06-28 10:07 K7ZCZ Fixed in Version => 6.4.0.858
2018-06-28 11:45 g3ucq Note Added: 0005519
2018-06-30 00:48 WA9PIE Note Added: 0005570
2018-06-30 00:48 WA9PIE Status resolved => closed
2018-06-30 00:48 WA9PIE Description Updated View Revisions
2018-06-30 00:48 WA9PIE Steps to Reproduce Updated View Revisions
2018-06-30 00:48 WA9PIE Additional Information Updated View Revisions
2018-06-30 00:48 WA9PIE Testing Not Started => Beta Successful
2018-07-23 22:52 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-07-24 15:35 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2018-07-25 08:00 WA9PIE Fixed in Version 6.4.0.858 => 6.4.0.873
2018-07-25 20:47 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe