View Issue Details

IDProjectCategoryView StatusLast Update
0002114Ham Radio DeluxeBugpublic2018-06-13 09:13
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version1703
Product Version6.4.0.659 
Target VersionFixed in Version6.4.0.843 
Summary0002114: Uninstall process has confusing UI
DescriptionUninstalling HRD shows prompts that stay "install" and "configure", which is confusing because the user expects to be UN-installing the software.

The uninstaller further shows the EULA and asks the user to agree to it, asks for a target directory, and asks if the installation should be done for all users of the computer or just the current user.
Steps To Reproduce1) Install HRD
2) Uninstall it with Add/Remove programs in the control panel
BUG#1) Observe that the UI shows the EULA, asks for a target directory, asks about user scope, and references "installing".

TagsNo tags attached.
ModuleAll
Sub-ModuleInstall
Testing Beta Successful

Relationships

related to 0002761 closedWA9PIE Uninstall process shows "Publisher Unknown" (indicating that setupHRD.exe is unsigned) 

Activities

K7ZCZ

2018-05-20 10:39

manager   ~0005067

Resolved with these checkins

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4126
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4127


The uninstall now looks like an uninstall; it doesn't show the EULA, talk about installation, or prompt for an installation location, ...

WA9PIE

2018-05-29 16:40

administrator   ~0005145

I tested the uninstaller (on a clean VM) and it is much simpler and things that were unnecessary are removed.

Question, however...

On install, the publisher correctly shows HRD Software, LLC

On uninstall, the publisher says "Unknown". Is this the correct behavior? (Image attached)

K7ZCZ

2018-05-29 20:09

manager   ~0005146

More information is needed:

What did "Show more details" show?

What specific executable was running? You can find the executable by using Process Manager, and that will reveal a path to the file. Capturing the file would help; at the very least, finding the version and signature information from that file would be helpful.

g3ucq

2018-06-01 03:44

viewer   ~0005164

The uninstall is very fast, almost instantaneous. The HRD folder is still left with a few files in it.
Also files left at C:\Users\HRD\AppData\Roaming\HRDLLC.

K7ZCZ

2018-06-01 09:05

manager   ~0005165

The files remaining in the HRD folder should be removed after a reboot. If not, please take the time to enumerate and describe the files in your report; it would be useful to have the names and sizes.

It's by-design to not remove user data.

WA9PIE

2018-06-05 13:56

administrator   ~0005203

I'm re-testing this.

John - install scripts only remove things that the install script created. Many things get created on "first-run". These things in the registry and in certain folders won't be removed by the installer (this includes activation key).

WA9PIE

2018-06-05 14:07

administrator  

ExactStepsTaken.mht (2,429,701 bytes)

WA9PIE

2018-06-05 14:07

administrator   ~0005204

On re-test, the same result. That is - the installer removes the program just fine. It's cleaner and it's easier to understand.

(These tests ran on a clean Windows 10 VM that had never had anything installed on it except Windows updates.)

My finding is related to the uninstall dialog saying "Publisher Unknown" when setupHRD.exe was running the uninstall.

In the attached files, you'll find a file that contains all the steps taken with images at each step... with one exception. Problem Steps Recorder doesn't snag the image when the uninstall script goes into UAC. So the additional image (PublisherUnknown) happened at step 10.5.

We may not fail this change because of this. But it's worth knowing if there's something we should change so that the publisher of setupHRD.exe is not "Unknown" when the uninstall ran. (The publisher was known when the install occurred.)

PublisherUnknown.PNG (41,329 bytes)
PublisherUnknown.PNG (41,329 bytes)

WA9PIE

2018-06-06 18:42

administrator   ~0005214

I've tested this twice with the same results. I'm going to pass this. If we seek to solve the "Publisher Unknown" problem with setupHRD.exe later, we can open a new bug report for that.

Issue History

Date Modified Username Field Change
2017-07-08 23:56 K7ZCZ New Issue
2017-07-08 23:57 K7ZCZ Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2018-05-20 10:39 K7ZCZ Assigned To => K7ZCZ
2018-05-20 10:39 K7ZCZ Status new => resolved
2018-05-20 10:39 K7ZCZ Resolution open => fixed
2018-05-20 10:39 K7ZCZ Testing => Not Started
2018-05-20 10:39 K7ZCZ Note Added: 0005067
2018-05-20 10:39 K7ZCZ Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2018-05-26 23:28 K7ZCZ Fixed in Version => 6.4.0.842
2018-05-29 16:40 WA9PIE File Added: UninstallPublisherUnknown.PNG
2018-05-29 16:40 WA9PIE Note Added: 0005145
2018-05-29 20:09 K7ZCZ Note Added: 0005146
2018-06-01 03:44 g3ucq Note Added: 0005164
2018-06-01 09:05 K7ZCZ Note Added: 0005165
2018-06-05 13:56 WA9PIE Note Added: 0005203
2018-06-05 14:07 WA9PIE File Added: ExactStepsTaken.mht
2018-06-05 14:07 WA9PIE File Added: PublisherUnknown.PNG
2018-06-05 14:07 WA9PIE Note Added: 0005204
2018-06-06 18:42 WA9PIE Note Added: 0005214
2018-06-06 18:42 WA9PIE Status resolved => closed
2018-06-06 18:42 WA9PIE Testing Not Started => Beta Successful
2018-06-07 12:30 WA9PIE Issue cloned: 0002761
2018-06-07 12:30 WA9PIE Relationship added related to 0002761
2018-06-13 09:13 WA9PIE Fixed in Version 6.4.0.842 => 6.4.0.843
2018-06-13 09:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe