View Issue Details

IDProjectCategoryView StatusLast Update
00021523 - Current Dev ListBugpublic2019-07-02 11:34
Reporterg3ucqAssigned ToK7ZCZ 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0002152: Bandscope crashes Rig Control
DescriptionWith only Rig Control running ( or other options, it does not matter)
Rig Control crashes/stops working when the Bandscope is used.
This was reported by a user in the Community Forum who says this has been happening since 2011.
I can confirm that Bandscope does crash Rig Control.
Steps To ReproduceHRD Rig Control/Tools/Bandscope.
Bandscope may crash Rig Control by doing nothing but changing the scan width data will crash Rig Control.
Even moving the Bnadscope window may crash Rig Control.
TagsNo tags attached.
ModuleRig Control
Sub-Module(select)
TestingNot Started

Relationships

related to 0002641 new 3 - Current Dev List DM780: debugging symbols not available for Olectra Chart DLL, used in Band Scope 
related to 0002315 new 3 - Current Dev List FT-891 Setting bandscope limits crashes HRD 
related to 0002734 closedPD9FER 4 - Closed w/o Action Rig Controll Crashes on changing Bands 

Activities

g3ucq

2017-07-22 11:31

updater   ~0003711

This what the user posted in the Rig Control Forum

"Last week they gave me instructions to uninstall HRD, with various things to do including going into the registry to remove HRD remnants in there. It is really frustrating that these guys do not seem capable of helping me with this problem. "

g3ucq

2017-07-22 11:57

updater   ~0003712

I just loaded v5 using my 2nd OS (dual boot) and Bandscope again crashed Rig Control so this has been a problem for a very long time.

K7ZCZ

2017-07-23 01:50

administrator   ~0003715

Sorry, but I'm not able to repro this. I'm using HRD 664.

I tried while connecting to my Yaesu FT-450D (a real radio). I've also tried while connected to the DemoMatic FT-450D.

I tried:

1) Undocking the Band scope window and moving it around
2) Docking it again
3) "Playing" the band scope, so it scans on its own
4) Clicking around in the band scope
5) Using the options to set the step width (maybe this is what you mean by "changing the step width data"?)

Maybe there are some details missing from your repro steps. Which radio are you using? Can you enumerate the specific steps you get before a crash? Can you collect a minidump file?

g3ucq

2017-07-23 03:12

updater   ~0003716

Fresh boot of the PC. Ran HRD which loaded the Logbook and DM780. RC connected to my IC-7300.
Then ran Bandscope from Tools/Bandcsope and got an immediate RC crash/stopped working.
I used the Visual Studio option and the message was :-
"An unhandled Win32 exception occurred in Hamradiodeluxe.exe(8632)"
I then ran the Visual Studio debugger and got this message :-
"Unhandled exception at 0x00941214 (olch2d32.dll) in HamRadioDeluxe.exe: 0xC000041D: An unhandled exception was encountered during a user callback."
I reloaded HRD and the problem reoccurred. HTH

g3ucq

2017-07-23 03:36

updater   ~0003717

With HRD, Logbook and DM780 all running well I connected to the Demo radio and then loaded the Bandscope.
I got an immediate crash as above.

K7ZCZ

2017-07-23 08:39

administrator   ~0003720

Sorry; resolved the wrong issue. Now I'm trying to recover.

K7ZCZ

2017-07-23 08:56

administrator   ~0003722

Thanks for the report!

I'm sorry, but I can't reproduce this problem using the steps you provide. I'm eager to fix this issue, but until I can reproduce it or collect enough information about the details of the crash, then I'm not able to do so.

Here are some follow-up questions which might help:

Your response implies that you have Visual Studio installed. Is that true?

Are you using any non-default program options?

It may help to know which versions of OLCH2D32.DLL you've got installed on yours system, and in particular, which one is loaded by DM780 when it crashes.

It might also help to indicate which build of Ham Radio Deluxe you're using. I don't see that information here.

It couldn't hurt to share which version of Windows you're using.

You say that you connect to "the DemoRadio", but the product supports several such radios; can you please identify one specifically?

g3ucq

2017-07-23 13:05

updater   ~0003724

Apologies for not giving the complete information.
I do not remember installing Visual Studio but it loads when required.
If you mean non-default options in HRD, No not that I am aware of. If you mean in Visual Studio, I don't know enough of the program to change anything :-)
Image attached of the OLCH2D32.dll details.
Ham Radio Deluxe v644
Windows 10 64 bit.
Demoradio TS2000

This afternoon I went to my radio club at Poldhu (Marcon site). They have HRD v5 and the Bandscope did not crash Rig Control despite my best efforts to. It was running with Demomatic TS450.
HTH

OLCH2D32.JPG (45,801 bytes)
OLCH2D32.JPG (45,801 bytes)

g3ucq

2017-07-23 13:08

updater   ~0003725

For v644 read v664.

K7ZCZ

2017-08-01 10:26

administrator   ~0003810

I'm still not able to reproduce this. Please provide reliable repro information, or upload a minidump file from a crash you've encountered. Without this information, I'm afraid there's nothing I can do for the issue.

g3ucq

2017-08-01 11:24

updater   ~0003812

Minidump attached MIke
HTH

Bandscope.dmp (98,297 bytes)

K7ZCZ

2017-08-01 20:48

administrator   ~0003815

Thanks, UCQ. Looks like this crash is occuring in our graphing library, and we don't have debug symbols for that. Thus, at first, this is a build system bug: we should have a copy of the PDB for the OLCHD32.DLL.

The stack to the crash I get just indicates that the message pump in Rig Control is passing a message long to a window proc in the DLL, and the DLL falls over:

     olch2d32.dll!100213ae() Unknown
     [Frames below may be incorrect and/or missing, no symbols loaded for olch2d32.dll]
     olch2d32.dll!10020528() Unknown
     olch2d32.dll!10020263() Unknown
     olch2d32.dll!10020079() Unknown
     olch2d32.dll!10051da3() Unknown
     [External Code]
> HamRadioDeluxe.exe!CWnd::OnWndMsg(unsigned int message, unsigned int wParam=101, long lParam=0, long * pResult=0x0018f5b8) Line 2440 C++
     HamRadioDeluxe.exe!CWnd::WindowProc(unsigned int message=275, unsigned int wParam=101, long lParam=0) Line 2094 C++
     HamRadioDeluxe.exe!AfxCallWndProc(CWnd * pWnd=0x04ec1524, HWND__ * hWnd=0x001d10a0, unsigned int nMsg=275, unsigned int wParam=101, long lParam=0) Line 285 C++
     HamRadioDeluxe.exe!AfxWndProc(HWND__ * hWnd=0x001d10a0, unsigned int nMsg=275, unsigned int wParam=101, long lParam=0) Line 434 C++
     [External Code]
     HamRadioDeluxe.exe!AfxInternalPumpMessage() Line 183 C++
     HamRadioDeluxe.exe!AfxWinMain(HINSTANCE__ * hInstance=0x00f46931, HINSTANCE__ * hPrevInstance=0x00000001, wchar_t * lpCmdLine=0x00000000, int nCmdShow=1636388) Line 47 C++
     [External Code]


I'll see if I can get a PDB built and checked in, then I'll have to ask you to reproduce this problem with a newer build and we can go from there.

g3ucq

2018-03-30 15:30

updater   ~0004602

Using .797 I am now unable to force the Bandscope to crash.

g3ucq

2018-03-31 04:58

updater   ~0004607

Update. I loaded HRD Rig Control, Logbook, DM780 and then Bandscope. I had altered nothing in any module.
 Rig Control immediately crashed and two mini dump files were created.

G3UCQ_HamRadioDeluxe_20180331_095021.zip (103,153 bytes)
G3UCQ_HamRadioDeluxe_20180331_095018.zip (93,489 bytes)

g3ucq

2018-04-02 09:36

updater   ~0004623

After your request for a video I have installed OBS Studio to record screen activity.
The first time I ran HRD and added Bandscope the Rig Control crashed creating 2 mini dump files.
Files attached and hope this solves it.

G3UCQ_Rig Control crash.zip (9,326,627 bytes)
G3UCQ_HamRadioDeluxe_20180402_141632.zip (108,329 bytes)
G3UCQ_HamRadioDeluxe_20180402_141631.zip (99,589 bytes)

g3ucq

2018-04-07 03:29

updater   ~0004740

No problems now.

g3ucq

2019-03-07 04:32

updater   ~0007615

Confirm fixed.

K7ZCZ

2019-07-01 16:39

administrator   ~0008186

John says this is working well in current builds

g3ucq

2019-07-02 11:34

updater   ~0008190

Just tested the Bandscope again and although it causes no crashing problems, control of the cursor seems hit and miss.
Sometimes it can be stopped and reversed other times not. Sometimes the control buttons would not respond until the scan reached the end.
Is it something used regularly? I never do especially with the waterfalls now so prominent.

Issue History

Date Modified Username Field Change
2017-07-22 11:29 g3ucq New Issue
2017-07-22 11:31 g3ucq Note Added: 0003711
2017-07-22 11:57 g3ucq Note Added: 0003712
2017-07-22 22:12 K7ZCZ Module (select) => Rig Control
2017-07-22 22:12 K7ZCZ Testing => Not Started
2017-07-23 01:50 K7ZCZ Assigned To => K7ZCZ
2017-07-23 01:50 K7ZCZ Status new => feedback
2017-07-23 01:50 K7ZCZ Note Added: 0003715
2017-07-23 03:12 g3ucq Note Added: 0003716
2017-07-23 03:12 g3ucq Status feedback => assigned
2017-07-23 03:36 g3ucq Note Added: 0003717
2017-07-23 08:35 K7ZCZ Status assigned => resolved
2017-07-23 08:35 K7ZCZ Resolution open => fixed
2017-07-23 08:39 K7ZCZ Status resolved => new
2017-07-23 08:39 K7ZCZ Resolution fixed => reopened
2017-07-23 08:39 K7ZCZ Note Added: 0003720
2017-07-23 08:56 K7ZCZ Note Added: 0003722
2017-07-23 13:05 g3ucq File Added: OLCH2D32.JPG
2017-07-23 13:05 g3ucq Note Added: 0003724
2017-07-23 13:08 g3ucq Note Added: 0003725
2017-08-01 10:26 K7ZCZ Status new => feedback
2017-08-01 10:26 K7ZCZ Note Added: 0003810
2017-08-01 11:24 g3ucq File Added: Bandscope.dmp
2017-08-01 11:24 g3ucq Note Added: 0003812
2017-08-01 11:24 g3ucq Status feedback => assigned
2017-08-01 20:48 K7ZCZ Note Added: 0003815
2018-03-30 11:24 K7ZCZ Relationship added related to 0002641
2018-03-30 15:30 g3ucq Note Added: 0004602
2018-03-31 04:58 g3ucq File Added: G3UCQ_HamRadioDeluxe_20180331_095021.zip
2018-03-31 04:58 g3ucq File Added: G3UCQ_HamRadioDeluxe_20180331_095018.zip
2018-03-31 04:58 g3ucq Note Added: 0004607
2018-04-02 09:36 g3ucq File Added: G3UCQ_Rig Control crash.zip
2018-04-02 09:36 g3ucq File Added: G3UCQ_HamRadioDeluxe_20180402_141632.zip
2018-04-02 09:36 g3ucq File Added: G3UCQ_HamRadioDeluxe_20180402_141631.zip
2018-04-02 09:36 g3ucq Note Added: 0004623
2018-04-07 03:29 g3ucq Note Added: 0004740
2018-04-13 10:22 WA9PIE Severity major => crash
2018-04-13 10:23 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-05-28 08:55 K7ZCZ Relationship added related to 0002315
2018-12-13 16:00 K7ZCZ Relationship added related to 0002734
2019-03-07 04:32 g3ucq Note Added: 0007615
2019-07-01 16:39 K7ZCZ Status assigned => resolved
2019-07-01 16:39 K7ZCZ Note Added: 0008186
2019-07-02 11:34 g3ucq Note Added: 0008190