View Issue Details

IDProjectCategoryView StatusLast Update
0002169Ham Radio DeluxeBugpublic2018-05-13 15:26
ReporterKB3NPH 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0002169: Non Sticky propagation track tab in ALE
DescriptionTicket #388027
Another long standing issue:
Propagation Tracking tab in the logbook ALE will go away after a period of time. After 15-20 minutes the "Track" checkbox will uncheck and A, K and Solar flux data will no longer be tracked and eventually go blank. That means no stored data in log (I track Prop data in log with every contact) It might happen when HRD goes out for new propagation data ...

Propagation data tracks forever in the DM-780 ALE window ...
Additional InformationRon posted 07/31/2017 11:28 AM
For this test it took ~28 minutes to "untrack" .... HRD just running in background, doesn't matter what you are doing ..Seems to "time out' .... Although there is 'data' showing after the 'uncheck', that data will go away on ALE activity such as a new contact ...

The only way to get tracking back is to re-check the "track" box or "Tracking", "Propagation tab

My thought is something that is timed is triggering the reset ... I'm pretty sure HRD goes out periodically and gets new space data (every 30 minutes ?) ... Could that be the reset trigger? I would look there first ...

Flux/A/K continues to track on the second page of the DM-780 ALE ....

TagsNo tags attached.
ModuleLogbook
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

Activities

KB3NPH

2017-07-31 12:38

administrator  

n4kit

2017-08-18 12:50

viewer   ~0004052

Confirmed on build 779/780.

K7ZCZ

2018-05-08 13:57

manager   ~0004975

Here is a link to the ticket:
https://support.hamradiodeluxe.com/scp/tickets.php?id=10892

K7ZCZ

2018-05-09 10:53

manager   ~0004980

I'm not perfectly sure I understand what "non sticky" means here. I can't reproduce any problem of the "Track" setting in the propagation tab persisting across instances of the ALE. If there's an sisue here, please open a separate mantis isuse with a solid description and some repro steps.

I'm able to reproduce the other issue, which involves the propagation track setting turning itself off after the first propagation update. That's fixed.

I also noticed that the "Propagation" choice in the "Tracking" menu of the ALE did not influence the track setting; it would reflect the setting of thet rack checkbox, but itself wouldn't change it. I've fixed that.

K7ZCZ

2018-05-09 10:54

manager   ~0004981

fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4112

PD9FER

2018-05-13 04:49

viewer   ~0005029

Working fine now

Issue History

Date Modified Username Field Change
2017-07-31 12:38 KB3NPH New Issue
2017-07-31 12:38 KB3NPH File Added: Propagation Tracking In ALE.jpg
2017-08-16 17:14 WA9PIE Sub-Module (select) => Appearance/UI
2017-08-16 17:14 WA9PIE Module (select) => DM780
2017-08-16 17:14 WA9PIE Testing Not Started => Alpha Failed
2017-08-17 12:50 WA9PIE Testing Alpha Failed => Not Started
2017-08-18 12:50 n4kit Note Added: 0004052
2017-08-18 12:51 n4kit Status new => confirmed
2017-08-18 12:51 n4kit Module DM780 => Logbook
2018-05-08 13:57 K7ZCZ Note Added: 0004975
2018-05-09 10:53 K7ZCZ Note Added: 0004980
2018-05-09 10:54 K7ZCZ Assigned To => K7ZCZ
2018-05-09 10:54 K7ZCZ Status confirmed => resolved
2018-05-09 10:54 K7ZCZ Resolution open => fixed
2018-05-09 10:54 K7ZCZ Testing Not Started => Not Started
2018-05-09 10:54 K7ZCZ Note Added: 0004981
2018-05-09 10:55 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-05-09 23:28 K7ZCZ Fixed in Version => 6.4.0.839
2018-05-13 04:49 PD9FER Note Added: 0005029
2018-05-13 11:52 WA9PIE Status resolved => closed
2018-05-13 11:52 WA9PIE Testing Not Started => Beta Successful
2018-05-13 15:25 WA9PIE Fixed in Version 6.4.0.839 => 6.4.0.840
2018-05-13 15:26 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe