View Issue Details

IDProjectCategoryView StatusLast Update
0002187Ham Radio DeluxeBugpublic2018-03-14 10:59
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version6.4.0.787 
Summary0002187: Favorites in Rig Control are gone
DescriptionBuild RC 671
User defined favorites ore gone since this build.

Steps To ReproduceOpen Rig Control
Click Favorites > Manager
All custom ones are gone.
Additional Informationhttps://support.ham-radio-deluxe.com/scp/tickets.php?id=11011
TagsNo tags attached.
ModuleRig Control
Sub-ModuleAppearance/UI
Testing N/A

Relationships

duplicate of 0002189 closedK7ZCZ Rig Control: "Favorites" box went missing from "Selection" bar 

Activities

PD9FER

2017-08-06 16:55

viewer   ~0003927

Here 2 screenshots, one from 664 (working) and one from 671 (Not working)

Working pre 671.png (76,269 bytes)
Working pre 671.png (76,269 bytes)
Not working 671.png (69,737 bytes)
Not working 671.png (69,737 bytes)

K7ZCZ

2017-08-06 21:53

manager   ~0003930

So far, I'm unable to reproduce this.

In 671, I'm able to:

1) Start Rig Control
2) Add frequencies to my favorites list
3) Exit the app
4) Restart the app
5) See the same frequencies in my favorites list again

K7ZCZ

2017-08-06 22:07

manager   ~0003931

Outside of Mantis, PD9FER said that this bug is exercised by upgrading, not by opening and saving values in the same version.

So, I invented these steps:

1) Install HRD 647
2) Create a few additional favorite frequencies, including a couple folders
3) Close the app
4) Upgrade to HRD 671
5) Open the Favorites Manager
6) The favorites I added in Step #2 are there

I'm not able to reproduce the reported issue.

K7ZCZ

2017-08-06 22:17

manager   ~0003932

The linked ticket is at least partially in a language that I don't speak. The original communication says that the favorites aren't visible, but attaches a screenshot that includes non-default favorites. (There are 84 or 85 favorites in a new install; the screenshot shows 135. Further, the screenshot shows "PSK,digital", "FT8", and "JT65" folders; HRD doesn't have default favorites folders with those names.

Maybe I'm missing some details in the ticket, but how was the conclusion made that the favorites weren't being opened from their file? What favorites are expected to be seen in this list that aren't there, and what do we know about them?

PD9FER

2017-08-07 09:41

viewer   ~0003936

Some notes:

Install any version prior 647
Add some custom favorites
Install 671
Look if the added favorites appear

I have tried it on 2 different computers.
One does replicate, the other doesn't
So not quite sure where to look at.

KB3NPH

2017-08-07 10:30

administrator   ~0003937

I have confirmed that the "Favorites" bar is completely missing from 671. See the attached images of 647 and 671

647 Favorites.jpg (51,389 bytes)
647 Favorites.jpg (51,389 bytes)
671 Favorites.jpg (70,880 bytes)
671 Favorites.jpg (70,880 bytes)

K7ZCZ

2017-08-07 11:06

manager   ~0003938

A fix for the missing "Favorites" bar has already been coded; see Mantis 2189.

This issue is about the Favorites content itself being missing from the favorites manager window. I'm unable to reproduce that problem.

n4kit

2017-08-07 13:35

viewer   ~0003941

Missing favorites data / favorites not being saved (as opposed to the list missing in the UI) is usually caused by a Read Only flag set on the C:\Users\user_name\AppData\Roaming\HRDLLC\Ham Radio Deluxe\HRD Favourites 01.txt.xml or HRD Favourites 01.txt files

Why we have 2 favorites files with the same data I don't know - the test data I just did wrote to both files.

K7ZCZ

2017-08-07 22:44

manager   ~0003943

Thanks for that, but as far as I can tell, the problem isn't favorites data not being saved -- it's that favorites data isn't being loaded; and only after an upgrade, and only on some machines.

Or do you mean to report that you've found a different bug, where favorites data isn't being saved correctly because you've found that the files in question have been marked read-only?

n4kit

2017-08-07 22:51

viewer   ~0003944

Yeah, sorry Mike, I fear I clouded the issue more than helped... no, not a new bug issue.

My only point was that, from way back when when I was doing support with Tim, 9 times out of 10 when a user had issues with Favorites (or DM-780 Macros for that matter) it turned out to be a read-only flag on an xml file.

Another thought that might be... if the user's previously modified favorites file was somehow deleted, the new installation would write a new default - making it appear that the user's favorites had "disappeared"...

K7ZCZ

2017-08-08 02:45

manager   ~0003947

It's possible that the file is deleted and replaced with a file containing a default set, yes. Do we have any evidence that is the case?

n4kit

2017-08-08 09:08

viewer   ~0003950

In short, no I don't have any evidence...
I did an install of .671 on the shack computer last night and checked the HRD Favourites 01.txt.xml and HRD Favourites 01.txt files before and after. Neither was overwritten by the install.
Is it possible that an uninstall would remove these files? i.e. if a user did an uninstall before installing the new version?

WA9PIE

2017-08-16 16:00

administrator   ~0003992

Wasn't this resolved in 777 and shipped in 780?

K7ZCZ

2017-08-16 18:05

manager   ~0003998

I'm not positive. The report was that the custom favorites were removed from the system altogether -- that is, the user's storage of their favorite frequencies was lost. I'm unable to reproduce that behavior, but Ferry says his is (on one of two computers).

The issue that was fixed for sure was different; 0002189 describes the part of the favorites UI going missing because of a bad change I had made.

I've commented on the ticket with the customer to see if he can confirm if the issue was resolved or not from his observation.

PD9FER

2017-08-17 01:58

viewer   ~0004006

Issue is resolved

K7ZCZ

2017-08-17 15:13

manager   ~0004011

Yep. Per the customer comments in the ticket, this actually a duplicate of 0002189

Issue History

Date Modified Username Field Change
2017-08-06 14:33 PD9FER New Issue
2017-08-06 16:44 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-08-06 16:55 PD9FER File Added: Working pre 671.png
2017-08-06 16:55 PD9FER File Added: Not working 671.png
2017-08-06 16:55 PD9FER Note Added: 0003927
2017-08-06 21:53 K7ZCZ Note Added: 0003930
2017-08-06 22:07 K7ZCZ Note Added: 0003931
2017-08-06 22:17 K7ZCZ Assigned To => K7ZCZ
2017-08-06 22:17 K7ZCZ Status new => feedback
2017-08-06 22:17 K7ZCZ Note Added: 0003932
2017-08-07 09:41 PD9FER Note Added: 0003936
2017-08-07 09:41 PD9FER Status feedback => assigned
2017-08-07 10:30 KB3NPH File Added: 647 Favorites.jpg
2017-08-07 10:30 KB3NPH File Added: 671 Favorites.jpg
2017-08-07 10:30 KB3NPH Note Added: 0003937
2017-08-07 11:06 K7ZCZ Note Added: 0003938
2017-08-07 13:35 n4kit Note Added: 0003941
2017-08-07 22:44 K7ZCZ Note Added: 0003943
2017-08-07 22:51 n4kit Note Added: 0003944
2017-08-08 02:45 K7ZCZ Note Added: 0003947
2017-08-08 09:08 n4kit Note Added: 0003950
2017-08-16 16:00 WA9PIE Note Added: 0003992
2017-08-16 18:05 K7ZCZ Note Added: 0003998
2017-08-16 18:11 K7ZCZ Relationship added related to 0002189
2017-08-17 01:58 PD9FER Note Added: 0004006
2017-08-17 15:13 K7ZCZ Relationship replaced duplicate of 0002189
2017-08-17 15:13 K7ZCZ Note Added: 0004011
2017-08-17 18:48 K7ZCZ Status assigned => resolved
2017-08-17 18:48 K7ZCZ Resolution open => duplicate
2017-08-17 18:48 K7ZCZ Testing => N/A
2017-08-17 18:48 K7ZCZ Status resolved => closed
2018-03-14 10:54 WA9PIE Fixed in Version => 6.4.0.787
2018-03-14 10:59 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe