View Issue Details

IDProjectCategoryView StatusLast Update
0002226Ham Radio DeluxeBugpublic2018-04-07 20:50
ReporterKB3NPH 
Assigned ToKB3NPH 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version6.4.0.798 
Summary0002226: FT-991 - DM-780 Crash when changing radio modes
DescriptionTicket# 131361
Customer reports that changing mode in V6.4.0.780, using Radio Pane in DM-780 from USB to DATA U, the DM-780 crashes with an MFC Error. Did a remote with the customer and verified the problem. Attempted to recreate the DM-780 folder in the HRDLLC but still had same issue. Deleted the DM-780 registry key in Current User\Software\Amateur Radio\ registry key and re-ran DM-780. Still had MFC crash when changing mode from USB to DATA U.

All modes change properly from within the Rig Control panel. Only issue is when attempting to change modes from the Radio Panel in DM-780.
TagsNo tags attached.
ModuleDM780
Sub-ModuleRadio Support
TestingNot Started

Relationships

related to 0002320 closedK7ZCZ DM780 crashes when selecting pulldown 

Activities

K7ZCZ

2017-08-22 10:56

manager   ~0004072

A minidump would help significantly, as I have no access to this radio model

PD9FER

2017-10-03 04:18

viewer   ~0004270

Other user. same radio .
https://support.ham-radio-deluxe.com/scp/tickets.php?id=11974
There are more at the Forums https://forums.ham-radio-deluxe.com/forum/hrd-6-x-peer-support-forums/hrd-6-2-digital-master/43616-crash-hrd-digital-master

Minidump attached

DigitalMaster_20171003_050130.zip (12,460,848 bytes)

PD9FER

2018-01-14 04:52

viewer   ~0004304

New report: Ticket #349688

KB3NPH

2018-02-09 07:57

administrator   ~0004309

Ticket #491653 is reporting very same issue as indicated in this bug ticket. I have received a mini-dump file which I have placed in Google Drive\HRD Software\Dumps\BR0002226_DigitalMaster_20180209_024033.mdmp

Hope this gives some insight into what is going on with these FT-991 radios and DM

PD9FER

2018-02-21 08:25

viewer   ~0004313

I made a Dupe per accident...
Mantis ID 0002320

K7ZCZ

2018-03-17 11:27

manager   ~0004502

This is a duplicate ... I'm focusing on the issue that has the best notes and minidump

WA9PIE

2018-04-07 20:50

administrator   ~0004763

Closing content that was verified as duplicates or not fixable.

Issue History

Date Modified Username Field Change
2017-08-22 10:43 KB3NPH New Issue
2017-08-22 10:56 K7ZCZ Assigned To => KB3NPH
2017-08-22 10:56 K7ZCZ Status new => feedback
2017-08-22 10:56 K7ZCZ Note Added: 0004072
2017-10-03 04:18 PD9FER File Added: DigitalMaster_20171003_050130.zip
2017-10-03 04:18 PD9FER Note Added: 0004270
2018-01-14 04:52 PD9FER Note Added: 0004304
2018-02-09 07:57 KB3NPH Note Added: 0004309
2018-02-21 08:25 PD9FER Note Added: 0004313
2018-03-13 20:35 K7ZCZ Relationship added related to 0002320
2018-03-17 11:27 K7ZCZ Status feedback => resolved
2018-03-17 11:27 K7ZCZ Resolution open => duplicate
2018-03-17 11:27 K7ZCZ Note Added: 0004502
2018-04-02 10:42 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-04-02 10:45 K7ZCZ Fixed in Version => 6.4.0.798
2018-04-07 20:49 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 20:50 WA9PIE Note Added: 0004763
2018-04-07 20:50 WA9PIE Status resolved => closed