View Issue Details

IDProjectCategoryView StatusLast Update
0002243Ham Radio DeluxeBugpublic2019-02-24 15:13
ReporterPD9FER 
Assigned ToPD9FER 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0002243: FT-857D Not showing and tracking Mode
DescriptionUsing HRD after V 6.3.0613 Mode is no longer visible in rig control, not it will track in Logbook
There was issues with the YAESU CAT protocol I am aware, however Mode was not one of the removed items

See screenshot, Mode is showing above the frequency.
With our latest version it is gone.
Steps To ReproduceN/A
Additional Informationhttps://support.ham-radio-deluxe.com/scp/tickets.php?id=11495
TagsFT-857D, Yaesu
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

related to 0002286 closedKC7FPF Ham Radio Deluxe Yaesu FT-1000MP Mark-V Field. Logbook ALE not tracking Mode 
has duplicate 0002602 closedKC7FPF Ham Radio Deluxe FT-897 Mode in Logbook not tracking when changing from Radio dial. 
related to 0002248 feedbackPD9FER 1 - Backlog Icom IC-718: Logbook ALE window does not regonize USB or LSB 

Activities

PD9FER

2017-09-10 09:23

viewer  

Capture.PNG (22,615 bytes)
Capture.PNG (22,615 bytes)

PD9FER

2017-09-10 10:10

viewer   ~0004157

Same for a customer with a FT-897d

PD9FER

2017-09-16 12:42

viewer   ~0004196

Also this with SDR https://support.ham-radio-deluxe.com/scp/tickets.php?id=11725

PD9FER

2017-10-03 13:23

viewer   ~0004271

I found out that in build 787 LSB and USB are removed from the default modes.
 Please add them back in the defaults.
 (by adding them manually, the problem is solved)

PD9FER

2018-03-16 12:59

viewer   ~0004495

Also on FT-1000MP MKV
Ticket #935726

K7ZCZ

2018-03-17 13:12

manager   ~0004504

I need more information to take action on this bug. Please let me know:

1) How to reproduce the problem. Step-by-step instructions are necessary; please be as clear as possible.
2) What you end up seeing. How does it currently work, and why is that wrong?
3) What you expect to see. How should it work, and what needs to change?

KB3NPH

2018-03-19 11:17

administrator   ~0004512

Mike, I just added two images from my IC-7100 display showing the problem. The Rig Control is set to USB. In the Logbook ALE, with it set to track the modes, it's showing CW. It should be showing USB just like the Rig Control Screen when the "Tracking" is checked as shown in the ALE image.

Hope this helps you understand what we're seeing with several different radio models, including my Icom IC-7100

USB IN RIG CONTROL.jpg (295,381 bytes)
Showing CW in ALE.jpg (186,373 bytes)
Showing CW in ALE.jpg (186,373 bytes)

K7ZCZ

2018-03-19 13:58

manager   ~0004513

Here's what I'm doing:
 
 1) Start Rig Control
 2) Get it connected to my radio. My radio happened to be in USB mode.
 3) Start Logbook
 4) Open my favorite database
 5) Press the "Add" button in the toolbar to bring up the QSO editor
 6) There, mark the "Track" checkbox next to the mode.
 
At this point, for me, I'm seeing that the "Mode" is set to "USB", like my radio.

 7) Chaneg the radio's mode by clicking on the [USB] box above the frequency on Rig Control. Set it to "CW"
 
Here, I observe that the QSO editor window changes to "CW".

 8) C hange the radio's mode by using the radio's controls. I switched to "PSK".
 
When I do so, I notice that the QSO editor window changes to "PSK31".

I'm using my IC-7610, and as far as I can tell, the code is working as intended so far.

Am I supposed to be doing different steps? Do you think the issue is unique to the radios previously listed in this bug?

K7ZCZ

2018-03-20 08:55

manager   ~0004514

In chat, I've confirmed with Tim that these steps reproduce the bug. I'm still a bit confused because this issue says that the "Mode is no longer visible in rig control", and the ticket shows screen shots with the [USB] mode box in rig control missing. That's a different issue than I reproduce in my steps, which focus on the QSO Editor Window in the Logbook not updating when the tracking box is marked.

When the mode box is not visible in Rig Control, it means that Rig Control couldn't recognize the mode response from the radio. That problem is local to Rig Control and means that the radio isn't correctly implemented in Rig Control.

When the Logbook application communicates with Rig Control to sync the QSO Editor Window controls, things are a bit more complicated. In that case, the Logbook application has connected to the Rig Control application with a socket. Occasionally, the applications communicate over the socket to exchange information about the state of the radio. When the Logbook application receives an update, the windows in the application send custom messages to each other to manage the updates of the UI.

The mechanism that seems to be failing is the socket communication layer. If a response isn't received to a socket message in 5 seconds, the thread handling the communication on the rig control side gets sick; it doesn't recover the framing of the protocol, and instead sits in a tight loop polling the socket for new connections that never come. The Logbook could close and reset the socket, but it doesn't. The applications stop exchanging updates, and nothing happens. I'm not sure how the applications get in this state in the wild, but it's conceivable that slow machines delay more than 5 seconds between reads; or that some other bug initiates the issue.

My investigation is directed and not exhaustive, so it's possible that there's also another cause.

But it seems that the resiliency of this protocol is a problem for reliability in communication between any of the applications.

PD9FER

2018-06-28 07:36

viewer   ~0005513

This issue is specific for the Yaesu FT-8x7 series

PD9FER

2018-06-28 09:23

viewer   ~0005515

Customer from ticket #935726 just asked about the status... FYI

PD9FER

2018-11-29 10:07

viewer   ~0006481

Asked customer again if it has been fixed

PD9FER

2018-11-29 12:00

viewer   ~0006482

Got reply as still not solved as in Build 907

WA9PIE

2018-12-27 15:49

administrator   ~0006814

Ferry - please retest with the FT-857D.

PD9FER

2018-12-28 05:26

viewer   ~0006820

Asked customer, waiting for feedback.
Also going to test this with Tim and Kevin

PD9FER

2018-12-29 03:59

viewer   ~0006823

Customer reported it as still broken in 6.5.0.163

K7ZCZ

2018-12-29 11:13

manager   ~0006824

Seems like we still don't have specific repro steps for this. Has the customer offered anything specific?

PD9FER

2018-12-29 11:18

viewer   ~0006825

I get this repro'd with Tim and Kevin

PD9FER

2018-12-29 12:18

viewer   ~0006826

Repro steps:
Just hook up a Yaesu 8x7 radio
Connect to Rig control
Look above the Frequency.... No Mode is displayed...
Confirmed FAIL in 6.5.0.163

See screenshot

PD9FER

2019-01-17 13:03

viewer   ~0007021

Another report: Ticket #908243

PD9FER

2019-02-08 04:35

viewer   ~0007313

Confirmed fixed in 6.5.0.191

Issue History

Date Modified Username Field Change
2017-09-10 09:23 PD9FER New Issue
2017-09-10 09:23 PD9FER File Added: Capture.PNG
2017-09-10 10:10 PD9FER Note Added: 0004157
2017-09-16 12:42 PD9FER Note Added: 0004196
2017-09-18 08:58 K7ZCZ Relationship added related to 0002248
2017-10-03 13:23 PD9FER Note Added: 0004271
2018-03-16 12:59 PD9FER Note Added: 0004495
2018-03-17 13:10 K7ZCZ Project 1 - Backlog => 2 - Next Dev List (Holding Area)
2018-03-17 13:12 K7ZCZ Assigned To => PD9FER
2018-03-17 13:12 K7ZCZ Status new => feedback
2018-03-17 13:12 K7ZCZ Note Added: 0004504
2018-03-19 11:17 KB3NPH File Added: USB IN RIG CONTROL.jpg
2018-03-19 11:17 KB3NPH File Added: Showing CW in ALE.jpg
2018-03-19 11:17 KB3NPH Note Added: 0004512
2018-03-19 13:58 K7ZCZ Note Added: 0004513
2018-03-20 08:55 K7ZCZ Note Added: 0004514
2018-06-28 07:36 PD9FER Note Added: 0005513
2018-06-28 09:23 PD9FER Note Added: 0005515
2018-11-27 21:51 WA9PIE Tag Attached: FT-8x7
2018-11-29 00:47 WA9PIE Tag Renamed FT-8x7 => Yaesu FT-8x7
2018-11-29 10:07 PD9FER Note Added: 0006481
2018-11-29 12:00 PD9FER Note Added: 0006482
2018-11-30 18:01 WA9PIE Tag Attached: Yaesu
2018-11-30 18:01 WA9PIE Tag Attached: FT-857D
2018-11-30 18:01 WA9PIE Tag Detached: Yaesu FT-8x7
2018-12-20 22:19 K7ZCZ Relationship added has duplicate 0002602
2018-12-20 22:19 K7ZCZ Relationship added related to 0002286
2018-12-27 15:49 WA9PIE Note Added: 0006814
2018-12-28 05:26 PD9FER Note Added: 0006820
2018-12-29 03:59 PD9FER Note Added: 0006823
2018-12-29 11:13 K7ZCZ Note Added: 0006824
2018-12-29 11:18 PD9FER Note Added: 0006825
2018-12-29 12:18 PD9FER File Added: 49180844_821276614874454_8817775679270551552_n.jpg
2018-12-29 12:18 PD9FER Note Added: 0006826
2019-01-17 13:03 PD9FER Note Added: 0007021
2019-01-21 02:23 WA9PIE Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2019-02-08 04:35 PD9FER Note Added: 0007313
2019-02-08 04:35 PD9FER Status feedback => resolved
2019-02-08 04:35 PD9FER Resolution open => fixed
2019-02-08 04:35 PD9FER Description Updated View Revisions
2019-02-08 04:35 PD9FER Testing => Not Started
2019-02-13 07:59 K7ZCZ Fixed in Version => 6.5.0.192
2019-02-13 14:34 WA9PIE Status resolved => closed
2019-02-13 14:34 WA9PIE Testing Not Started => Beta Successful
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.192 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe