View Issue Details

IDProjectCategoryView StatusLast Update
00022485 - Closed w/o ActionBugpublic2019-09-14 01:49
ReporterPD9FERAssigned ToPD9FER 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionno change required 
Summary0002248: Icom IC-718: Logbook ALE window does not regonize USB or LSB
DescriptionWith the logbook ALE open, Mode and Freq tracking enabled, whilst switching Modes on the radio USB and LSB are not seen.
They displayed as AM
However in Rig Control I see the correct mode, same as for the Radio pane in Logbook.

Looks like something in the ALE is wrong.
Steps To ReproduceStart rigcontrol
Start logbook
Open ALE and select freq & Mode tracking
Change mode on the radio and compare.
Also look at Mode displayed in the Radio Pane.
Additional InformationMaybe related to Mantis 0002243 Only Mode shows in Rigcontrol for me, so I think it are 2 different cases but possible linked to each other.
TagsIC-718, ICOM
ModuleLogbook
Sub-ModuleALE Window
TestingNot Started

Relationships

related to 0002243 closedPD9FER Ham Radio Deluxe FT-857D Not showing and tracking Mode 

Activities

PD9FER

2017-09-18 06:44

updater  

cw.png (57,869 bytes)
cw.png (57,869 bytes)
usb.png (61,972 bytes)
usb.png (61,972 bytes)

PD9FER

2017-09-19 06:50

updater   ~0004244

From my log:
You see Modes are read correctly, only ALE displays AM when USB or LSB is selected.

13:47:59 HRD Interface Message << Mode: LSB Filter: Wide
13:47:59 HRD Interface Message >> [116] get frequencies
13:47:59 HRD Interface Message << 14142000-0
13:47:59 HRD Interface Message >> [116] get dropdown-text {Mode} [116] get dropdown-text {Filter}
13:47:59 HRD Interface Message << Mode: LSB Filter: Wide

PD9FER

2017-09-27 07:16

updater   ~0004266

I found out that in build 787 LSB and USB are removed from the default modes.
Please add them back in the defaults.
(by adding them manually, the problem is solved)

WA9PIE

2018-06-14 00:15

administrator   ~0005301

Ferry... please elaborate with images.

PD9FER

2018-06-22 05:25

updater   ~0005375

See screenshot. (LSB not included in it)

Fresh install, Open Logbook
Go To Tools > Configure > Modes
Look for SSB LSB and USB
Note that it states:
LSB > SSB
SSB > SSB
USB > USB

It should be:
LSB > LSB
USB > USB
SSB should be removed. (TQSL will map it)

For some reason SSB gets parsed to the ALE mode tracking instead of the known modes in the radio.

Knipsel.PNG (35,509 bytes)
Knipsel.PNG (35,509 bytes)

WA9PIE

2018-06-22 10:54

administrator   ~0005384

Ferry,

Please review the ADIF standards at www.adif.org for SSB.

Please also review the list of modes accepted by LOTW:
https://lotw.arrl.org/lotw-help/frequently-asked-questions/#modes

PD9FER

2018-06-22 11:52

updater   ~0005385

I am very aware of them

Logbook users want have LSB or USB displayed in their Log
I found out, when Mode is mapping it to SSB some radios wont track mode in the ALE

Let LoTW (TQSL) do the mapping (as it always did)

PD9FER

2018-06-22 12:34

updater   ~0005386

For some reason a few radios read the mode in ALE tracking from that list.

WA9PIE

2018-06-23 17:03

administrator   ~0005405

This one is going to require a discussion.

PD9FER

2019-04-11 13:52

updater   ~0007850

I told in several meetings this can be closed

Issue History

Date Modified Username Field Change
2017-09-18 06:44 PD9FER New Issue
2017-09-18 06:44 PD9FER File Added: cw.png
2017-09-18 06:44 PD9FER File Added: usb.png
2017-09-18 08:58 K7ZCZ Relationship added related to 0002243
2017-09-19 06:50 PD9FER Note Added: 0004244
2017-09-27 07:16 PD9FER Note Added: 0004266
2018-06-14 00:15 WA9PIE Note Added: 0005301
2018-06-14 00:15 WA9PIE Assigned To => PD9FER
2018-06-14 00:15 WA9PIE Status new => assigned
2018-06-14 00:16 WA9PIE Status assigned => feedback
2018-06-22 05:25 PD9FER File Added: Knipsel.PNG
2018-06-22 05:25 PD9FER Note Added: 0005375
2018-06-22 10:54 WA9PIE Note Added: 0005384
2018-06-22 11:52 PD9FER Note Added: 0005385
2018-06-22 12:34 PD9FER Note Added: 0005386
2018-06-23 17:03 WA9PIE Note Added: 0005405
2018-11-30 09:04 PD9FER Tag Attached: Icom IC-718
2018-11-30 16:35 WA9PIE Tag Attached: ICOM
2018-11-30 16:36 WA9PIE Tag Attached: IC-718
2018-11-30 16:36 WA9PIE Tag Detached: Icom IC-718
2019-04-11 13:52 PD9FER Note Added: 0007850
2019-04-11 13:53 PD9FER Status feedback => resolved
2019-04-11 13:53 PD9FER Resolution open => no change required
2019-04-11 13:53 PD9FER Description Updated View Revisions
2019-04-11 13:53 PD9FER Steps to Reproduce Updated View Revisions
2019-04-11 13:53 PD9FER Testing => Not Started
2019-04-18 19:41 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-06-15 11:36 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2019-08-30 13:50 K7ZCZ Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2019-08-30 16:13 K7ZCZ Fixed in Version => 6.7.0.226
2019-09-14 01:48 WA9PIE Status resolved => closed
2019-09-14 01:48 WA9PIE Fixed in Version 6.7.0.226 =>
2019-09-14 01:49 WA9PIE Project 3 - Current Dev List => 5 - Closed w/o Action