View Issue Details

IDProjectCategoryView StatusLast Update
0002286Ham Radio DeluxeBugpublic2019-02-24 15:13
ReporterPD9FER 
Assigned ToKC7FPF 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0002286: Yaesu FT-1000MP Mark-V Field. Logbook ALE not tracking Mode
DescriptionWhen Using the FT-1000MP MK-V Frequency tracks fine.
Mode Stays Greyed as CW.

When connecting an Icom radio it is tracking.
Steps To ReproduceCan't reproduce.
Not having my hands on a FT-1000
Asked in the Beta forums, No confirmations yet
Additional InformationTicket #151301
TagsFT-1000MP, Yaesu
ModuleLogbook
Sub-ModuleALE Window
Testing Beta Successful

Relationships

related to 0003156 new 3 - Current Dev List Logbook ALE band tracking doesn't give clear indication of invalid bands 
related to 0002282 closedK7ZCZ 4 - Closed w/o Action TS-950SD Frequency Tracking In Logbook goes non-responsive 
related to 0002243 closedPD9FER Ham Radio Deluxe FT-857D Not showing and tracking Mode 

Activities

PD9FER

2018-03-06 05:59

viewer   ~0004447

FT-897D and FT-857 have the same problem for this customer Ticket# 800206

PD9FER

2018-03-13 08:51

viewer   ~0004482

Another one Ticket #585464 FT1000 Mark V Field

KC7FPF

2018-04-23 12:17

viewer   ~0004882

Spoke with a customer stated the the issue in not an an issue when using the FTDX5000L

KB3NPH

2018-05-23 13:04

administrator   ~0005096

Ticket #645432 Customer with FT-920 reports same issue where mode in ALE does not track from RC

g3ucq

2018-09-23 07:37

viewer   ~0006229

F5SRH and other report problems with no mode tracking of the FT847, FT857, FT-897, FT1000D, FT-1000MP.
This was first reported on 29 October 2017. Priority please as users are annoyed.

PD9FER

2018-10-28 08:43

viewer   ~0006350

New Ticket #583881

WA9PIE

2018-11-13 15:46

administrator   ~0006428

I'm using an FT-857D and I'm not having any such troubles.

That said - I do think we should move this up in priority and solve it.

WA9PIE

2018-11-13 15:48

administrator   ~0006429

MB - is there anything obvious in the code that you see that would prevent MODE from being "tracked" (that term is annoying, but whatever)?

K7ZCZ

2018-11-13 15:57

manager   ~0006430

Sorry, but I haven't looked into this because the problem isn't clear to me. I'm guessing the user is physically changing the mode on the front panel of the radio, but the ALE window, when open and connected to Rig Control, isn't showing the change. Is that right?

WA9PIE

2018-12-16 00:02

administrator   ~0006668

Here's a video submitted by a user on this topic.

http://f4dbd.radioamateur.org/upload/hrd_problem.mov

This is contained within trouble ticket: https://support.hamradiodeluxe.com/scp/tickets.php?id=22715

WA9PIE

2018-12-16 00:03

administrator   ~0006669

Take a look at the customers video and see if it provides enough information to document the issue.

WA9PIE

2018-12-16 11:46

administrator   ~0006675

Additional video: https://f4dbd.radioamateur.org/upload/hrd_mode_track.mov

K7ZCZ

2018-12-19 21:30

manager   ~0006724

The first video seems pretty clear; the second doesn't show much.

Here's what I gather to be the repro steps for this issue:


1) Start Rig Control. Connect to the FT-1000 radio
2) Start Logbook. Make sure Logbook connects to Rig Control
3) Open the ALE to add a new entry.
4) In the ALE, mark the "Track" checkboxes for both mode and band.
5) Switch around the mode on the radio using the radio's front panel.

BUG#1) The radio changes mode, and Rig Contro reflects the changes. The Logbook ALE display doesn't reflect the change.

6) Switch around the mode on the Rig Control UI.

BUG#2) The radio changes mode, and Rig Controls shows that. The Logbook ALE doesn't show the change even though it mode tracking is marked.

7) Swtich around the band on the radio's control panel.

BUG#3) The video odoesn't show Rig control. Presumably, it's working. But it does show that the Logbook ALE doesn't track the changes in band correctly.

BUG#3 is the most doubtful, since the video doesn't show the different moving pieces.

Do I have it right?

K7ZCZ

2018-12-20 21:32

manager   ~0006750

Since there are two different problems here, maybe it would be best to split this issue into two different bugs. Using a single Mantis issue to track multiple problems with the software ends up making the issues harder to track.


In the second "hrd_problem" video, the user tunes to 10.200 MHz and the "Band" drop-down goes blank. This is by design, as far as I can tell. HRD defines the 30-meter band between 10.000 MHz and 10.150 MHz. Since the tuned frequency is outside those ranges, the band control is cleared. The HRD definitions match the ADIF definitions given in the ADIF spec: http://www.adif.org/304/ADIF_304.htm#Band_Enumeration


Later in the video, the user tunes to 18.200. This is outside the ADIF definition for the 17m band, which is 18.068 to 18.168 MHz. Some dubious code exists which does some math that applies in this case: the wavelength is computed as (280 / Mhz), so we have (280 / 18.200) which gives 15.384 meters. That's formatted to 15m, and then matches the band name, even though it doesn't match the band's range for frequency.

While this math is good for building antennas and passing exams, I don't think it's appropriate for the calculation of the ADIF field value. The math to compute the band name was added in Changelist 501 (see https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/501).

K7ZCZ

2018-12-20 21:49

manager   ~0006751

Several radios are named in this bug as having an issue tracking mode in the ALE. Those mentioned are the FT-1000MP MarkV, the FT-897D, the FT-857, and the FT-920. These radios all use the "old" Yaesu binary protocol. The FTDX-5000 is identified as not having the problem, and I'm not able to reproduce the problem with the FT-991 I have. This suggests that the issue is related to the handling of that protocol in Rig Control. Of course, that's just a suggestion; there's no hard evidence -- just an observation that the reported radios have something in common, and that attribute is exclusive to radios which don't seem to have the problem.

I note that the user in the video is switching among USB, LSB, and CW. The flashing CW button indicates that the user is also passing through the CW-R mode (described on page 37 of the FT-1000MP MarkV manual). It's a possibility that these modes are not represented consistently between Rig Control and the Logbook, or communicated correctly from Rig Control to the Logbook. Again, since I have no radio to use for testing this feature or protocol, I can only speculate.

WA9PIE

2018-12-21 14:43

administrator   ~0006785

A customer report via email confirms K7ZCZ's last comment:

"This is the problem with the FT897D. What seems strange to me is the fact that older versions do not manifest this problem. Before I bought the license I used the latest version of the 5th series and it was not the error, the ALE section of the Logbook very well followed the way the transceiver works when changing the way of working."

K7ZCZ

2019-02-03 12:46

manager   ~0007246

This issue is a real rodeo: several different radios, a couple videos. It's not completely clear to me what I should be trying to fix.

I've made a guess at what appears to be the issue, but I didn't receive a response. Amazingly, I'm the only one who's taken the time to write any repro steps, but I'm just guessing at what people are trying to report. I don't feel like I have any solid information to start investigating any particular problem.

Is anyone able to provide a clear example of what reporting? Is there some other way that we can figure out what's wrong?

K7ZCZ

2019-02-03 13:49

manager   ~0007247

Let me try to take a first cut at sorting this all out.

Ticket 645432: Version 6.4.0.840 with FT-920. This user reports that the band in Logbook changes, but the mode doesn't change. It would be useful to know if Rig Control is reporting the mode in this scenario, but that information is not given. If Rig Control is not reporting the mode, then I think this is the same issue reported in Mantis 3153 and is now fixed. Since I have access to an FT-920 at the moment, I'm pretty confident in this fix. But if Rig Control is showing a mode, then there's a communication problem between Rig Control and Logbook.

Ticket 585464: Version 6.4.0.794 with FT-1000 Mark V. This user reports that the Logbook is not tracking the mode from the radio. The user said they can set the mode with Rig Control, but says nothing of being able to read the mode with Rig Control. About 10 days later, the user provided screen shots of Rig Control showing no mode setting being read from the radio. Maybe Rig Control never could read the mode, or maybe Rig Control only failed ten days after the ticket was initially opened -- that information isn't given. The customer wasn't asked to submit a log, but helpfully does. That log shows that Rig Control is not responding with a mode, so this makes the problem seem like it's isolated to Rig Control. That makes me believe that Mantis 3153 will fix it, but I can't confirm that because I don't have the radio to test it myself.

Ticket 800206: Version 6.4.0.787 with FT-1000 MP. This user reports the Logbook isn't tracking. There is some discussion about changing a list of mode mappings. (Seems like that list is in Logbook, though I don't see anything in the ticket which says that explicitly.)

Ticket 151301: Version 6.4.0.787 with FT-1000 MP Mark V Field. This user reports the Logbook isn't tracking. Some discussion and lots of screenshots of the mode mapping window again, but no diagnostic performed to see if Rig Control was tracking the mode from the radio.

Ticket 583881: Version 6.4.0.893 with FT-897 or FT-857. Mentions only Logbook. We don't know if Rig Control is tracking the mode or not.


The Logbook doesn't connect directly to the radio. Instead, it queries Rig Control to read (and set, sometimes) the state of the radio. If the Logbook isn't reflecting the state of the radio, the first thing we need to do is figure out if the problem is between the Logbook and Rig Control, or between Rig Control and the Radio.

That's easy to do. If Rig Control is showing (and tracking) the radio's mode, then we know that Rig Control is working. If it's not, then the problem is isolated between Rig Control and the radio -- and we need to fix Rig Control.

I think that many Yaesu radio which use their old protocol were broken. I believe they were fixed, at least improved, by the fix made in Mantis 3153. I can't test that, since I have only one radio (a FT-920) that speaks this protocol. All of the rigs reported in this issue (the FT-897, the FT-857, the FT-920, and the different FT-1000 variants) use the old Yaesu protocol.

If the issue is something wrong with communication between Rig Control and the Logbook, then we need to investigate what's wrong with the Logbook's queries (or Rig Control's responses, or Logbook's handling of those response, or ...) and sort out what might be wrong. That's a different investigation than I performed for Mantis 3153.

One of the tickets (585464) seems to show that it's the communication between Rig Control and the radio that is at issue. None of the other tickets mention the status of Rig Control, as far as I can tell.

It would be quite helpful to collect that diagnostic information as it would direct further investigation into the problem.

K7ZCZ

2019-02-04 15:03

manager   ~0007254

I've moved the problem with out-of-band indication in the ALE to its own issue at 3156. That issue is independent of any radio, so it can be separately addressed as soon as the team agrees on a design.

PD9FER

2019-02-07 08:03

viewer   ~0007305

Customer from Ticket #585464 with the FT-1000 Mark V confirms it fixed in 6.5.0.191

Issue History

Date Modified Username Field Change
2017-12-01 04:28 PD9FER New Issue
2018-03-06 05:59 PD9FER Note Added: 0004447
2018-03-13 08:51 PD9FER Note Added: 0004482
2018-04-23 12:17 KC7FPF Note Added: 0004882
2018-05-23 13:04 KB3NPH Note Added: 0005096
2018-09-23 07:37 g3ucq Note Added: 0006229
2018-10-28 08:43 PD9FER Note Added: 0006350
2018-11-13 15:46 WA9PIE Note Added: 0006428
2018-11-13 15:47 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-11-13 15:47 WA9PIE Assigned To => K7ZCZ
2018-11-13 15:47 WA9PIE Status new => assigned
2018-11-13 15:48 WA9PIE Note Added: 0006429
2018-11-13 15:57 K7ZCZ Assigned To K7ZCZ => WA9PIE
2018-11-13 15:57 K7ZCZ Testing => Not Started
2018-11-13 15:57 K7ZCZ Note Added: 0006430
2018-12-01 14:53 K7ZCZ Tag Attached: Yaesu
2018-12-01 14:55 K7ZCZ Tag Attached: FT-1000MP
2018-12-16 00:02 WA9PIE Note Added: 0006668
2018-12-16 00:03 WA9PIE Assigned To WA9PIE => PD9FER
2018-12-16 00:03 WA9PIE Status assigned => feedback
2018-12-16 00:03 WA9PIE Note Added: 0006669
2018-12-16 11:46 WA9PIE Note Added: 0006675
2018-12-19 21:30 K7ZCZ Note Added: 0006724
2018-12-20 21:32 K7ZCZ Note Added: 0006750
2018-12-20 21:49 K7ZCZ Note Added: 0006751
2018-12-20 22:19 K7ZCZ Relationship added related to 0002282
2018-12-20 22:19 K7ZCZ Relationship added related to 0002243
2018-12-21 14:43 WA9PIE Note Added: 0006785
2018-12-27 15:40 WA9PIE Assigned To PD9FER => KC7FPF
2019-02-03 12:46 K7ZCZ Note Added: 0007246
2019-02-03 13:49 K7ZCZ Note Added: 0007247
2019-02-04 15:03 K7ZCZ Note Added: 0007254
2019-02-04 15:03 K7ZCZ Relationship added related to 0003156
2019-02-07 08:03 PD9FER Note Added: 0007305
2019-02-07 08:03 PD9FER Status feedback => assigned
2019-02-13 13:34 WA9PIE Status assigned => closed
2019-02-13 13:34 WA9PIE Resolution open => fixed
2019-02-13 13:34 WA9PIE Fixed in Version => 6.5.0.191
2019-02-13 13:34 WA9PIE Testing Not Started => Beta Successful
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.191 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe