View Issue Details

IDProjectCategoryView StatusLast Update
0002289Ham Radio DeluxeBugpublic2019-01-16 22:04
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0002289: FREQ_RX send in wrong formating to QRZ.com Log
DescriptionWhen uploading a log directly written to logbook via the API FREQ_RX is send to the QRZ Log in the wrong formatting (Hz instead of MHz)
See attached document for explanation and screenshots.
Steps To ReproduceSee doc.
Additional InformationTicket #432889
TagsNo tags attached.
ModuleLogbook
Sub-ModuleParser
Testing Beta Successful

Relationships

Activities

PD9FER

2017-12-06 08:31

viewer  

Issue uploading incorrect formating to QRZ.docx (163,830 bytes)

PD9FER

2018-01-07 03:44

viewer   ~0004299

Ticket #434921

KC7FPF

2018-06-06 16:20

viewer   ~0005213

Was contacted by KN4PMA in regards to attempting the get a updated status of this issue.

WA9PIE

2018-06-23 17:33

administrator   ~0005408

MikeB... does Ferry have enough detail in the attached Word doc to start this?

PD9FER

2018-11-21 13:39

viewer   ~0006440

Got a reply
Ticket #434921

K7ZCZ

2018-11-23 11:26

manager   ~0006448

Last edited: 2018-11-23 12:05

View 2 revisions

As far as I can tell, no Logbook API is involved and the problem is actually when the Logbook uses the QRZ API to try to upload a record. Is that correct?

 > MikeB... does Ferry have enough detail in the attached Word doc to start this?

Sorry, I don't know what it is that Ferry wants to start. If you can provide an explanation, I can offer an evaluation. Or, maybe it's easier to just ask Ferry directly?

K7ZCZ

2018-11-24 00:23

manager   ~0006457

I spent about three hours digging through this issue. Here's what I had to piece together to make sense of the report:


  • The attached document says "our DB", but never establishes who "our" is. Is it QRZ? Or HRD? Or maybe even JTAlert or QSO Relay? Turns out I viewed the properties of the document to figure out that it was written by Ferry, so that produces the clue that "Our DB" refers to the HRD Logbook database.

  • "The API" could mean any of a few APIs the Logbook exposes. We never find out which one is in use, but it doesn't matter. The API is only in use because (due to other tracked issues) the Logbook APIs are the only real way to get the FREQ_RX field populated.

  • There are four or five different code paths in the Logbook that end up contacting QRZ; these end up using one of two or three different implementations of different code that actually contacts QRZ. Copy-and-paste reuse, completely oblivious to any effort to refactor, is missing from our code base and it makes questions of "which way?" absolutely prerequisite to understanding how to investigate a bug. Without some way to limit scope, I'm obliged to research all of the involved implementations for the problem, not just one. The document implies, but doesn't say, that the QRZ upload is being done by the "automatic uploads" feature.

  • Now that we know the "automatic uploads" feature is involved, and which database is invovled, the problem isn't too hard to find.



Reasoning out these guesses isn't that hard, but it's not exact work and consumes more time than it should.

K7ZCZ

2018-11-24 00:24

manager   ~0006458

This fix is checked into the 6.5 branch
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4488

PD9FER

2018-12-11 04:33

viewer   ~0006574

Fixed

g3ucq

2018-12-12 13:41

viewer   ~0006590

Unable to test

Issue History

Date Modified Username Field Change
2017-12-06 08:31 PD9FER New Issue
2017-12-06 08:31 PD9FER File Added: Issue uploading incorrect formating to QRZ.docx
2018-01-07 03:44 PD9FER Note Added: 0004299
2018-06-06 16:20 KC7FPF Note Added: 0005213
2018-06-23 17:33 WA9PIE Note Added: 0005408
2018-06-23 17:34 WA9PIE Assigned To => K7ZCZ
2018-06-23 17:34 WA9PIE Status new => assigned
2018-06-23 17:34 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-11-21 13:39 PD9FER Note Added: 0006440
2018-11-23 11:26 K7ZCZ Note Added: 0006448
2018-11-23 12:05 K7ZCZ Note Edited: 0006448 View Revisions
2018-11-24 00:23 K7ZCZ Note Added: 0006457
2018-11-24 00:24 K7ZCZ Status assigned => resolved
2018-11-24 00:24 K7ZCZ Resolution open => fixed
2018-11-24 00:24 K7ZCZ Testing => Not Started
2018-11-24 00:24 K7ZCZ Note Added: 0006458
2018-12-09 15:48 K7ZCZ Fixed in Version => 6.5.0.132
2018-12-11 04:33 PD9FER Note Added: 0006574
2018-12-12 13:41 g3ucq Note Added: 0006590
2018-12-21 01:00 WA9PIE Status resolved => closed
2018-12-21 01:00 WA9PIE Description Updated View Revisions
2018-12-21 01:00 WA9PIE Testing Not Started => Beta Successful
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe