View Issue Details

IDProjectCategoryView StatusLast Update
00023163 - Current Dev ListBugpublic2018-05-26 23:30
Reporterk2dls 
Assigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformOSWindows 10OS Version1709
Product Version 
Target VersionFixed in Version6.4.0.842 
Summary0002316: Intermittement API reports data added when data NOT added
DescriptionThe HRD API running on TCP/7826 reports that data has been added to the HRD Lobgook when it has not been added. This appears to occur where a remote MySQL/MariaDB database is being used.
Steps To Reproduce1 - Start rig control and logbook.
2 - Open a telnet session to localhost 7826.
3 - db add "K2DLS Logbook" { CALL="VK1ZZZ" NAME="Testing" DXCC="150" COUNTRY="Australia" STATE="ACT" QSO_DATE="20180126" QSO_DATE_OFF="20180126" TIME_ON="062030" TIME_OFF="062530" FREQ="14076000" FREQ_RX="14076000" BAND="20m" BAND_RX="20m" ADDRESS="Single address line" MODE="JT65" RST_SENT="-15" RST_RCVD="15" DISTANCE="250" COMMENT="JT65" CQZ="30" ITUZ="59" PFX="VK1" CONT="OC" MY_GRIDSQUARE="QF55mx" MY_CQ_ZONE="30" MY_ITU_ZONE="59" STATION_CALLSIGN="VK2BYI" QSO_COMPLETE="Y " }
4 - API reports: Found 27 Valid Fields...
Added 27 Fields to K2DLS Logbook...
5 - Check logbook. The data is not there.
6 - Try again.
7 - The data is still not there.
Additional InformationVK2BYI reported that as a kludge, an open local MS-Access HRD DB in the background somehow prevents this from occurring. I tried the kludge and the next insert worked.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleFunctional
Testing Beta Successful

Relationships

related to 0002720 resolvedK7ZCZ Logbook: Poor error handling when database opening fails 
related to 0002721 new Documentation: YouTube video doesn't give complete instructions for switching to MariaDB 

Activities

WA9PIE

2018-02-22 16:20

administrator   ~0004315

Changing status. Seems to be more work left.

k2dls

2018-02-23 20:04

updater   ~0004321

Defect still exists in build 790.

Error.png (12,568 bytes)
Error.png (12,568 bytes)

K7ZCZ

2018-05-24 13:06

manager   ~0005102

I think there are two causes to this issue.

One is that the default database used the HRDCLI is configurable; and it's possible that users end up in a state where that configuration is invalid after they delete the default database. They're likely to do so because we instruct them to (see related bug). In that state, the user has no idea they're incorrectly configured because we don't give a warning when the configured database is deleted; and we don't give an error at startup when the invalid configuration is observable.

Even if the database used for the network interfaces to the logbook is correctly configured, the insertion may fail for any number of reasons. There is no error handling in the HRDCLI code for the "add" verb. I've added some, so now we'll at least report an error if something goes wrong.

I've never been able to reproduce this problem, so I'm unfortunately doing a bit of inductive reasoning. But I think addressing those issues will remedy this problem for our customers.

K7ZCZ

2018-05-24 13:06

manager   ~0005103

I believe this issue is addressed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4132

Issue History

Date Modified Username Field Change
2018-01-26 10:44 k2dls New Issue
2018-01-29 14:18 Roger Assigned To => Roger
2018-01-29 14:18 Roger Status new => assigned
2018-01-29 14:18 Roger Testing => Not Started
2018-02-22 12:49 Roger Reproducibility always => random
2018-02-22 12:49 Roger Status assigned => resolved
2018-02-22 12:49 Roger Resolution open => no change required
2018-02-22 12:49 Roger Testing Not Started => Beta Successful
2018-02-22 16:20 WA9PIE Status resolved => assigned
2018-02-22 16:20 WA9PIE Note Added: 0004315
2018-02-23 20:04 k2dls File Added: Error.png
2018-02-23 20:04 k2dls Note Added: 0004321
2018-03-02 10:40 K7ZCZ Assigned To Roger => K7ZCZ
2018-05-18 09:26 K7ZCZ Relationship added related to 0002720
2018-05-18 09:26 K7ZCZ Relationship added related to 0002721
2018-05-24 13:06 K7ZCZ Note Added: 0005102
2018-05-24 13:06 K7ZCZ Status assigned => resolved
2018-05-24 13:06 K7ZCZ Resolution no change required => fixed
2018-05-24 13:06 K7ZCZ Note Added: 0005103
2018-05-26 23:29 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-05-26 23:30 K7ZCZ Fixed in Version => 6.4.0.842