View Issue Details

IDProjectCategoryView StatusLast Update
0002317Ham Radio DeluxeBugpublic2018-11-11 00:34
Reporterk2dls 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.902 
Summary0002317: Imported ADIF records no longer displayed in open logbook
DescriptionImporting an ADIF file into the Logbook now requires a manual refresh before the imported records are displayed. It should not require manual intervention. This likely broke around the time that former programmer Mike removed some unnecessary screen refreshes to speed up searches.

See
Steps To ReproduceCreate an ADIF file of records to be imported.
Import the ADIF file into the active Logbook.
Imported records are not seen in the Logbook.
Refresh the Logbook.
Imported records are now seen.
Additional InformationSee https://forums.ham-radio-deluxe.com/node/44913 for discussion.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleImport Export
Testing Beta Successful

Relationships

Activities

WA9PIE

2018-03-16 01:04

administrator   ~0004491

It kinda sounds like we removed the "refresh" after ADIF import. We should probably put it back.

WA9PIE

2018-06-17 15:55

administrator   ~0005352

I just verified that this remains in the 846 build.

WA9PIE

2018-06-23 17:10

administrator   ~0005407

Reproduced using the steps included. Seems to be "shovel-ready."

K7ZCZ

2018-10-29 15:01

manager   ~0006354

Resolved with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4396

WA9PIE

2018-11-05 11:40

administrator   ~0006372

I tested and verified this one myself.

Issue History

Date Modified Username Field Change
2018-02-01 12:35 k2dls New Issue
2018-03-16 01:04 WA9PIE Note Added: 0004491
2018-06-17 15:55 WA9PIE Note Added: 0005352
2018-06-23 17:10 WA9PIE Note Added: 0005407
2018-06-23 17:10 WA9PIE Assigned To => WA9PIE
2018-06-23 17:10 WA9PIE Status new => assigned
2018-06-23 17:10 WA9PIE Assigned To WA9PIE => K7ZCZ
2018-06-23 17:10 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-10-29 15:01 K7ZCZ Status assigned => resolved
2018-10-29 15:01 K7ZCZ Resolution open => fixed
2018-10-29 15:01 K7ZCZ Testing => Not Started
2018-10-29 15:01 K7ZCZ Note Added: 0006354
2018-11-04 07:49 K7ZCZ Fixed in Version => 6.4.0.900
2018-11-05 11:40 WA9PIE Status resolved => closed
2018-11-05 11:40 WA9PIE Testing Not Started => Beta Successful
2018-11-05 11:40 WA9PIE Note Added: 0006372
2018-11-11 00:34 WA9PIE Fixed in Version 6.4.0.900 => 6.4.0.902
2018-11-11 00:34 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe