View Issue Details

IDProjectCategoryView StatusLast Update
0002319Ham Radio DeluxeBugpublic2018-06-14 01:17
ReporterKB3NPH 
Assigned ToKB3NPH 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0002319: Ticket #224553 - System Crash when printing Matrix
DescriptionConfirmed bug in HRD Logbook when selecting the "PRINT" option when displaying the Awards Tracking Matrix screen. Once the print icon is clicked system crashes with Mini-dump creation screen.

Duplicate by:
Open Logbook
Open Awards Tracking
Click on "Matrix" icon
Click on "Print" icon
Immediate logbook crash
See image attached for location of the PRINT button we're talking about.
MiniDump located in G-Drive, Software > Dumps > File Name "BugTicket_0002319.mdmp"


TagsNo tags attached.
ModuleLogbook
Sub-ModuleFunctional
TestingNot Started

Relationships

duplicate of 0002572 closedK7ZCZ Logbook build 794 Crash on Printing awardd status 

Activities

KB3NPH

2018-02-07 13:12

administrator  

Matrix Print Button.jpg (475,423 bytes)

K7ZCZ

2018-04-16 09:53

manager  

BugTicket_0002319.7z (14,726,516 bytes)

K7ZCZ

2018-04-16 09:53

manager   ~0004839

The compressed minidump is only 14 megs, so I'm attaching it here so it's easier to find.

K7ZCZ

2018-04-16 09:54

manager   ~0004840

The stack in the minidump is the same as 2572, which I fixed a few days ago.

0:000> kp
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr  
00 (Inline) -------- HRDLogbook!CGdiObject::GetSafeHandle+0x4 [f:\dd\vctools\vc7libs\ship\atlmfc\include\afxwin1.inl @ 68] 
01 008feb90 01853d63 HRDLogbook!CDC::SelectObject(class CFont * pFont = 0x008a0022)+0x2f [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wingdi.cpp @ 252] 
02 008fec78 018537c9 HRDLogbook!CAwards2View::DrawPageFrame(class CDC * pDC = 0x008fed00 {hDC={...} attrib={...}}, class CRect * rect = 0x008fecbc {LT(26, 234) RB(4838, 6284)  [4812 x 6050]}, wchar_t * lpTitle = 0x1fbf51d8 "Awards Summary Report.Tim Browning, KB3NPH")+0x363 [c:\ham radio\logbook\hrdlogbook\awards2view.cpp @ 1365] 
03 008fece0 01854023 HRDLogbook!CAwards2View::PrintSpreadsheet(class CDC * pDC = 0x008fed00 {hDC={...} attrib={...}})+0xd9 [c:\ham radio\logbook\hrdlogbook\awards2view.cpp @ 1409] 
04 008ff0d4 013e408b HRDLogbook!CAwards2View::OnFilePrint(void)+0x213 [c:\ham radio\logbook\hrdlogbook\awards2view.cpp @ 1265] 
05 008ff0e4 013e3ec4 HRDLogbook!_AfxDispatchCmdMsg(class CCmdTarget * pTarget = 0x12237f78, unsigned int nID = 0xe107, int nCode = 0n0, <function> * pfn = 0x01853e10, void * pExtra = 0x00000000, unsigned int nSig = 0x3a, struct AFX_CMDHANDLERINFO * pHandlerInfo = 0x00000000)+0x42 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 78] 
06 008ff114 013fc07e HRDLogbook!CCmdTarget::OnCmdMsg(unsigned int nID = 0xe107, int nCode = 0n0, void * pExtra = 0x00000000, struct AFX_CMDHANDLERINFO * pHandlerInfo = 0x00000000)+0x120 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 373] 
07 008ff154 013f9e32 HRDLogbook!CView::OnCmdMsg(unsigned int nID = 0xe107, int nCode = 0n0, void * pExtra = 0x00000000, struct AFX_CMDHANDLERINFO * pHandlerInfo = 0x00000000)+0x1f [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\viewcore.cpp @ 164] 
08 008ff194 013df867 HRDLogbook!CFrameWnd::OnCmdMsg(unsigned int nID = 0xe107, int nCode = 0n0, void * pExtra = 0x00000000, struct AFX_CMDHANDLERINFO * pHandlerInfo = 0x00000000)+0x37 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\winfrm.cpp @ 980] 
09 008ff1e4 013f9efe HRDLogbook!CWnd::OnCommand(unsigned int wParam = 0xe107, long lParam = 0n0)+0x89 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2784] 
0a 008ff200 013e0454 HRDLogbook!CFrameWnd::OnCommand(unsigned int wParam = 0xe107, long lParam = 0n0)+0x7b [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\winfrm.cpp @ 383] 
0b 008ff2b8 013af0f6 HRDLogbook!CWnd::OnWndMsg(unsigned int message = 0x111, unsigned int wParam = 0xe107, long lParam = 0n0, long * pResult = 0x008ff2f0)+0x3c [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2108] 
0c 008ff2d4 013e1c4a HRDLogbook!CXTPCommandBarsSiteBase<CMDIChildWnd>::OnWndMsg(unsigned int message = 0x111, unsigned int wParam = 0xe107, long lParam = 0n0, long * pResult = 0x008ff2f0)+0x46 [c:\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpframewnd.h @ 190] 
0d 008ff2f4 013dd2bd HRDLogbook!CWnd::WindowProc(unsigned int message = 0x111, unsigned int wParam = 0xe107, long lParam = 0n0)+0x22 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2094] 
0e 008ff364 013dda72 HRDLogbook!AfxCallWndProc(class CWnd * pWnd = 0x12244280 {hWnd={...}}, struct HWND__ * hWnd = 0x00031d8a, unsigned int nMsg = 0x111, unsigned int wParam = 0xe107, long lParam = 0n0)+0xb0 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 285] 
0f 008ff384 7442e0bb HRDLogbook!AfxWndProc(struct HWND__ * hWnd = 0x00031d8a, unsigned int nMsg = 0x111, unsigned int wParam = 0xe107, long lParam = 0n0)+0x34 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 434] 
10 008ff3b0 74438849 user32!_InternalCallWinProc+0x2b
11 008ff3d4 7443b145 user32!InternalCallWinProc+0x20
12 008ff4a4 7443833a user32!UserCallWinProcCheckWow+0x1be
13 008ff4e8 7441fbab user32!CallWindowProcAorW+0xd4
14 008ff500 01643e0c user32!CallWindowProcW+0x1b
15 008ff548 7442e0bb HRDLogbook!CXTPHookManager::HookWndProc(struct HWND__ * hWnd = 0x013dda3e, unsigned int message = 0x111, unsigned int wParam = 0xe107, long lParam = 0n0)+0xac [c:\hrdbranch\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\common\xtphookmanager.cpp @ 267] 
16 008ff574 74438849 user32!_InternalCallWinProc+0x2b
17 008ff598 7443b145 user32!InternalCallWinProc+0x20
18 008ff668 74428503 user32!UserCallWinProcCheckWow+0x1be
19 008ff6d0 74428aa0 user32!DispatchClientMessage+0x1b3
1a 008ff718 77a30bcd user32!__fnDWORD+0x50
1b 008ff750 76cb2a4c ntdll!KiUserCallbackDispatcher+0x4d
1c 008ff754 7443a9fd win32u!NtUserMessageCall+0xc
1d 008ff7c0 7441b95b user32!SendMessageWorker+0x860
1e 008ff7e8 015520d1 user32!SendMessageW+0x5b
1f 008ff824 01550821 HRDLogbook!CXTPControl::OnExecute(void)+0x191 [c:\hrdbranch\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpcontrol.cpp @ 914] 
20 008ff86c 015ffff8 HRDLogbook!CXTPControl::ClickToolBarButton(class CRect rcActiveRect = {LT(8, 2) RB(66, 54)  [58 x 52]})+0x271 [c:\hrdbranch\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpcontrol.cpp @ 785] 
21 008ff888 01552235 HRDLogbook!CXTPControlButton::OnClick(int bKeyboard = 0n0, class CPoint pt = {x=41 y=29})+0x78 [c:\hrdbranch\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpcontrolbutton.cpp @ 77] 
22 008ff8a0 0153a328 HRDLogbook!CXTPControl::OnLButtonDown(class CPoint point = {x=41 y=29})+0x35 [c:\hrdbranch\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpcontrol.cpp @ 1327] 
23 008ff8bc 01536058 HRDLogbook!CXTPCommandBar::OnLButtonDown(unsigned int nFlags = 1, class CPoint point = {x=41 y=29})+0x128 [c:\hrdbranch\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpcommandbar.cpp @ 434] 
24 008ff8d4 013e091b HRDLogbook!CXTPToolBar::OnLButtonDown(unsigned int nFlags = 1, class CPoint point = {x=41 y=29})+0x88 [c:\hrdbranch\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtptoolbar.cpp @ 1016] 
25 008ff990 0153accb HRDLogbook!CWnd::OnWndMsg(unsigned int message = <Value unavailable error>, unsigned int wParam = 1, long lParam = 0n1900585, long * pResult = 0x008ff9c8)+0x503 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2473] 
26 008ff9ac 013e1c4a HRDLogbook!CXTPCommandBar::OnWndMsg(unsigned int message = 0x201, unsigned int wParam = 1, long lParam = 0n1900585, long * pResult = 0x008ff9c8)+0x2b [c:\hrdbranch\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpcommandbar.cpp @ 2416] 
27 008ff9cc 013dd2bd HRDLogbook!CWnd::WindowProc(unsigned int message = 0x201, unsigned int wParam = 1, long lParam = 0n1900585)+0x22 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2094] 
28 008ffa3c 013dda72 HRDLogbook!AfxCallWndProc(class CWnd * pWnd = 0x12106338 {hWnd={...}}, struct HWND__ * hWnd = 0x00041da6, unsigned int nMsg = 0x201, unsigned int wParam = 1, long lParam = 0n1900585)+0xb0 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 285] 
29 008ffa5c 7442e0bb HRDLogbook!AfxWndProc(struct HWND__ * hWnd = 0x00041da6, unsigned int nMsg = 0x201, unsigned int wParam = 1, long lParam = 0n1900585)+0x34 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 434] 
2a 008ffa88 74438849 user32!_InternalCallWinProc+0x2b
2b 008ffaac 7443b145 user32!InternalCallWinProc+0x20
2c 008ffb7c 744290dc user32!UserCallWinProcCheckWow+0x1be
2d 008ffbe8 74428c20 user32!DispatchMessageWorker+0x4ac
2e 008ffbf4 013e6cff user32!DispatchMessageW+0x10
2f 008ffc04 013e7336 HRDLogbook!AfxInternalPumpMessage(void)+0x3e [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\thrdcore.cpp @ 183] 
30 008ffc20 018041d9 HRDLogbook!CWinThread::Run(void)+0x57 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\thrdcore.cpp @ 629] 
31 008ffc34 01802a29 HRDLogbook!AfxWinMain(struct HINSTANCE__ * hInstance = 0x013a0000, struct HINSTANCE__ * hPrevInstance = 0x00000000, wchar_t * lpCmdLine = 0x00ae23bc "/Quiet", int nCmdShow = 0n1)+0x66 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\winmain.cpp @ 47] 
32 008ffc80 770d8654 HRDLogbook!__tmainCRTStartup(void)+0x12f [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c @ 618] 
33 008ffc94 77a24a77 kernel32!BaseThreadInitThunk+0x24
34 008ffcdc 77a24a47 ntdll!__RtlUserThreadStart+0x2f
35 008ffcec 00000000 ntdll!_RtlUserThreadStart+0x1b

K7ZCZ

2018-04-16 09:55

manager   ~0004841

duplicate of 2572

Issue History

Date Modified Username Field Change
2018-02-07 13:12 KB3NPH New Issue
2018-02-07 13:12 KB3NPH File Added: Matrix Print Button.jpg
2018-02-07 13:20 KB3NPH Description Updated View Revisions
2018-04-13 10:23 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-04-16 09:53 K7ZCZ File Added: BugTicket_0002319.7z
2018-04-16 09:53 K7ZCZ Note Added: 0004839
2018-04-16 09:54 K7ZCZ Note Added: 0004840
2018-04-16 09:55 K7ZCZ Assigned To => K7ZCZ
2018-04-16 09:55 K7ZCZ Status new => resolved
2018-04-16 09:55 K7ZCZ Resolution open => duplicate
2018-04-16 09:55 K7ZCZ Note Added: 0004841
2018-04-16 09:55 K7ZCZ Relationship added duplicate of 0002572
2018-05-03 20:10 K7ZCZ Fixed in Version => 6.4.0.837
2018-05-26 23:38 K7ZCZ Assigned To K7ZCZ => KB3NPH
2018-06-14 00:41 WA9PIE Status resolved => closed
2018-06-14 00:41 WA9PIE Fixed in Version 6.4.0.837 => 6.4.0.840
2018-06-14 01:17 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe