View Issue Details

IDProjectCategoryView StatusLast Update
0002580Ham Radio DeluxeBugpublic2018-04-09 14:37
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.806 
Summary0002580: Build 794 Logbook Crashes after clicking on cluster spots
DescriptionAs the title says, when clicking on cluster spots to get them in the ALE and change the VFO to the spots frequency a crash happens.
Steps To ReproduceDouble or Single Click (depending on your cluster options) to select a station.
This might work most of the time but also crashes are happening,
Additional InformationMinidump(s) with this Mantis ID are in the G-Drive Dump folder
TagsNo tags attached.
ModuleLogbook
Sub-ModuleVarious
Testing Beta Successful

Relationships

related to 0002098 resolvedK7ZCZ 3 - Current Dev List Logbook UI stalls for a while after connecting DX Cluster 

Activities

PD9FER

2018-03-08 16:54

viewer   ~0004453

Also for Ticket #768428
Added a 2nd Minidump with this Mantis ID, please look at both

K7ZCZ

2018-03-10 23:00

manager   ~0004466

Fix is out for review with this shelve set:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/shelveset?ss=fix%20cluster%20crash%3Bmikeblas%40msn.com

K7ZCZ

2018-03-14 08:11

manager   ~0004487

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3937

vk2byi

2018-03-23 18:41

viewer   ~0004550

Tested with double click on cluster row with ALE open, as well as, right click on cluster row and select 'New ALE Window'. In both cases new ALE window is opened as is populated with lookup details. Fixed!

g3ucq

2018-04-02 13:57

viewer   ~0004628

This not fixed for me aas v.798 crashes every time I right click a cluster spot.
See Mantis 2613

w4ase

2018-04-02 14:09

viewer   ~0004629

Same has John - here is my dump file. It does not matter if I right click on a spot and open an ALE or open an ALE in Logbook both crash as soon as you click on anything in the ALE window.

HRDLogbook_20180402_190041.mdmp (754,150 bytes)

K7ZCZ

2018-04-02 20:12

manager   ~0004631

Both the W4ASE minidump added here and the minidump that G3UCQ added to 2613 end up at the callstack below.

I just made a mistake in cleaning up some code surrounding some of the other callsign lookup work I did; it's an easy fix and checked in with this change:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4015

0:028> kb
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr Args to Child
00 19aff6a8 532fab39 00000000 19aff6d4 19aff6f0 HRDLogbookCallsignLookup!CXMLMgr::AddAttribute+0x11b [c:\ham radio\hrdcommon\xmlmgr.cpp @ 1916]
*** WARNING: Unable to verify checksum for HRDLogbook.exe
01 19aff8fc 017256d5 01aa4364 00020002 1ad129c8 HRDLogbookCallsignLookup!HRDLogbookCallsignLookupW+0xce9 [c:\ham radio\logbook\hrdlogbookcallsignlookup\hrdlogbookcallsignlookup.cpp @ 3973]
02 19aff920 01725b0e 002705e6 00020002 1827f6ac HRDLogbook!CLibBackgroundProcessingThread::CallsignLookup+0x35 [c:\ham radio\logbook\hrdlogbook\logbookbackgroundprocessingthread.cpp @ 508]
03 19aff964 0181dac0 4d080048 1830ec30 1ac35118 HRDLogbook!CLibBackgroundProcessingThread::DoWork+0xde [c:\ham radio\logbook\hrdlogbook\logbookbackgroundprocessingthread.cpp @ 206]
04 19aff98c 0181da06 4d08000c 012d2227 1830ec30 HRDLogbook!CThinThread::Run+0x80 [c:\ham radio\logbook\hrdlogbook\thinthread.cpp @ 178]
05 19aff9c8 012d217b 182e3638 4d0803c4 012d2227 HRDLogbook!CThinThread::Start+0x46 [c:\ham radio\logbook\hrdlogbook\thinthread.cpp @ 226]
06 19affa00 012d22a3 012d2227 19affa20 75858654 HRDLogbook!_callthreadstartex+0x1b [f:\dd\vctools\crt\crtw32\startup\threadex.c @ 376]
07 19affa0c 75858654 1830ec30 75858630 392c5c3a HRDLogbook!_threadstartex+0x7c [f:\dd\vctools\crt\crtw32\startup\threadex.c @ 354]
08 19affa20 77bc4a77 1830ec30 3b65e59c 00000000 kernel32!BaseThreadInitThunk+0x24
09 19affa68 77bc4a47 ffffffff 77be9ea8 00000000 ntdll!__RtlUserThreadStart+0x2f
0a 19affa78 00000000 012d2227 1830ec30 00000000 ntdll!_RtlUserThreadStart+0x1b

k6mkf

2018-04-03 17:52

viewer   ~0004644

V.799 Logbook hangs here when:

1. Create ALE from DX Cluster spot (right-click)
2. Add the log entry from the ALE thus created.
3. Logbook hangs with the pale screen of impending death

DMP file taken and uploaded to \Dropbox\Ham Radio Deluxe as K6MKF HRDLogbook 20180403.zip

Also, while in the 'Not Responding' state, the Logbook process is acquiring .2MB of memory every second, according to Task Manager.

k6mkf

2018-04-03 18:49

viewer   ~0004647

I allowed the 'Not Responding' Logbook to run for a few hours. Memory usage grew to over 400MB and continued to grow. Killed it with Task Manager.

K7ZCZ

2018-04-03 19:47

manager   ~0004648

Last edited: 2018-04-03 19:47

View 2 revisions

The minidump described by K6MKF is a live-lock condition that is a side-effect of the design flaw described in Mantis 2098. It is not a new issue, nor is it related to this issue.

PD9FER

2018-04-04 11:11

viewer   ~0004678

Works for me in build 799

k6mkf

2018-04-04 11:28

viewer   ~0004679

My concern here is that I am seeing this issue with v.799 on a very generic Windows 10 Home 64-bit implementation, which is likely a common one among our Users.

If I have some sort of configuration error, I'd like to know what it is so it can be corrected and I can then achieve the results that Ferry, PD9FER, and others are seeing.

If my HRD and Windows configurations are correct, then perhaps there is actual issue with Logbook that needs to be resolved before this Beta moves toward a release.

K7ZCZ

2018-04-04 11:41

manager   ~0004680

K6MKF, if you're referring to the hang that you're having, then that's not a new issue. It's being tracked by Mantis 2098, and we'll work on it soon. If you're referring to the crash that others have reported in this issue, then please provide the steps that you're executing in order to realize the crash, as well as a matching minidump, and I can have a look.

It would help me track and manage issues if you could please clearly identify your comments by using the corresponding Mantis issue for communication. If you're not sure which issue to use, opening a new issue is almost always better than adding information to the wrong one. Thanks!

k6mkf

2018-04-04 11:54

viewer   ~0004681

I think I've managed to confuse myself, as well as others. Here's what I think understand so far:

Mantis # 0002652 - which is about a hang with Logbook and DM-780 and the IP Server under v.6.4.0.794. This was bug was opened as a result of this support ticket: IP Server hangs - Rig Control restart fixes [#160414]

 My notes above, here on 0002580, are referring to Beta v.799 Logbook hanging whenever I attempt to add a log entry via the Logbook ALE screen. Then I opened Mantis 0002653 just about my Logbook v.799 issue, as my issue with Logbook v.799 does not seem to fix well with 0002580.

My personal email is mike.flowers@gmail.com and my cell is 408-307-8258 if you want to chat directly.

WA9PIE

2018-04-04 14:59

administrator   ~0004688

K6MKF - do you consider this item fixed as described in this specific Mantis issue?

k6mkf

2018-04-04 15:08

viewer   ~0004690

>>> As the title says, when clicking on cluster spots to get them in the ALE and change the VFO to the spots frequency a crash happens.

In as much as the ALE window is created and populated, and the VFO changes, this is fixed.

However, any subsequent attempt to use the resulting ALE window to record a log entry, or to use an 'Add' ALE window to do so, results in a hang of Logbook as reported in Mantis 0002653. This is what I am consistently encountering with v.799.

Issue History

Date Modified Username Field Change
2018-03-08 02:16 PD9FER New Issue
2018-03-08 16:54 PD9FER Note Added: 0004453
2018-03-08 18:39 K7ZCZ Assigned To => K7ZCZ
2018-03-08 18:39 K7ZCZ Status new => assigned
2018-03-10 23:00 K7ZCZ Note Added: 0004466
2018-03-11 12:32 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-03-11 12:32 WA9PIE Status assigned => resolved
2018-03-11 12:32 WA9PIE Testing => Not Started
2018-03-13 14:21 WA9PIE Resolution open => @21@
2018-03-13 14:27 WA9PIE Resolution @21@ => @22@
2018-03-13 18:51 WA9PIE Resolution @22@ => fixed
2018-03-14 08:11 K7ZCZ Status resolved => assigned
2018-03-14 08:11 K7ZCZ Status assigned => resolved
2018-03-14 08:11 K7ZCZ Note Added: 0004487
2018-03-22 07:05 WA9PIE Target Version => 6.4.0.797
2018-03-22 07:06 WA9PIE Fixed in Version => 6.4.0.797
2018-03-23 18:41 vk2byi Note Added: 0004550
2018-03-30 19:47 WA9PIE Testing Not Started => Beta Successful
2018-04-02 13:57 g3ucq Note Added: 0004628
2018-04-02 14:09 w4ase File Added: HRDLogbook_20180402_190041.mdmp
2018-04-02 14:09 w4ase Note Added: 0004629
2018-04-02 20:12 K7ZCZ Note Added: 0004631
2018-04-03 17:52 k6mkf Note Added: 0004644
2018-04-03 18:49 k6mkf File Added: K6MKF Logbbok Memory Useage post-hang.JPG
2018-04-03 18:49 k6mkf Note Added: 0004647
2018-04-03 19:47 K7ZCZ Note Added: 0004648
2018-04-03 19:47 K7ZCZ Relationship added related to 0002089
2018-04-03 19:47 K7ZCZ Relationship added related to 0002098
2018-04-03 19:47 K7ZCZ Relationship deleted related to 0002089
2018-04-03 19:47 K7ZCZ Note Edited: 0004648 View Revisions
2018-04-04 11:11 PD9FER Note Added: 0004678
2018-04-04 11:28 k6mkf Note Added: 0004679
2018-04-04 11:41 K7ZCZ Note Added: 0004680
2018-04-04 11:54 k6mkf Note Added: 0004681
2018-04-04 14:59 WA9PIE Note Added: 0004688
2018-04-04 15:08 k6mkf Note Added: 0004690
2018-04-04 15:27 WA9PIE Target Version 6.4.0.797 =>
2018-04-06 11:21 WA9PIE Status resolved => closed
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:25 WA9PIE Fixed in Version 6.4.0.797 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806