View Issue Details

IDProjectCategoryView StatusLast Update
0002582Ham Radio DeluxeMaintenancepublic2018-04-09 14:37
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version1703
Product Version6.4.0.794 
Target VersionFixed in Version6.4.0.806 
Summary0002582: change flags to reduce mindump sizes
Description
Minidumps currently use these flags to prepare the dump: (MiniDumpWithPrivateReadWriteMemory | MiniDumpWithDataSegs | MiniDumpWithHandleData | MiniDumpWithFullMemoryInfo | MiniDumpWithThreadInfo |MiniDumpWithUnloadedModules), in addition to a data section filter.

Dump files from our application are pretty large, and a bit difficult for customers to upload. We should experiment with different flags and the data section filter to see if we can get good dumps that are smaller, but still usable for troubleshooting.

TagsNo tags attached.
ModuleAll
Sub-ModuleGeneral
Testing Not Tested

Relationships

Activities

K7ZCZ

2018-03-11 22:29

manager   ~0004476

I've added a dropdown to the "Preferences" page of the global program preferences (this is where temperature and distance units are selected). The dropdown lets the user choose small or large minidumps. Small minidumps are substantially smaller, but I worry that they won't be useful because they contain very little data. With some iteration, I can tune the flags further.

Until the settings are tuned (and maybe even after ...) particularly pesky bugs might require us to request the user reproduce the problem with "Large" selected. "Small" is selected by default.

This shelf set has been posted for review with these changes:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/shelveset?ss=mindump%20sizing%3Bmikeblas%40msn.com

K7ZCZ

2018-03-17 16:05

manager   ~0004506

fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3942

WA9PIE

2018-04-06 10:28

administrator   ~0004719

Maintenance items not testable by beta. Approved as-is.

Issue History

Date Modified Username Field Change
2018-03-08 14:09 K7ZCZ New Issue
2018-03-08 14:09 K7ZCZ Status new => assigned
2018-03-08 14:09 K7ZCZ Assigned To => K7ZCZ
2018-03-11 22:29 K7ZCZ Note Added: 0004476
2018-03-17 16:05 K7ZCZ Status assigned => resolved
2018-03-17 16:05 K7ZCZ Resolution open => fixed
2018-03-17 16:05 K7ZCZ Note Added: 0004506
2018-03-22 07:05 WA9PIE Target Version => 6.4.0.797
2018-03-22 07:06 WA9PIE Fixed in Version => 6.4.0.797
2018-04-04 15:27 WA9PIE Target Version 6.4.0.797 =>
2018-04-06 10:28 WA9PIE Note Added: 0004719
2018-04-06 10:28 WA9PIE Status resolved => closed
2018-04-06 10:29 WA9PIE Testing Not Started => Not Tested
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:25 WA9PIE Fixed in Version 6.4.0.797 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806