View Issue Details

IDProjectCategoryView StatusLast Update
0002595Ham Radio DeluxeBugpublic2018-04-09 14:37
ReporterWA9PIE 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.4.0.787 
Target VersionFixed in Version6.4.0.806 
Summary0002595: The data Logbook sends to HRDLOG.net is not complete (field QSO_Date and Time_On are missing)
DescriptionAccording to Claudio (creator of HRDLog.net and HRD Label), there is a condition that HRD Logbook (your program) send QSO data to HRDLOG.net (my web site) and the data is not complete (field QSO_Date and Time_On are missing).

My Logbook -> double click on a QSO -> change a value (for example RST Sent) -> press button "Update" then view Logfile

According to Chris (N4KIT), it happens when you have automatic HRDlog.net enabled and change a QSO is ALE:Modify. When the Update (F7) is clicked, the upload string is not properly constructed for QSO_DATE in the DELETE string.

To replicate this, an account on HRDLog.net is required.
Steps To Reproduce1. add a QSO
2. select the QSO
3. show QSL toolbar
4. select "Sent Yes" then press "Apply"
5. open the "Logfile"

23:55:24 WebLog Delete Submitted OK
23:55:24 WebLog Delete Upload data .: Cmd=DELETE&Callsign=IW1QLH&Code=1f1d3aa3c6&ADIFKey=<QSO_DATE:8>20170304+<CALL:6>IZ1YFQ+<BAND:3>40m+<FREQ:8>7.127000+<MODE:3>LSB+<RST_SENT:2>56+<RST_RCVD:2>59+<STATION_CALLSIGN:6>IW1QLH+<DXCC:3>248+<EOR> -
23:55:24 WebLog Delete Reply .......: <?xml version="1.0" ?><HrdLog xmlns="http://xml.hrdlog.com"><NewEntry><error>A key should contain at least: Call, QSO_Date, Time_On</error></NewEntry></HrdLog>
23:55:24 WebLog Delete Error .......: A key should contain at least: Call, QSO_Date, Time_On
23:55:24 WebLog Delete Status ......:
                         
23:55:24 WebLog Upload Submitted OK
23:55:24 WebLog Upload Upload data .: Callsign=IW1QLH&Code=1f1d3aa3c6&ADIFData=<CALL:6>IZ1YFQ+<BAND:3>40m+<FREQ:8>7.127000+<MODE:3>LSB+<RST_SENT:2>56+<RST_RCVD:2>59+<STATION_CALLSIGN:6>IW1QLH+<DXCC:3>248+<QSL_SENT:1>Y+<QSL_RCVD:1>N+<QSL_SENT_VIA:1>D+<EOR> -
23:55:24 WebLog Upload Reply .......: <?xml version="1.0" ?><HrdLog xmlns="http://xml.hrdlog.com"><NewEntry><error>Missing QSO_Date Time_On A record should contain at least: Call, QSO_Date, Time_On, Band, Mode</error></NewEntry></HrdLog>
23:55:24 WebLog Upload Error .......: Missing QSO_Date Time_On A record should contain at least: Call, QSO_Date, Time_On, Band, Mode
23:55:24 WebLog Upload Status ......:


Your software follow these steps to change the QSO:
send a DELETE command to delete the QSO having old data
send a INSERT command with new data
--- but ---

ERROR 1: DELETE - there isn't TIME_ON (HRDLOG.net needs this data to select the specific QSO)
To correct: send also TIME_ON

ERROR 2: INSERT - there isn't QSO_Date, TIME_On (HRDLOG.net needs all data because a new QSO is generated)
To correct: send also QSO_Date and TIME_On
TagsNo tags attached.
ModuleLogbook
Sub-ModuleHRDLog.net
Testing Beta Successful

Relationships

related to 0001879 closedK7ZCZ HRDlog.net issues 

Activities

K7ZCZ

2018-03-10 13:34

manager   ~0004462

Are further details available? The steps given in "Description" don't match the steps given in "Steps to reproduce". I can probably suss my way through it, but it is easier to make progress with clear information about the problem.

K7ZCZ

2018-03-10 16:38

manager   ~0004463

After some fuss:

1) I got some logbook data imported.
2) I created an HRDLog account
3) configured my new HRDLog account with HRD Logbook.
4) I edited a single QSO in the logbook, changing the RST from "" to "599".
5) Saved the QSO.
6) Observed this output in the HRD Logfile tab:

14:31:13 WebLog Delete Submitted OK
14:31:13 WebLog Delete Upload data .: Cmd=DELETE&Callsign=K7ZCZ&Code=d8b10980a0&ADIFKey=<QSO_DATE:8>20171227+<TIME_ON:6>162500+<CALL:5>KM7YG+<BAND:3>40m+<FREQ:8>7.074000+<MODE:3>FT8+<RST_SENT:3>599+<RST_RCVD:3>599+<DXCC:3>291+<DISTANCE:8>2202.784+<EOR> -
14:31:13 WebLog Delete Reply .......: <?xml version="1.0" ?><HrdLog xmlns="http://xml.hrdlog.com"><NewEntry><delete>3</delete></NewEntry></HrdLog>
14:31:13 WebLog Delete Error .......:
14:31:13 WebLog Delete Status ......:
                          
14:31:14 WebLog Upload Submitted OK
14:31:14 WebLog Upload Upload data .: Callsign=K7ZCZ&Code=d8b10980a0&ADIFData=<QSO_DATE:8>20171227+<TIME_ON:6>162500+<CALL:5>KM7YG+<BAND:3>40m+<FREQ:8>7.074000+<MODE:3>FT8+<RST_SENT:2>59+<RST_RCVD:3>599+<DXCC:3>291+<DISTANCE:8>0.000000+<QSL_SENT:1>N+<QSL_RCVD:1>N+<QSL_SENT_VIA:1>D+<EOR> -
14:31:14 WebLog Upload Status ......: 1

The errors here are probably because I have no log entries in my HRD Log account. I don't want to upload anything (because other users can see it) until I can properly figure out how to import all of my logs into HRD Logbook.

But it's pretty plain to see that the QSO_DATE and TIME_ON fields exist in the data sent to HRDLog.

I'm marking this not repro for now; if clearer instructions are available, or a lookbook database is available that has record which specifically can't be imported can be made available, I can take another crack at reproducing the problem.

K7ZCZ

2018-03-10 16:44

manager   ~0004464

I've added a record to HRDLog.net, and I can update it without a problem. As far as I can tell, we send the QSO_DATE and TIME_ON fields when they're available in the logbook record.

WA9PIE

2018-03-12 17:36

administrator   ~0004478

Here's a video from Claudio demonstrating the bug. It's related to updating existing QSOs.

https://youtu.be/dBD6CPcUh3s

K7ZCZ

2018-03-12 18:29

manager   ~0004479

Thanks! It looks like my error was to follow the steps in the "Description" rather than the "Steps to Reproduce".

In case the video disappears, here are written instructions

1) Start up the Logbook
2) Use the "Logfile" command in the "View" window to assure that a "Logfile" tab is available.
3) Open a logbook database.
4) Use the "HRD Log.net" command in the "Configure" tear-off of the "Tools" menu to set up an HRDLog.net account. The "Upload every time a logbook entry is added" checkbox must be marked.
5) In the Logbook database tab's toolbar, there's a "QSL" button with two down-chevrons in a circle. Click this top open the "QSL Status Toolbar"
6) Select a row in the logbook view window.
7) change the "Sent" dropdown in the "QSL Status Toolbar" to "Yes"
8) Press the "Apply" checkbox on the "Sent" side of the "QSL Status Toolbar".

The error message and communication with the server can be observed in the "Logfile" tab, as described above.

K7ZCZ

2018-03-13 09:37

manager   ~0004483

With a good repro in hand, I have a fix coded for this. It's pretty involved, so I want a bit more time to clean it up ... but should be able to check it in tonight or tomorrow.

K7ZCZ

2018-03-13 16:29

manager   ~0004484

Shelf set is here:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/shelveset?ss=fix%20HRDLog.net%20%28Mantis%202595%29%3Bmikeblas%40msn.com

K7ZCZ

2018-03-17 11:38

manager   ~0004503

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3973

WA9PIE

2018-03-22 17:15

administrator   ~0004527

Claudio reports that this is not completely fixed:

Mike,
still in error, in the "Upload data" the field QSO_Date is not present
:(


Claudio - IW1QLH

image.png (53,632 bytes)
image.png (53,632 bytes)

K7ZCZ

2018-03-22 17:54

manager   ~0004529

Uhoh. Definitely worked in testing, let me see if I can figure out what happened ...

K7ZCZ

2018-03-22 18:51

manager   ~0004530

reactivating

K7ZCZ

2018-03-22 18:51

manager   ~0004531

Dunno what went wrong; maybe I was just half-hearted in testing. Definitely fixed now, with this checkin.

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3988

vk2byi

2018-04-04 02:25

viewer   ~0004656

Successfully uploaded, modified and deleted a contact in HRDLog.Net with the Upload, Modify and Delete menu options on the File --> HRDLog.net right-click context menu.

Test case results from Logbook logfile attached. Fixed.

Test Case Result #0001879.txt (1,868 bytes)
Upload
======
17:13:42  WebLog Upload  Submitted OK
17:13:42  WebLog Upload  Upload data .: Callsign=VK2BYI&Code=xxxxxxxxxx&ADIFData=<QSO_DATE:8>20180403+<TIME_ON:6>070230+<CALL:5>KF8PD+<BAND:3>20m+<FREQ:9>14.076108+<MODE:3>FT8+<RST_SENT:3>+03+<RST_RCVD:3>+08+<STATION_CALLSIGN:6>VK2BYI+<GRIDSQUARE:6>EM54br+<DXCC:3>291+<DISTANCE:5>14530+<QSL_SENT:3>Yes+<QSL_RCVD:2>No+<QSL_SENT_VIA:6>Direct+<EOR> -
17:13:42  WebLog Upload  Status ......: 1


Modify (implemented as Delete then Upload)
==========================================
17:16:43  WebLog Delete  Submitted OK
17:16:43  WebLog Delete  Upload data .: Cmd=DELETE&Callsign=VK2BYI&Code=xxxxxxxxxx&ADIFKey=<QSO_DATE:8>20180403+<TIME_ON:6>070230+<CALL:5>KF8PD+<EOR> -
17:16:43  WebLog Delete  Reply .......: <?xml version="1.0" ?><HrdLog xmlns="http://xml.hrdlog.com"><NewEntry><delete>3</delete></NewEntry></HrdLog>
17:16:43  WebLog Delete  Error .......: 
17:16:43  WebLog Delete  Status ......: 
                         
17:16:43  WebLog Upload  Submitted OK
17:16:43  WebLog Upload  Upload data .: Callsign=VK2BYI&Code=xxxxxxxxxx&ADIFData=<QSO_DATE:8>20180403+<TIME_ON:6>070230+<CALL:5>KF8PD+<BAND:3>20m+<FREQ:9>14.076108+<MODE:3>FT8+<RST_SENT:3>+03+<RST_RCVD:3>+08+<STATION_CALLSIGN:6>VK2BYI+<GRIDSQUARE:6>EM54br+<DXCC:3>291+<DISTANCE:5>14530+<QSL_SENT:2>No+<QSL_RCVD:2>No+<QSL_SENT_VIA:6>Direct+<EOR> -
17:16:43  WebLog Upload  Status ......: 1


Delete
======
17:18:13  WebLog Delete  Submitted OK
17:18:13  WebLog Delete  Upload data .: Cmd=DELETE&Callsign=VK2BYI&Code=xxxxxxxxxx&ADIFKey=<QSO_DATE:8>20180403+<TIME_ON:6>070230+<CALL:5>KF8PD+<EOR> -
17:18:13  WebLog Delete  Reply .......: <?xml version="1.0" ?><HrdLog xmlns="http://xml.hrdlog.com"><NewEntry><delete>3</delete></NewEntry></HrdLog>
17:18:13  WebLog Delete  Error .......: 
17:18:13  WebLog Delete  Status ......: 

WA9PIE

2018-04-04 14:33

administrator   ~0004684

I'm going to give the 799 build to Claudio and have him also test it.

WA9PIE

2018-04-06 14:57

administrator   ~0004731

Claudio reports that this problem is resolved.

He does point out another minor thing that won't affect the operation of the software. (see image)

Claudio.PNG (11,852 bytes)
Claudio.PNG (11,852 bytes)

Issue History

Date Modified Username Field Change
2018-03-09 17:41 WA9PIE New Issue
2018-03-09 17:41 WA9PIE Status new => assigned
2018-03-09 17:41 WA9PIE Assigned To => K7ZCZ
2018-03-10 13:34 K7ZCZ Note Added: 0004462
2018-03-10 16:38 K7ZCZ Note Added: 0004463
2018-03-10 16:44 K7ZCZ Status assigned => resolved
2018-03-10 16:44 K7ZCZ Resolution open => unable to reproduce
2018-03-10 16:44 K7ZCZ Note Added: 0004464
2018-03-12 17:36 WA9PIE Note Added: 0004478
2018-03-12 17:37 WA9PIE Status resolved => assigned
2018-03-12 17:37 WA9PIE Resolution unable to reproduce => reopened
2018-03-12 18:29 K7ZCZ Note Added: 0004479
2018-03-13 09:37 K7ZCZ Note Added: 0004483
2018-03-13 16:29 K7ZCZ Note Added: 0004484
2018-03-17 11:38 K7ZCZ Status assigned => resolved
2018-03-17 11:38 K7ZCZ Resolution reopened => fixed
2018-03-17 11:38 K7ZCZ Note Added: 0004503
2018-03-17 11:39 K7ZCZ Relationship added related to 0001879
2018-03-22 07:05 WA9PIE Target Version => 6.4.0.797
2018-03-22 07:06 WA9PIE Fixed in Version => 6.4.0.797
2018-03-22 17:15 WA9PIE File Added: image.png
2018-03-22 17:15 WA9PIE Note Added: 0004527
2018-03-22 17:54 K7ZCZ Note Added: 0004529
2018-03-22 18:51 K7ZCZ Status resolved => feedback
2018-03-22 18:51 K7ZCZ Resolution fixed => reopened
2018-03-22 18:51 K7ZCZ Note Added: 0004530
2018-03-22 18:51 K7ZCZ Status feedback => resolved
2018-03-22 18:51 K7ZCZ Resolution reopened => fixed
2018-03-22 18:51 K7ZCZ Fixed in Version 6.4.0.797 =>
2018-03-22 18:51 K7ZCZ Note Added: 0004531
2018-04-02 10:40 K7ZCZ Fixed in Version => 6.4.0.798
2018-04-04 02:25 vk2byi File Added: Test Case Result #0001879.txt
2018-04-04 02:25 vk2byi Note Added: 0004656
2018-04-04 14:33 WA9PIE Note Added: 0004684
2018-04-04 15:27 WA9PIE Target Version 6.4.0.797 =>
2018-04-06 14:57 WA9PIE File Added: Claudio.PNG
2018-04-06 14:57 WA9PIE Note Added: 0004731
2018-04-06 14:58 WA9PIE Status resolved => closed
2018-04-06 14:58 WA9PIE Testing Not Started => Beta Successful
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:25 WA9PIE Fixed in Version 6.4.0.798 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806