View Issue Details

IDProjectCategoryView StatusLast Update
0002596Ham Radio DeluxeBugpublic2018-06-13 20:40
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status closedResolutionduplicate 
Product Version6.4.0.794 
Target VersionFixed in Version6.4.0.837 
Summary0002596: crash in Logbook with minidump
DescriptionPY3OG has provided the minidump in "PY3OG_HRDLogbook_20180306_141110.7z" that shows a crash when pressing OK in the Logbook's ALE window. The call stack is in the additional information area, below.

The crash is very similar to the crash in 2199, but not exactly the same. The 2199 crash is in OnReset(), while this crash is in OnOK(). The result is the same; the apparent dereference of a NULL this pointer while trying to call a method on a member object.


Steps To ReproduceNo repro steps are available; I'm working with the customers to attempt to get more information.

Additional Information0:000> kb
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr Args to Child
WARNING: Frame IP not in any known module. Following frames may be wrong.
00 0053f77c 01061983 0053f79c b834a655 77497c50 0x0
01 0053f7c8 01068c62 00762ed0 1ad3ea90 015ec39a HRDLogbook!CWnd::UpdateData+0x4d [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 4359]
02 0053f7d4 015ec39a b834a67d 00000111 00000000 HRDLogbook!CDialog::OnOK+0xa [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\dlgcore.cpp @ 798]
03 0053f87c 01064039 00000000 1ad3ea90 0053f8bc HRDLogbook!CLogbookFull::OnOK+0x3ba [c:\ham radio\logbook\hrdlogbook\logbookfull.cpp @ 4081]
04 0053f88c 01063e72 1ad3ea90 00000001 00000000 HRDLogbook!_AfxDispatchCmdMsg+0x42 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 78]
05 0053f8bc 01068af1 00000001 0175e788 00000000 HRDLogbook!CCmdTarget::OnCmdMsg+0x120 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 373]
06 0053f8e0 0105f7ea 00000001 00000000 00000000 HRDLogbook!CDialog::OnCmdMsg+0x1b [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\dlgcore.cpp @ 85]
07 0053f930 01060402 00000001 00000000 b834a875 HRDLogbook!CWnd::OnCommand+0x89 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2784]
08 0053f9e8 0102d4b6 00000111 00000001 00000000 HRDLogbook!CWnd::OnWndMsg+0x3c [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2108]
09 0053fa04 01061bf8 00000111 00000001 00000000 HRDLogbook!CXTPDialogBase<CXTPResizeDialog>::OnWndMsg+0x46 [c:\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpdialogbase.h @ 194]
0a 0053fa24 0105d2de 00000111 00000001 00000000 HRDLogbook!CWnd::WindowProc+0x22 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2094]
0b 0053fa94 0105da93 1ad3ea90 00050830 00000111 HRDLogbook!AfxCallWndProc+0xb0 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 285]
0c 0053fab4 7749e0bb 00050830 00000111 00000001 HRDLogbook!AfxWndProc+0x34 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 434]
0d 0053fae0 774a8849 0105da5f 00050830 00000111 user32!_InternalCallWinProc+0x2b
0e 0053fb04 774ab145 00000111 00000001 00000000 user32!InternalCallWinProc+0x20
0f 0053fbd4 774a833a 0105da5f 00000000 00000111 user32!UserCallWinProcCheckWow+0x1be
10 0053fc18 7748fbab 00000111 00000001 00000000 user32!CallWindowProcAorW+0xd4
11 0053fc30 012c3ebc 0105da5f 00050830 00000111 user32!CallWindowProcW+0x1b
12 0053fc78 7749e0bb 0105da5f 00000111 00000001 HRDLogbook!CXTPHookManager::HookWndProc+0xac [c:\hrdbranch\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\common\xtphookmanager.cpp @ 267]
13 0053fca4 774a8849 012c3e10 00050830 00000111 user32!_InternalCallWinProc+0x2b
14 0053fcc8 774ab145 00000111 00000001 00000000 user32!InternalCallWinProc+0x20
15 0053fd98 774990dc 012c3e10 00000000 00000111 user32!UserCallWinProcCheckWow+0x1be
16 0053fe04 77498c20 93d81e03 0053fe3c 01066cef user32!DispatchMessageWorker+0x4ac
17 0053fe10 01066cef 00762f00 00000000 0197f3d0 user32!DispatchMessageW+0x10
18 0053fe20 01067326 ffffffff 0197f3d0 0197f3d0 HRDLogbook!AfxInternalPumpMessage+0x3e [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\thrdcore.cpp @ 183]
19 0053fe3c 01484209 00000000 00000020 00000001 HRDLogbook!CWinThread::Run+0x57 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\thrdcore.cpp @ 629]
1a 0053fe50 01482a59 01020000 00000000 00751ce0 HRDLogbook!AfxWinMain+0x66 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\winmain.cpp @ 47]
1b 0053fe9c 773c8654 003aa000 773c8630 4d6933ea HRDLogbook!__tmainCRTStartup+0x12f [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c @ 618]
1c 0053feb0 779a4a77 003aa000 af590c5a 00000000 kernel32!BaseThreadInitThunk+0x24
1d 0053fef8 779a4a47 ffffffff 779c9ec6 00000000 ntdll!__RtlUserThreadStart+0x2f
1e 0053ff08 00000000 01482ad7 003aa000 00000000 ntdll!_RtlUserThreadStart+0x1b
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
TestingNot Started

Relationships

related to 0002199 closedK7ZCZ HRD Logbook stops responding 

Activities

K7ZCZ

2018-03-10 08:57

manager  

PY3OG_HRDLogbook_20180306_141110.zip (34,798,856 bytes)

K7ZCZ

2018-03-10 08:57

manager   ~0004461

attached minidump

K7ZCZ

2018-03-11 08:20

manager   ~0004467

Very similar (but not the same) call stack as 2199. Might be the same cause, might not ...

K7ZCZ

2018-04-10 11:14

manager   ~0004797

A recent call stack (pasted to 0002199) shows that this bug is a duplicate of 0002199.

Issue History

Date Modified Username Field Change
2018-03-10 08:56 K7ZCZ New Issue
2018-03-10 08:56 K7ZCZ Status new => assigned
2018-03-10 08:56 K7ZCZ Assigned To => K7ZCZ
2018-03-10 08:57 K7ZCZ File Added: PY3OG_HRDLogbook_20180306_141110.zip
2018-03-10 08:57 K7ZCZ Note Added: 0004461
2018-03-11 08:19 K7ZCZ Relationship added related to 0002199
2018-03-11 08:20 K7ZCZ Note Added: 0004467
2018-04-10 11:14 K7ZCZ Status assigned => resolved
2018-04-10 11:14 K7ZCZ Resolution open => duplicate
2018-04-10 11:14 K7ZCZ Note Added: 0004797
2018-04-13 10:22 WA9PIE Severity minor => crash
2018-05-03 20:10 K7ZCZ Fixed in Version => 6.4.0.837
2018-06-13 20:40 WA9PIE Status resolved => closed
2018-06-13 20:40 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe