View Issue Details

IDProjectCategoryView StatusLast Update
0002597Ham Radio DeluxeBugpublic2018-04-09 14:37
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version1703
Product Version6.4.0.794 
Target VersionFixed in Version6.4.0.806 
Summary0002597: Logbook's "About" box has broken link to user manual
DescriptionLooks like there's some sort of redirect happengin when users request manual.pdf from the website; problem is, that redirect is broken and it is hard to find the manual.

Steps To Reproduce1) start up the logbook
2) In the menu bar, press the "About" button

-or-

use the "About HRD Logbook..." command in the "Help" menu

3) The resulting "About HRD Logbook" window has a link labeled "wiki:" which has the text "http://www.ham-radio-deluxe.com/files/manual.pdf"

4) Click that link

BUG#1) You end up at your browser with an error because it got redirected to this URL: "https://www.ham-radio-deluxe.comhttp//cdn.ham-radio-deluxe.com/files/manual.pdf"

This is _not_ a problem with the link in the application because pasting "http://www.ham-radio-deluxe.com/files/manual.pdf" into your browser causes the same redirect to the same bogus URL.
TagsNo tags attached.
ModuleAll
Sub-ModuleDocumentation
Testing Beta Successful

Relationships

Activities

WA9PIE

2018-03-16 19:26

administrator   ~0004496

Let's change the link for the manual to https://wiki.Ham-Radio-Deluxe.com

K7ZCZ

2018-03-16 19:36

manager   ~0004497

fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3950

vk2byi

2018-03-23 18:46

viewer   ~0004551

Verified all links are correct in HRD Logbook About box.

g3ucq

2018-03-26 03:20

viewer   ~0004580

All links work correctly.

Issue History

Date Modified Username Field Change
2018-03-10 14:19 K7ZCZ New Issue
2018-03-10 14:19 K7ZCZ Status new => assigned
2018-03-10 14:19 K7ZCZ Assigned To => WA9PIE
2018-03-16 19:26 WA9PIE Note Added: 0004496
2018-03-16 19:26 WA9PIE Assigned To WA9PIE => K7ZCZ
2018-03-16 19:36 K7ZCZ Status assigned => resolved
2018-03-16 19:36 K7ZCZ Resolution open => fixed
2018-03-16 19:36 K7ZCZ Note Added: 0004497
2018-03-22 07:05 WA9PIE Target Version => 6.4.0.797
2018-03-22 07:06 WA9PIE Fixed in Version => 6.4.0.797
2018-03-23 18:46 vk2byi Note Added: 0004551
2018-03-26 03:20 g3ucq Note Added: 0004580
2018-03-30 19:44 WA9PIE Description Updated View Revisions
2018-03-30 19:44 WA9PIE Steps to Reproduce Updated View Revisions
2018-03-30 19:44 WA9PIE Testing Not Started => Beta Successful
2018-04-04 14:29 WA9PIE Status resolved => closed
2018-04-04 15:28 WA9PIE Target Version 6.4.0.797 =>
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:25 WA9PIE Fixed in Version 6.4.0.797 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806