View Issue Details

IDProjectCategoryView StatusLast Update
0002627Ham Radio DeluxeBugpublic2019-01-16 22:05
ReporterKB3NPH 
Assigned ToK7ZCZ 
PriorityhighSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0002627: Miscellaneous fixes for FT-991 Rig Control
DescriptionDan posted 03/23/2018 11:01 AM
Hi Tim
My version is 6.4.0.794 for the purpose of record keeping.

OK. I have examined and created a list of items that I think Programmers should look at for the FT-991 Rig Control. It is based on the features that are important to me. I cannot immediately comment on other features. However, these issues do seem to be pretty important features and I do not mind wringing these out as a test person if it will be beneficial to all of your customers who use HRD Rig Control.
Here is my list:

1) APF feature : Needs to be Coded as a button ON/OFF
3) 101 Data Output Slider : Set it and it reverts back to zero
4) APF Slider : Set it and it reverts back to zero
5) Contour Width Slider: Set it and it reverts back to zero
If I find other things , I will happily report them to you.

Please advise on the items above and please submit to Programmers.
Thanks much
73
Dan
Additional InformationTicket #316751
TagsFT-991, FT-991A, Yaesu
ModuleRig Control
Sub-ModuleFunctional
Testing Beta Successful

Relationships

duplicate of 0002631 closedK7ZCZ FT-991A Inoperative Sliders 
duplicate of 0002986 closedK7ZCZ Rig Control: APF and Contour on/off buttons don't work for FT-991 
related to 0002760 closedK7ZCZ FT-991 firmware upgrade makes HRD unusable 

Activities

K7ZCZ

2018-12-13 13:56

manager   ~0006614

Most of these issues are duplicates:
1) This is a duplicate of 2986
2) There is no #2.
3) This is an issue.
4) This is a duplicate of 2631.
5) This is a duplicate of 2631.


In the future, please open one issue for each problem. It's never too hard to resolve something duplicate, but it is quite tedious (and therefore error prone) to track several different problems in a single Mantis issue.

K7ZCZ

2018-12-13 14:06

manager   ~0006616

Last edited: 2018-12-13 14:07

View 2 revisions

This issue mentions only one RTTY parameter control. They were all renumbered in a recent firmware update from the manufacturer for this radio. See Mantis 2760.

K7ZCZ

2018-12-13 14:10

manager   ~0006617

RTTY sliders (only) are fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4557

WA9PIE

2018-12-17 11:57

administrator   ~0006694

I removed ticket number from the Summary and placed it in Additional Information.

WA9PIE

2019-01-01 21:21

administrator   ~0006834

Validated

WA9PIE

2019-01-02 12:37

administrator   ~0006863

Changing status back to Beta Failed after seeing the APF return to zero. All this is referenced on page 58 of the FT-991A operating manual (rig must be in CW mode for APF to function). But otherwise it will return to zero.

Issue History

Date Modified Username Field Change
2018-03-27 20:46 KB3NPH New Issue
2018-03-28 23:16 K7ZCZ Tag Attached: FT991
2018-03-28 23:16 K7ZCZ Tag Attached: Yaesu
2018-11-27 11:56 WA9PIE Tag Attached: FT-991
2018-11-29 00:17 WA9PIE Tag Attached: Yaesu FT-991(A)
2018-11-29 00:19 WA9PIE Tag Detached: FT-991
2018-11-29 00:19 WA9PIE Tag Detached: FT991
2018-11-29 00:19 WA9PIE Tag Detached: Yaesu
2018-11-30 18:12 WA9PIE Tag Attached: Yaesu
2018-11-30 18:13 WA9PIE Tag Attached: FT-991
2018-11-30 18:14 WA9PIE Tag Attached: FT-991A
2018-11-30 18:23 WA9PIE Tag Detached: FT-991A
2018-11-30 18:23 WA9PIE Tag Detached: Yaesu FT-991(A)
2018-12-13 00:01 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-12-13 13:18 K7ZCZ Tag Attached: FT-991A
2018-12-13 13:56 K7ZCZ Note Added: 0006614
2018-12-13 13:59 K7ZCZ Relationship added related to 0002986
2018-12-13 13:59 K7ZCZ Relationship added duplicate of 0002631
2018-12-13 13:59 K7ZCZ Relationship deleted related to 0002986
2018-12-13 13:59 K7ZCZ Relationship added duplicate of 0002986
2018-12-13 14:05 K7ZCZ Relationship added related to 0002760
2018-12-13 14:06 K7ZCZ Note Added: 0006616
2018-12-13 14:07 K7ZCZ Note Edited: 0006616 View Revisions
2018-12-13 14:10 K7ZCZ Assigned To => K7ZCZ
2018-12-13 14:10 K7ZCZ Status new => resolved
2018-12-13 14:10 K7ZCZ Resolution open => fixed
2018-12-13 14:10 K7ZCZ Note Added: 0006617
2018-12-14 17:10 K7ZCZ Fixed in Version => 6.5.0.137
2018-12-17 11:57 WA9PIE Summary Ticket #316751 - Miscellaneous fixes for FT-991 Rig Control => Miscellaneous fixes for FT-991 Rig Control
2018-12-17 11:57 WA9PIE Additional Information Updated View Revisions
2018-12-17 11:57 WA9PIE Note Added: 0006694
2019-01-01 21:21 WA9PIE Status resolved => closed
2019-01-01 21:21 WA9PIE Testing Not Started => Beta Successful
2019-01-01 21:21 WA9PIE Note Added: 0006834
2019-01-02 12:37 WA9PIE Status closed => resolved
2019-01-02 12:37 WA9PIE Testing Beta Successful => Beta Failed
2019-01-02 12:37 WA9PIE Note Added: 0006863
2019-01-02 12:45 WA9PIE Status resolved => closed
2019-01-02 12:45 WA9PIE Testing Beta Failed => Beta Successful
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.137 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe