View Issue Details

IDProjectCategoryView StatusLast Update
0002630Ham Radio DeluxeEnhancementpublic2019-11-07 05:35
ReporterKB3NPHAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0002630: Implement button access to Voice Recordings Playback Bank, 5 memories, using CAT Command PB Play Back (Yaesu)
DescriptionTicket #275105

Dan posted 03/27/2018 3:22 PM
Please implement button access to Voice Recordings Playback Bank, 5 memories, using CAT Command PB Play Back

Please assign each to it's own button.

Necessary for Contesting and DXing

Dan
TagsFT-991A, Yaesu
ModuleRig Control
Sub-ModuleFunctional
Testing Beta Successful

Activities

K7ZCZ

2018-12-15 13:29

administrator   ~0006662

I've added a drop-dwon for the VOX playback memories. This doesn't work perfectly due to a bug in the radio; querying playback state with "PB0" reports "PB00" if playback is stopped, and also uses the resposne of "PB00" to indicate that playback of message 1 is running.

K7ZCZ

2018-12-15 13:32

administrator   ~0006663

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4570

WA9PIE

2018-12-17 11:55

administrator   ~0006691

I just edited the Summary because it contained a ticket number and had no "summary" of the request.

WA9PIE

2019-01-09 14:56

administrator   ~0006925

I just tested this successfully. This is a VERY cool thing.

NOTE: While the memories are clearly saved to the point where you can see them in Rig Control (when you return to that dialog box), and you can exercise them with the proper buttons on the rig, I found it interesting that they're not stored in Menus 18, 19, 20,21, & 22. I expected that... but maybe that's not the way it works.

But as for what this feature does... it's working. Very cool. I need to buy one of those external keypads for the rig from Yaesu.

Issue History

Date Modified Username Field Change
2018-03-27 21:02 KB3NPH New Issue
2018-03-28 23:14 K7ZCZ Tag Attached: FT991A
2018-03-28 23:14 K7ZCZ Tag Attached: Yaesu
2018-11-27 11:56 WA9PIE Tag Attached: FT-991
2018-11-29 00:17 WA9PIE Tag Attached: Yaesu FT-991(A)
2018-11-29 00:18 WA9PIE Tag Detached: FT-991
2018-11-29 00:18 WA9PIE Tag Detached: FT991A
2018-11-29 00:18 WA9PIE Tag Detached: Yaesu
2018-11-30 18:12 WA9PIE Tag Attached: Yaesu
2018-11-30 18:13 WA9PIE Tag Attached: FT-991
2018-11-30 18:14 WA9PIE Tag Attached: FT-991A
2018-11-30 18:16 WA9PIE Tag Detached: FT-991
2018-11-30 18:16 WA9PIE Tag Detached: Yaesu FT-991(A)
2018-12-15 13:29 K7ZCZ Note Added: 0006662
2018-12-15 13:32 K7ZCZ Assigned To => K7ZCZ
2018-12-15 13:32 K7ZCZ Status new => resolved
2018-12-15 13:32 K7ZCZ Resolution open => fixed
2018-12-15 13:32 K7ZCZ Note Added: 0006663
2018-12-15 16:17 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-12-17 11:55 WA9PIE Summary Ticket #275105 - FT-991A - Voice Memories in Rig Control => Implement button access to Voice Recordings Playback Bank, 5 memories, using CAT Command PB Play Back
2018-12-17 11:55 WA9PIE Description Updated View Revisions
2018-12-17 11:55 WA9PIE Note Added: 0006691
2018-12-27 16:42 WA9PIE Fixed in Version => 6.5.0.161
2019-01-09 14:56 WA9PIE Status resolved => closed
2019-01-09 14:56 WA9PIE Testing Not Started => Beta Successful
2019-01-09 14:56 WA9PIE Note Added: 0006925
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.161 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-01-25 14:13 WA9PIE Summary Implement button access to Voice Recordings Playback Bank, 5 memories, using CAT Command PB Play Back => Implement button access to Voice Recordings Playback Bank, 5 memories, using CAT Command PB Play Back (Yaesu)
2019-11-07 05:35 WA9PIE Fixed in Version 6.5.0.183 => 6.5.0.196