View Issue Details

IDProjectCategoryView StatusLast Update
0002648Ham Radio DeluxeEnhancementpublic2019-11-07 05:35
ReporterPD9FERAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0002648: Logbook: enable Filter to look inbetween QSO Dates
DescriptionCustomer Request
I would like to filter logbook QSOs between 2 dates, eg 1st Jan 2012 and 31st December 2012 or 1st January 2018 and 31st March 2018
Steps To ReproduceN/A
At this time this option is not available.
Additional InformationTicket #771100
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Beta Successful

Relationships

related to 0000460 assignedWA9PIE 1 - Backlog Logbook database fields not all available for Filter 

Activities

WA9PIE

2018-04-03 10:47

administrator   ~0004633

Ferry - isn't this already possible?

PD9FER

2018-04-03 10:51

viewer   ~0004634

Not that I am aware of.
I tried to do the same here, but can't find any option.

K7ZCZ

2018-12-10 15:16

administrator   ~0006568

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4537

Filtering on date fields is now possible.

WA9PIE

2018-12-11 01:05

administrator   ~0006569

I moved this from the Backlog because it appear to have been coded, but didn't show up in the change log (because Backlog doesn't have any versions to populate into FIV.) It should show up now.

g3ucq

2018-12-12 13:53

viewer   ~0006591

What is the correct syntax to show in between dates?
My test.
The first filter is QSO date/Since/01/11/2018 and the 2nd filter And QSO date/Before/02/12/2018.
The result is QSO dates from 01/11/2018 to 11/12/2018. ?

PD9FER

2018-12-20 15:23

viewer   ~0006737

Testing this one

g3ucq

2018-12-21 05:23

viewer   ~0006766

The first filter seems to work as it should but the second AND filter does not.

PD9FER

2018-12-21 05:57

viewer   ~0006769

Tested in 6.5.0.161
Can only input one field when choosing "Between"
See attached screenshot.

Date.png (92,653 bytes)
Date.png (92,653 bytes)

g3ucq

2018-12-21 06:07

viewer   ~0006771

I was using the Field options Since/Between etc. by selecting the 'QSO date' field as a filter.

PD9FER

2018-12-21 06:40

viewer   ~0006773

Looks like that field is gone in build 161...
Can you attach a screenshot John?

g3ucq

2018-12-21 06:55

viewer   ~0006774

Ferry. If you mean the Date field then that is visible.
I used the other filters to try to get the result I wanted.

K7ZCZ

2018-12-21 09:41

administrator   ~0006775

This checkin fixes a couple of loose ends in the filter implementation.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4636


When a build includes this code, you should be able to search for QSOs between two dates (or, dates on any field ...) by doing this:

1) Open the filter bar
2) Mark the first "Field" checkbox
3) Select the "QSO date" field there
4) Select "Since" in the Match field
5) Select the beginning date value in the "Value" field
6) In the next field, mark the "And" button
7) Select the "QSO Date" field there, too
8) Select "Before" for the Match type
9) Select the ending date you want in the "Value" field
10) Press "Apply"

Since "Before" indicates the end of the range, the date given for "Before" should be newer than the date given for "Since".


Thanks for testing! :)

g3ucq

2018-12-21 10:03

viewer   ~0006777

In the first "Field" I have QSO date/Since/01/12/2018
In the 2nd field I have And/QSO date/Before/07/12/2018
The newest date shown is 21/12/2018 but the oldest is 01/12/2018.
See the attached image.

filter.JPG (117,557 bytes)
filter.JPG (117,557 bytes)

K7ZCZ

2018-12-21 10:59

administrator   ~0006782

When I said "When a build includes this code", I meant that you'll need a build with the newest change for this to work. Testing now won't teach us much. Please wait for the next beta build for further test.

g3ucq

2018-12-21 11:04

viewer   ~0006783

When you said "Thanks for testing! :) " I thought you meant to keep testing and had failed to read all your post. Sorry.

WA9PIE

2019-01-01 22:53

administrator   ~0006850

I tried testing this in the 164 build and I don't see "Between" in the drop-down.

PD9FER

2019-01-02 01:10

viewer   ~0006851

Tested build 164
The Between line is removed I guess.
The way described by Mike-B works, but is sensitive for operator error.
However it is functional.

PD9FER

2019-01-02 03:34

viewer   ~0006852

The Reporter of Ticket #771100 confirms the Enhancement as working in 6.5.0.164

g3ucq

2019-01-02 03:47

viewer   ~0006853

Confirm this works as described in -0006775.
Instead of 'Since' and 'Before' would 'From' and 'To' be better?
It might make more sense to those who do not speak English as a first language.

WA9PIE

2019-01-03 15:35

administrator   ~0006868

With Between removed... the other filters with Before and After do work.

The problem with this could be that it takes away two filter options that could otherwise be used to slim down the results even further.

But as it is - we'll take it as validated as designed.

Issue History

Date Modified Username Field Change
2018-04-03 04:11 PD9FER New Issue
2018-04-03 10:47 WA9PIE Note Added: 0004633
2018-04-03 10:51 PD9FER Note Added: 0004634
2018-12-10 15:12 K7ZCZ Relationship added related to 0000460
2018-12-10 15:16 K7ZCZ Assigned To => K7ZCZ
2018-12-10 15:16 K7ZCZ Status new => resolved
2018-12-10 15:16 K7ZCZ Resolution open => fixed
2018-12-10 15:16 K7ZCZ Testing => Not Started
2018-12-10 15:16 K7ZCZ Note Added: 0006568
2018-12-11 01:04 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-12-11 01:05 WA9PIE Fixed in Version => 6.5.0.132
2018-12-11 01:05 WA9PIE Note Added: 0006569
2018-12-12 13:53 g3ucq Note Added: 0006591
2018-12-20 15:23 PD9FER Note Added: 0006737
2018-12-21 05:23 g3ucq Note Added: 0006766
2018-12-21 05:57 PD9FER File Added: Date.png
2018-12-21 05:57 PD9FER Note Added: 0006769
2018-12-21 06:07 g3ucq Note Added: 0006771
2018-12-21 06:40 PD9FER Note Added: 0006773
2018-12-21 06:55 g3ucq Note Added: 0006774
2018-12-21 09:41 K7ZCZ Note Added: 0006775
2018-12-21 09:41 K7ZCZ Fixed in Version 6.5.0.132 =>
2018-12-21 10:03 g3ucq File Added: filter.JPG
2018-12-21 10:03 g3ucq Note Added: 0006777
2018-12-21 10:59 K7ZCZ Note Added: 0006782
2018-12-21 11:04 g3ucq Note Added: 0006783
2018-12-27 16:41 WA9PIE Fixed in Version => 6.5.0.163
2019-01-01 22:53 WA9PIE Note Added: 0006850
2019-01-02 01:10 PD9FER Note Added: 0006851
2019-01-02 03:34 PD9FER Note Added: 0006852
2019-01-02 03:47 g3ucq Note Added: 0006853
2019-01-03 15:35 WA9PIE Status resolved => closed
2019-01-03 15:35 WA9PIE Fixed in Version 6.5.0.163 => 6.5.0.164
2019-01-03 15:35 WA9PIE Testing Not Started => Beta Successful
2019-01-03 15:35 WA9PIE Note Added: 0006868
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.164 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-11-07 05:35 WA9PIE Fixed in Version 6.5.0.183 => 6.5.0.196