View Issue Details

IDProjectCategoryView StatusLast Update
0002649Ham Radio DeluxeBugpublic2018-05-13 15:26
Reporterg3ucq 
Assigned ToK7ZCZ 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0002649: Award Tracking investigation
DescriptionWith Award Tracking open, digging down causes Award Tracking and the Logbook to stop responding.
Steps To ReproduceOpen Logbook and select Award Tracking.
Click on an Award Program e.g. ARRL DXCC (PIE3).
Click on 'Need QSL'
Double click a Country.
Award Tracking and the Logbook will stop responding.
It seems that clicking any column will cause the same result.
Additional InformationNo mini dump file was created so I have added a video file.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleAwards
Testing Beta Successful

Relationships

Activities

g3ucq

2018-04-04 04:25

viewer  

G3UCQ_Award Tracking.zip (3,114,248 bytes)

g3ypp

2018-04-04 05:28

viewer   ~0004667

I can replicate that. Crashes every time. Minidump created. I'll put it in dropbox

g3ypp

2018-04-05 12:00

viewer   ~0004702

Here is my minidump file

G3YPP_Mantis_2649_HRDLogbook_20180404_103003.zip (271,628 bytes)

g3ucq

2018-04-05 12:39

viewer   ~0004703

Crashed on demand. My mini dump file

G3UCQ_HRDLogbook_20180405_173643.zip (212,496 bytes)

K7ZCZ

2018-04-05 13:16

manager   ~0004704

fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4021

K7ZCZ

2018-04-05 13:16

manager   ~0004705

Thanks for the clear report!

g3ucq

2018-04-07 03:06

viewer   ~0004738

Fixed but parts of other windows are shown during the search. Can that be cleared up?
See image

Capture.JPG (46,107 bytes)
Capture.JPG (46,107 bytes)

K7ZCZ

2018-04-07 13:03

manager   ~0004749

Sorry, but it'll probably be a while before redraw issues can become a priority. If you'd like to track it, feel free to open another issue with a clear repro case and a description of the issue.

WA9PIE

2018-04-11 14:51

administrator   ~0004802

I don't see us supporting "ARRL DXCC (PIE3)" because it was a test. Drop that award and use "ARRL DXCC (HRD)" instead. If it works, we're good.

g3ucq

2018-04-11 15:01

viewer   ~0004803

I deleted the PIE3 Awards a few days ago and have no problems with any of the remaining Awards.
Fixed

g3ucq

2018-05-04 10:47

viewer   ~0004940

Fixed

WA9PIE

2018-05-12 01:08

administrator   ~0005003

Closed and waiting on May 2018 release.

Issue History

Date Modified Username Field Change
2018-04-04 04:25 g3ucq New Issue
2018-04-04 04:25 g3ucq File Added: G3UCQ_Award Tracking.zip
2018-04-04 05:28 g3ypp Note Added: 0004667
2018-04-05 10:36 K7ZCZ Assigned To => K7ZCZ
2018-04-05 10:36 K7ZCZ Status new => assigned
2018-04-05 12:00 g3ypp File Added: G3YPP_Mantis_2649_HRDLogbook_20180404_103003.zip
2018-04-05 12:00 g3ypp Note Added: 0004702
2018-04-05 12:39 g3ucq File Added: G3UCQ_HRDLogbook_20180405_173643.zip
2018-04-05 12:39 g3ucq Note Added: 0004703
2018-04-05 13:16 K7ZCZ Status assigned => resolved
2018-04-05 13:16 K7ZCZ Resolution open => fixed
2018-04-05 13:16 K7ZCZ Testing => Not Started
2018-04-05 13:16 K7ZCZ Note Added: 0004704
2018-04-05 13:16 K7ZCZ Note Added: 0004705
2018-04-07 03:06 g3ucq File Added: Capture.JPG
2018-04-07 03:06 g3ucq Note Added: 0004738
2018-04-07 13:03 K7ZCZ Note Added: 0004749
2018-04-11 14:51 WA9PIE Note Added: 0004802
2018-04-11 15:01 g3ucq Note Added: 0004803
2018-04-12 17:06 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-04-13 10:22 WA9PIE Severity major => crash
2018-05-03 20:10 K7ZCZ Fixed in Version => 6.4.0.837
2018-05-04 10:47 g3ucq Note Added: 0004940
2018-05-12 01:07 WA9PIE Testing Not Started => Beta Successful
2018-05-12 01:08 WA9PIE Note Added: 0005003
2018-05-12 01:08 WA9PIE Status resolved => closed
2018-05-13 15:25 WA9PIE Fixed in Version 6.4.0.837 => 6.4.0.840
2018-05-13 15:26 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe