View Issue Details

IDProjectCategoryView StatusLast Update
0002653Ham Radio DeluxeBugpublic2019-03-06 20:07
Reporterk6mkfAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformOSWindowsOS VersionWindows 10 Pro64
Product Version 
Target VersionFixed in Version2018-07-23_Retest 
Summary0002653: v6.4.0.799 (Beta) hangs on ALE add from DX Cluster and ALE add
Descriptionv.799 - ALE from DX Cluster spot still having issues.

Logbook hangs when:

1. Create ALE from DX Cluster spot (right-click)
2. Add the log entry from the ALE thus created.
3. Logbook hangs with the pale screen of impending death

DMP file taken and uploaded to \Dropbox\Ham Radio Deluxe as K6MKF HRDLogbook 20180403.zip

This hang also occurs when an ALE window is opened with the 'Add' button to open an new ALE.

Also, while in the 'Not Responding' state, the Logbook process is acquiring .2MB of memory every second, according to Task Manager.
Steps To Reproduce1. Create ALE from DX Cluster spot (right-click)
2. Add the log entry from the ALE thus created.
3. Logbook hangs with the pale screen of impending death
Additional InformationLogbook hangs with every attempt to add a log entry through ALE. No other Beta Testers report this issue, and I am wondering if my implementation of v.799 is somehow unique. If not, then other HRD users may also be impacted by this issue.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
TestingNot Started

Activities

k6mkf

2018-04-06 13:12

viewer   ~0004730

Further finding with this issue. The main Logbook window has disappeared, leaving only the ALE window. It is not present in the task bar either. Other characteristics of this issue appear unchanged.

Logbook Main Disappears.jpg (298,184 bytes)

k6mkf

2018-04-07 09:25

viewer   ~0004745

Still an issue here on my Beta laptop with Beta v.803. Main Logbook window is gone. ALE window pale and not responding. Memory for Logbook process increasing by .2MB each second.

k6mkf

2018-04-07 20:49

viewer   ~0004755

Still an issue here on my Beta laptop with the newly released v6.4.0.805.

Main Logbook window is gone. ALE window pale and not responding.

Memory for Logbook process increasing by .2MB each second.

Until I can get some help figuring out why this is failing on my Windows 10 Home 64-bit laptop, I'll be useless to the Beta test efforts going forward.

g3ucq

2018-04-09 15:05

viewer   ~0004784

I have been reporting the same issue in 0002199 for ages. It is also happening in v806.

K7ZCZ

2018-04-16 18:46

administrator   ~0004847

This issue is not the same as 2199:

2199 is a crash; this issue isn't.
2199 has a minidump; this issue doesn't.
2199 doesn't involve the DX Cluster. This issue does.

g3ucq

2018-04-17 02:52

viewer   ~0004848

As the ALE seems to be the common factor that is why I said it was the same issue.

K7ZCZ

2018-04-17 05:35

administrator   ~0004849

I don't think that 2199 and this issue have the same cause. Please continue to help me work them separately.

g3ucq

2018-04-17 05:46

viewer   ~0004850

Certainly. Will do.

WA9PIE

2018-06-14 00:35

administrator   ~0005310

Can anyone replicate this?

g3ucq

2018-06-24 04:09

viewer   ~0005422

No problem now.

WA9PIE

2018-06-30 00:21

administrator   ~0005556

These items were retested and found to be resolved/fixed.

Issue History

Date Modified Username Field Change
2018-04-04 10:19 k6mkf New Issue
2018-04-06 13:12 k6mkf File Added: Logbook Main Disappears.jpg
2018-04-06 13:12 k6mkf Note Added: 0004730
2018-04-07 09:25 k6mkf Note Added: 0004745
2018-04-07 20:49 k6mkf Note Added: 0004755
2018-04-09 15:05 g3ucq Note Added: 0004784
2018-04-16 18:46 K7ZCZ Note Added: 0004847
2018-04-17 02:52 g3ucq Note Added: 0004848
2018-04-17 05:35 K7ZCZ Note Added: 0004849
2018-04-17 05:46 g3ucq Note Added: 0004850
2018-04-25 23:27 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-06-14 00:35 WA9PIE Note Added: 0005310
2018-06-23 18:18 WA9PIE Project 3 - Current Dev List => Issues Needing Retest
2018-06-23 18:18 WA9PIE Category Bug => General
2018-06-23 23:13 WA9PIE Category General => Bug
2018-06-24 04:09 g3ucq Note Added: 0005422
2018-06-24 19:07 WA9PIE Status new => resolved
2018-06-24 19:07 WA9PIE Resolution open => unable to reproduce
2018-06-24 19:07 WA9PIE Testing => Not Started
2018-06-30 00:20 WA9PIE Project Issues Needing Retest => Ham Radio Deluxe
2018-06-30 00:20 WA9PIE Fixed in Version => 6.4.0.846.a
2018-06-30 00:21 WA9PIE Note Added: 0005556
2018-06-30 00:21 WA9PIE Status resolved => closed
2019-03-06 20:07 WA9PIE Fixed in Version 6.4.0.846.a => 2018-07-23_Retest