View Issue Details

IDProjectCategoryView StatusLast Update
00026575 - Closed w/o ActionEnhancementpublic2019-09-14 01:59
ReporterPD9FERAssigned ToPD9FER 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Summary0002657: Request: option to turn off Tool Tips
DescriptionCustomer comment:
The way I look at it is the buttons already tell me what the function is. I don't need a popup getting the way of what I can already see. Plus, if the tip pops up over the button I want to click on, it gets in the way - prevents me from clicking... I have defined quite a few buttons with macros, so the button I have defined for, let's say, turning on the RIT (clearly says RIT ON on the button face) the tool tip says something like "Defines as RIT ON" (or something like that - I'm at work right now and can't see the actual tip) - I find this to be really annoying
Additional InformationTicket #158237

Initially, the customer asked turning them off in Rig Control
Would be better to implement this in all applications.
 
There seems to be an option in logbook to turn them off (see screenshot)
TagsNo tags attached.
ModuleAll
Sub-ModuleAppearance/UI
TestingNot Started

Relationships

related to 0003256 feedbackK7ZCZ 3 - Current Dev List What is the minimum screen size (in pixels) that HRD supports? 
has duplicate 0003031 closedWA9PIE 5 - Closed w/o Action Add option to disable tool tips in Rig Control 
has duplicate 0003246 closedK7ZCZ 5 - Closed w/o Action V6.5.0.199 Need way to turn off Tooltips in Rig Control 
related to 0003411 closedPD9FER 3 - Current Dev List Add option to turn off tool tips in Rig Control app 
related to 0003412 closedPD9FER 3 - Current Dev List Add option to turn off tool tips in DM780 application 
related to 0003413 closedPD9FER 3 - Current Dev List Add an option to turn off tool tips in Logbook application 
related to 0003414 closedPD9FER 3 - Current Dev List Add an option to Satellite Tracking to turn off tool tips in the application 
related to 0003415 closedPD9FER 3 - Current Dev List Add an option to HRD Rotator to turn off tool tips in the application 
related to 0003416 closedPD9FER 3 - Current Dev List Add an option to the Mapper application to turn off tool tips in the application 

Activities

PD9FER

2018-04-06 04:13

updater  

image.png (55,807 bytes)
image.png (55,807 bytes)

K7ZCZ

2019-02-01 18:28

administrator   ~0007210

Seems like we need to do a little bit of specification to get this fixed: specifically which tool tips should be configurable?

I think there are three groups of tool tips in the application. One is shown on menu items when the mouse is hovered over them. Another group is attached to toolbar buttons, and appears when the mouse is hovered over those. A third is over the radio controls themselves -- anything in the radio view.

Are there other groups? Different ways to identify groups of buttons? Which do we want to be able to enable or disable?

K7ZCZ

2019-02-01 18:29

administrator   ~0007211

Also, if we want to do this for all applications, it would be best to open a Mantis issue for each application. The scope for each application would be different depending on the design of the application and the desired effect of the feature in that application.

PD9FER

2019-03-13 15:51

updater   ~0007683

Just have a option in all applications to turn Tool Tips off
That will be sufficient enough.
So disable all Hover over txt when disabled,

PD9FER

2019-03-21 15:30

updater   ~0007714

The closed 0003246 has some more additional info regarding Tool Tips covering up Buttons, rendering them inusable

K7ZCZ

2019-03-21 15:33

administrator   ~0007715

In the Triage meeting of 2019-03-21, we identified a couple questions:

There was some question about other applications having an option to hide tooltips, but nobody was sure if it did or not. It would help to know if other applications do (or don't) have those options, and the location of that option in each app.

The scope of this issue is also unclear. Is it to fix Rig Control (as in the title) or "all applications" (as in comment #7683)?

K7ZCZ

2019-03-28 16:40

administrator   ~0007786

In the Triage meeting of 2019-03-28, we agreed that Ferry would find answers to the above questions. I've re-written them here for clarity:

1) Are there other applications in the suite which have an option to disable tooltips for that application? If so, where are those options found, and in which applications. It helps to affirmatively indicate the absence of such an option.

2) Are we intending to switch of all tool tips, suite-wide, from one setting? Or is the intention that each application has itso wn option, local to that application, to switch off tool tips for the application?

3) If we're considering turning off tool-tips for other applications, we should consider scope for those applications, as well. (That is, the same question as comment #7210 applies for each application. Every tool tip? Just ones in certain windows? A set of options for each group of tool tips? Something else ... ?)

K7ZCZ

2019-07-25 14:40

administrator   ~0008266

Are you making progress on answering these questions, Ferry? It's been about four months since the last update.

PD9FER

2019-07-25 14:42

updater   ~0008268

I think I have told already to make it an option in all suites to turn off Tool Tips

K7ZCZ

2019-07-25 18:49

administrator   ~0008274

That answers #1 and #2. What about #3?

PD9FER

2019-07-26 03:33

updater   ~0008281

First of all, we do not need to turn the Tooltips Off. We need a toggle between Show and Hide (enable/disable)
This should be selectable in every app of the suite.
In my opinion a Tooltip is a Tooltip, so this applies to All Tooltips.

K7ZCZ

2019-07-28 10:14

administrator   ~0008290

> First of all, we do not need to turn the Tooltips Off. We need a toggle between Show and Hide
 
Yes, I think that's true -- despite the title of this issue and the nomenclature used in previous comments.

 > In my opinion a Tooltip is a Tooltip, so this applies to All Tooltips.
  
I think it's pretty obvious that tool tips are used for different reasons in different parts of each application. If we want to treat them all as one for the scope of this feature, we can do that, though.

We still have the outstanding question in 7715 (repeated in 7786): are there other applications in the suite which already have the option to disable tool tips? In the team calls, the claim was made that there was already such an option. I can't seem to find it. If we can confirm such an option doesn't exist, then we can just code this feature from scratch. If the option already exists, then we should find that option and make the new code look like and behave like the old code.

Once we can answer that question, I think we can start writing code.

PD9FER

2019-07-29 02:14

updater   ~0008292

The only one Tooltip toggle I found are at Logbook in the ALE under Options (see the 1st reply)

K7ZCZ

2019-07-30 18:28

administrator   ~0008306

OK, I think we've got enough information to proceed.

This is a lot of work, spread out across each of the apps. I'm closing this issue and I've opened individual Mantis issues for each application so we can readily track and prioritize the work.

PD9FER

2019-08-08 14:34

updater   ~0008338

We are going to discuss in Support

K7ZCZ

2019-08-09 09:09

administrator   ~0008345

In the team call on 2019-08-08, we had decided to close this issue after discovering that there already was a way to hide the menu bar and tool bar tool tips in Rig Control, and the tool bar tool tips in most other apps. We also though adding this option was too much work for each application (a day or two, each) when there were few requests for the option, and when there seemed to be some misunderstanding in the ticket.

Since then, Ferry decided that the issue warrented more discussion among the support team, so it is now assigned to him pending the outcome of those discussions.

K7ZCZ

2019-08-09 09:20

administrator   ~0008346

Turns out the applications already do have a mechanism to stop the display of some tool tips:

1) Start up Rig Control
2) Connect to a radio -- DemoMatic is fine
3) Right-click in an unoccupied area of the toolbar dock
4) In thee resulting context menu, click "Customize..."
5) This results in a "Customize" dialog. In that property sheet, activate the "Options" property page
6) Mark (or unmark) the "Show ScreenTips on toolbars" box to disable the display of tool tips in the tool bars

A similar option exists for the menu bar:

7) Cancel the "Customize" dialog
8) Right-click in an unoccupied area of the menu bar
9) In thee resulting context menu, click "Customize..."
10) Activate the "Options" tab in the sheet in the "Customize" dialog
11) Use the "Show ScreenTips on toolbars" box to control the display of tool tips.

PD9FER

2019-08-09 16:28

updater   ~0008349

Had conversation with the Team.

Since there only are two Requests for this feature, I recommend to close it as won't fix (yet)
If more requests are getting in, we always can reconsider.

For now, Close with Won't Fix

Issue History

Date Modified Username Field Change
2018-04-06 04:13 PD9FER New Issue
2018-04-06 04:13 PD9FER File Added: image.png
2019-01-04 12:58 K7ZCZ Relationship added has duplicate 0003031
2019-02-01 18:28 K7ZCZ Note Added: 0007210
2019-02-01 18:29 K7ZCZ Assigned To => PD9FER
2019-02-01 18:29 K7ZCZ Status new => feedback
2019-02-01 18:29 K7ZCZ Note Added: 0007211
2019-03-13 15:51 PD9FER Note Added: 0007683
2019-03-17 11:42 K7ZCZ Relationship added has duplicate 0003246
2019-03-21 15:30 PD9FER Note Added: 0007714
2019-03-21 15:32 WA9PIE Assigned To PD9FER => K7ZCZ
2019-03-21 15:33 K7ZCZ Note Added: 0007715
2019-03-21 15:33 K7ZCZ Assigned To K7ZCZ => PD9FER
2019-03-21 15:37 K7ZCZ Relationship added related to 0003256
2019-03-28 16:40 K7ZCZ Note Added: 0007786
2019-07-25 14:40 K7ZCZ Note Added: 0008266
2019-07-25 14:42 PD9FER Note Added: 0008268
2019-07-25 18:49 K7ZCZ Note Added: 0008274
2019-07-26 03:33 PD9FER Note Added: 0008281
2019-07-28 10:14 K7ZCZ Note Added: 0008290
2019-07-29 02:14 PD9FER Note Added: 0008292
2019-07-30 18:24 K7ZCZ Relationship added related to 0003411
2019-07-30 18:24 K7ZCZ Relationship added related to 0003412
2019-07-30 18:25 K7ZCZ Relationship added related to 0003413
2019-07-30 18:26 K7ZCZ Relationship added related to 0003414
2019-07-30 18:26 K7ZCZ Relationship added related to 0003415
2019-07-30 18:27 K7ZCZ Relationship added related to 0003416
2019-07-30 18:28 K7ZCZ Note Added: 0008306
2019-07-30 18:28 K7ZCZ Status feedback => resolved
2019-07-30 18:28 K7ZCZ Resolution open => won't fix
2019-07-30 18:28 K7ZCZ Testing => Not Started
2019-08-08 14:34 PD9FER Note Added: 0008338
2019-08-09 09:09 K7ZCZ Note Added: 0008345
2019-08-09 09:20 K7ZCZ Note Added: 0008346
2019-08-09 16:28 PD9FER Note Added: 0008349
2019-08-21 10:34 K7ZCZ Status resolved => closed
2019-09-14 01:59 WA9PIE Project 1 - Backlog => 5 - Closed w/o Action