View Issue Details

IDProjectCategoryView StatusLast Update
0002668Ham Radio DeluxeMaintenancepublic2018-07-25 20:47
Reporterg3ucq 
Assigned ToK7ZCZ 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.873 
Summary0002668: Opening Logbook ALE with Logbook Tab open
DescriptionOpening an ALE by clicking on a contact in the Logbook does not show the QSO until another tab is clicked.
Steps To ReproduceOpen the Logbook and (double) click on a QSO.
The ALE opens.
Click the Logbook tab.
Close the ALE.
(double) Click on (that) QSO again so that the ALE opens.
The Logbook tab will be selected but no QSOs will be shown.
Click another tab and then the Logbook tab and the QSO/s will be shown.
This is the only tab that does not display what was previously displayed.
Additional InformationIt has probably been like this for many versions.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing Beta Successful

Relationships

related to 0002790 new 3 - Current Dev List Documentation: does not explain use or function of "Logbook" tab in ALE 

Activities

g3ucq

2018-04-09 11:20

viewer   ~0004781

Right click on a cluster spot and select New ALE Window.
Previous QSOs will be shown under the Logbook Tab which does not happen by double clicking on the Logbook.

WA9PIE

2018-06-23 16:58

administrator   ~0005402

I was able to repro this with the steps provided.

To the point G3UCQ is making... there must be a different treatment of how the Logbook tab is refreshed depending on whether you open this from the logbook... or from selecting a spot (with a previously worked call).

K7ZCZ

2018-06-29 17:16

manager   ~0005551

This issue has a couple layers, but it's mainly due to the use of a timer that occasionally (kinda) causes the Logbook tab to update rather than a more deterministic approach, which deliberately updates the tab when the dependency of the tab changes.

K7ZCZ

2018-06-29 17:28

manager   ~0005553

The documentation for the product acknowledges that this tab exists, but doesn't explain what it does or how to use it. I've opened another issue about that.

It's against what I believe in, but because it has historically been hard to get a good description of desired behaviour, I'm going to take a stab at it myself and forge ahead. Here's what I'll implement, unless there are (promptly) some objections:

If the ALE is opened to add a record, the Logbook tab remains empty until the user explicitly does a search.

If the ALE is opened to edit an existing record (by double-clicking in the a logbook view) the Logbook tab will populate with a search on the selected callsign. If the tab is opened with an existing record and the "Next" or "Prev" buttons are used to navigate, the content of the Logbook tab will be refreshed for the newly selected callsign.

These behaviours should occurr if the logbook tab was ivsible or not when the window was opened; or when the Next or Prev buttons were used. Hiding the Logbook tab doesn't change its behaviour. When it is next visited, it should already be in the expected state and hte user doesn't need to refresh or perform another search.

The user can use the search buttons to populate the Logbook tab; these buttons are adjacent to the "Call" and "Locator" edit fields, as well as the "Country" drop-down.

K7ZCZ

2018-07-01 23:30

manager   ~0005591

Fixed in the MikeB2 branch with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4203

K7ZCZ

2018-07-12 14:31

manager   ~0005658

merged to the main branch with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4223

g3ucq

2018-07-13 15:47

viewer   ~0005683

Fixed

PD9FER

2018-07-14 06:52

viewer   ~0005696

Fixed

Issue History

Date Modified Username Field Change
2018-04-09 11:11 g3ucq New Issue
2018-04-09 11:20 g3ucq Note Added: 0004781
2018-06-23 16:58 WA9PIE Steps to Reproduce Updated View Revisions
2018-06-23 16:58 WA9PIE Testing => Not Started
2018-06-23 16:58 WA9PIE Note Added: 0005402
2018-06-23 16:58 WA9PIE Severity tweak => minor
2018-06-23 16:58 WA9PIE Assigned To => K7ZCZ
2018-06-23 16:58 WA9PIE Status new => assigned
2018-06-23 16:58 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-06-29 17:10 K7ZCZ Relationship added related to 0002790
2018-06-29 17:16 K7ZCZ Note Added: 0005551
2018-06-29 17:28 K7ZCZ Note Added: 0005553
2018-07-01 23:30 K7ZCZ Note Added: 0005591
2018-07-12 14:31 K7ZCZ Status assigned => resolved
2018-07-12 14:31 K7ZCZ Resolution open => fixed
2018-07-12 14:31 K7ZCZ Fixed in Version => 6.4.0.864
2018-07-12 14:31 K7ZCZ Note Added: 0005658
2018-07-13 15:47 g3ucq Note Added: 0005683
2018-07-14 06:52 PD9FER Note Added: 0005696
2018-07-17 16:49 WA9PIE Status resolved => closed
2018-07-17 16:49 WA9PIE Testing Not Started => Beta Successful
2018-07-23 22:52 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-07-24 15:36 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2018-07-25 08:00 WA9PIE Fixed in Version 6.4.0.864 => 6.4.0.873
2018-07-25 20:47 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe