View Issue Details

IDProjectCategoryView StatusLast Update
0002669Ham Radio DeluxeBugpublic2018-05-13 15:26
Reporterk2dls 
Assigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0002669: Web browser fix causes default web browser to open on first run after install.
DescriptionThis happened once on the first run after the install of build 799 and then again on the first run after the install of build 803. It looks like the code change that externalizes the web browser causes the default web browser to load unrequested on first run after install.
Steps To ReproduceInstall new HRD version
Run Rig Control
Run Logbook
Run DM780
Default webrowser will open on to the HRD forums home page without any further action by the end user.

Additional InformationAlso confirmed by G3UCQ.
TagsNo tags attached.
ModuleDM780
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

Activities

k2dls

2018-04-09 16:28

viewer   ~0004785

Correction, just not to confuse things. This appeared in 803, not 799 and exists in 806.

K7ZCZ

2018-04-09 19:11

manager   ~0004786

Actually, this always happened on the first run of a new version. It's just that the window opened internally, and was likely hidden.

I've found the code and removed it. Maybe we use this to announce a new version or something some day, but since we don't have such content authored, it's annoying.

K7ZCZ

2018-04-09 19:13

manager   ~0004787

Resolved with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4038

g3ucq

2018-05-04 10:56

viewer   ~0004942

Fixed

Issue History

Date Modified Username Field Change
2018-04-09 14:26 k2dls New Issue
2018-04-09 16:28 k2dls Note Added: 0004785
2018-04-09 19:11 K7ZCZ Note Added: 0004786
2018-04-09 19:13 K7ZCZ Assigned To => K7ZCZ
2018-04-09 19:13 K7ZCZ Status new => resolved
2018-04-09 19:13 K7ZCZ Resolution open => fixed
2018-04-09 19:13 K7ZCZ Module (select) => DM780
2018-04-09 19:13 K7ZCZ Sub-Module (select) => Appearance/UI
2018-04-09 19:13 K7ZCZ Testing => Not Started
2018-04-09 19:13 K7ZCZ Note Added: 0004787
2018-04-12 17:06 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-05-03 20:10 K7ZCZ Fixed in Version => 6.4.0.837
2018-05-04 10:56 g3ucq Note Added: 0004942
2018-05-12 01:10 WA9PIE Status resolved => closed
2018-05-12 01:10 WA9PIE Testing Not Started => Beta Successful
2018-05-13 15:25 WA9PIE Fixed in Version 6.4.0.837 => 6.4.0.840
2018-05-13 15:26 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe