View Issue Details

IDProjectCategoryView StatusLast Update
0002675Ham Radio DeluxeEnhancementpublic2018-05-13 15:26
ReporterKC7FPF 
Assigned ToKC7FPF 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0002675: Control-F" function
DescriptionCould just get the "Control-F" function to copy the frequency correctly from the Frequency window. It only copies the first digital to the clipboard, and has been that way through a number of updates.
TagsNo tags attached.
ModuleRig Control
Sub-ModuleRig Control
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-04-14 23:37

manager   ~0004827

Last edited: 2018-04-15 16:14

View 2 revisions

This bug doesn't offer a clear repro case; if one can be provided, I can try to find a fix.

Here's what I tried:

1) start up logbook
2) Run Rig Control, too, make sure they're connected. Rig Controll was connected to my TS-590SG.
3) Open the "Radio Pane" in Logbook. Click on the "Main" frequency display
4) Press CTRL+F
5) I found that the clipboard was not modified
6) Click on the frequency control in the tool bar, near my station information.
7) Press CTRL+F
8) The clipboard wasn't changed
9) Press "Add" to open the ALE
10) Turn off Tracking of band and mode
11) Click the "<" button next to the frequencyh
12) Click in the Frequency edit control, now populated with "14.074.000"
13) Pres CTRL+F.
14) This puts some XML on the clipboard; it looks like this:

    <?xml version="1.0"?>
    <ADX>
        <HEADER>
            <ADIF_VER>3.0.0</ADIF_VER>
            <PROGRAMID>HAMRADIODELUXE</PROGRAMID>
            <PROGRAMVERSION>Version 6.4.0.806</PROGRAMVERSION>
            <CREATED_TIMESTAMP>20180414 213001</CREATED_TIMESTAMP>
            <USERDEF FIELDID="0" TYPE="S">BIOGRAPHY</USERDEF>
            <USERDEF FIELDID="1" TYPE="S">EQSL_STATUS</USERDEF>
            <USERDEF FIELDID="2" TYPE="S">HEADING</USERDEF>
            <USERDEF FIELDID="3" TYPE="S">LOTW_STATUS</USERDEF>
            <USERDEF FIELDID="4" TYPE="S">NOTES</USERDEF>
            <USERDEF FIELDID="5" TYPE="S">USER_DEFINED_0</USERDEF>
            <USERDEF FIELDID="6" TYPE="S">USER_DEFINED_1</USERDEF>
            <USERDEF FIELDID="7" TYPE="S">USER_DEFINED_2</USERDEF>
            <USERDEF FIELDID="8" TYPE="S">USER_DEFINED_3</USERDEF>
            <USERDEF FIELDID="9" TYPE="S">USER_DEFINED_4</USERDEF>
            <USERDEF FIELDID="10" TYPE="S">USER_DEFINED_5</USERDEF>
            <USERDEF FIELDID="11" TYPE="S">USER_DEFINED_6</USERDEF>
            <USERDEF FIELDID="12" TYPE="S">MY_ANTENNAS</USERDEF>
            <USERDEF FIELDID="13" TYPE="D">USER_DEFINED_9</USERDEF>
            <USERDEF FIELDID="14" TYPE="S">ISMULTIPLIER</USERDEF>
            <USERDEF FIELDID="15" TYPE="S">ROVERLOCATION</USERDEF>
            <USERDEF FIELDID="16" TYPE="S">HRDCOUNTRYNO</USERDEF>
            <USERDEF FIELDID="17" TYPE="S">APP_HAMRADIODELUXE_CREDIT_GRANTED</USERDEF>
            <USERDEF FIELDID="18" TYPE="S">APP_HAMRADIODELUXE_CREDIT_SUBMITTED</USERDEF>
        </HEADER>
        <RECORDS></RECORDS>
    </ADX>


I can't imagine that this is what the bug is about, but I also don't think this is behaviour that anyone expects. Maybe it should be a separate bug.

With what little is in the bug report, I expected at least one of these frequency displays to copy the first digit of the frequency to the clipboard after pressing CTRL+F. But nothing seemed to affect the keyboard.

Please provide complete repro steps:

1) Is it necessary to connect to Rig Control?
2) Which freuqency display window are you referring to?
3) Should tracking be turned on or off?
4) Are you sure you mean CTRL+F and not CTRL+C?
5) Into what application are you trying ot paste the copied frequency when you find that it isn't complete?

With an accurate repro case, I'm happy to investigate the issue. At this poitn, I can't say that I understand what the bug is meant to report.

Thanks for your help!

K7ZCZ

2018-04-15 01:36

manager   ~0004828

I finally figured it out. Tunrs out this issue is describing a problem in Rig Control, where the CTRL+F keystroke is a shortcut for the "Copy Freq" command in the "Edit" menu of the radio view. The problem was that the code was copying a Unicode string into the clipboard, not correctly setting its length, and claiming it to be CF_TEXT instead of CF_UNICODE.

The CTRL+M shortcut (for the "Copy Mode"command) was broken in the same way. I have fixed both.

I've combined the copy-and-pasted implementations into a single function, and that function heeds the _UNICODE preprocessor symbol to decide which clipboard format to use.

K7ZCZ

2018-04-15 01:37

manager   ~0004829

Switching this to Module == Rig Control instead of Module == Logbook.

_PLEASE_ try to write better repro steps and issue descriptions so that I can quickly find problems. It took far less time to fix this issue than it did to sort out what the report was actually describing.

K7ZCZ

2018-04-15 13:13

manager   ~0004833

Fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4057

vk2byi

2018-05-12 19:35

viewer   ~0005025

Selecting Copy Freq and Copy Mode from the Edit menu, or using the Ctrl+F and Ctrl+M accelerators, both result in the current frequency and mode displayed in Rig Control being copied to the clipboard. Fixed.

vk2byi

2018-05-12 19:43

viewer   ~0005027

Retested in 6.4.0.839 with same results. Passed/fixed.

Issue History

Date Modified Username Field Change
2018-04-13 16:36 KC7FPF New Issue
2018-04-14 23:37 K7ZCZ Assigned To => K7ZCZ
2018-04-14 23:37 K7ZCZ Status new => feedback
2018-04-14 23:37 K7ZCZ Note Added: 0004827
2018-04-14 23:37 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-04-14 23:38 K7ZCZ Assigned To K7ZCZ => KC7FPF
2018-04-15 01:36 K7ZCZ Note Added: 0004828
2018-04-15 01:37 K7ZCZ Note Added: 0004829
2018-04-15 01:38 K7ZCZ Module Logbook => Rig Control
2018-04-15 01:38 K7ZCZ Sub-Module (select) => Rig Control
2018-04-15 01:38 K7ZCZ Testing => Not Started
2018-04-15 13:13 K7ZCZ Status feedback => resolved
2018-04-15 13:13 K7ZCZ Resolution open => fixed
2018-04-15 13:13 K7ZCZ Note Added: 0004833
2018-04-15 16:14 K7ZCZ Note Edited: 0004827 View Revisions
2018-05-03 20:10 K7ZCZ Fixed in Version => 6.4.0.837
2018-05-12 19:35 vk2byi Note Added: 0005025
2018-05-12 19:43 vk2byi Note Added: 0005027
2018-05-13 11:51 WA9PIE Status resolved => closed
2018-05-13 11:51 WA9PIE Testing Not Started => Beta Successful
2018-05-13 15:25 WA9PIE Fixed in Version 6.4.0.837 => 6.4.0.840
2018-05-13 15:26 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe