View Issue Details

IDProjectCategoryView StatusLast Update
0002678Ham Radio DeluxeBugpublic2018-05-13 15:26
ReporterPD9FER 
Assigned ToPD9FER 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0002678: Rotator Great Circle display has Black borders and degrees not fully showing
DescriptionThe Great circle map is not displayed right (black borders and bad readout
Steps To ReproduceOpen Rotator
Click Map
Select Great circle
(see screenshot)
Additional InformationTicket #497627
Ticket #289341
TagsNo tags attached.
ModuleRotator
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

Activities

PD9FER

2018-04-16 09:11

viewer  

Rotor.png (556,040 bytes)

K7ZCZ

2018-04-16 11:20

manager   ~0004844

I have a fix coded for the black background. Since the font used to draw the azimuth labels is black, they'll show up as soon as the black background is white (or, grey, really -- matching the background of the rest of the window).

I'm not sure what's specifically meant by "bad readout". Maybe it's just referring to the black-on-black text, but maybe not. Maybe some other label or indicator is incorrect? Please advise about what you expect to see compared to what's in the provided screenshot and I can see about fixing it.

KB3NPH

2018-04-16 11:23

administrator   ~0004845

Mike, maybe the screenshots I just posted will help explain the issue. One shows the mercator map as it should (without the black around it). The other screenshot shows how the same map is showing in V6.4.0.806. It has a black field behind it and the compass points are not showing properly around the world map. This is NOT how it's supposed to be displayed. Hope this helps.

K7ZCZ

2018-04-16 18:03

manager   ~0004846

Tim clarified in chat that the issue is only the background, so I've checked in this change for a fix:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4059

PD9FER

2018-05-04 08:37

viewer   ~0004932

Confirm Fixed in build 837

g3ucq

2018-05-04 10:40

viewer   ~0004937

Also fixed for me in 837

WA9PIE

2018-05-12 01:08

administrator   ~0005005

Closed and waiting on May 2018 release.

Issue History

Date Modified Username Field Change
2018-04-16 09:11 PD9FER New Issue
2018-04-16 09:11 PD9FER File Added: Rotor.png
2018-04-16 11:20 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-04-16 11:20 K7ZCZ Assigned To => PD9FER
2018-04-16 11:20 K7ZCZ Status new => feedback
2018-04-16 11:20 K7ZCZ Note Added: 0004844
2018-04-16 11:23 KB3NPH File Added: Map Mercator Normal Display.jpg
2018-04-16 11:23 KB3NPH File Added: Map Mercator Normal Display (w).jpg
2018-04-16 11:23 KB3NPH Note Added: 0004845
2018-04-16 18:03 K7ZCZ Status feedback => resolved
2018-04-16 18:03 K7ZCZ Resolution open => fixed
2018-04-16 18:03 K7ZCZ Testing => Not Started
2018-04-16 18:03 K7ZCZ Note Added: 0004846
2018-05-03 20:10 K7ZCZ Fixed in Version => 6.4.0.837
2018-05-04 08:37 PD9FER Note Added: 0004932
2018-05-04 10:40 g3ucq Note Added: 0004937
2018-05-12 01:06 WA9PIE Steps to Reproduce Updated View Revisions
2018-05-12 01:06 WA9PIE Additional Information Updated View Revisions
2018-05-12 01:06 WA9PIE Testing Not Started => Beta Successful
2018-05-12 01:08 WA9PIE Note Added: 0005005
2018-05-12 01:08 WA9PIE Status resolved => closed
2018-05-13 15:25 WA9PIE Fixed in Version 6.4.0.837 => 6.4.0.840
2018-05-13 15:26 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe