View Issue Details

IDProjectCategoryView StatusLast Update
0002694Ham Radio DeluxeEnhancementpublic2018-05-13 15:26
ReporterKB3NPH 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0002694: Ticket #419258 - DM-780 Macro Editor will not accept "," in comment lines
DescriptionMike Flowers posted 04/26/2018 1:06 PM
Using DM-780 to write macros, you cannot use commas in the # comments .

The Macro Manager complains that you are using a comma in a CAT command. Not so - you are using it in a comment which should be ignored.
See attached image

TagsNo tags attached.
ModuleDM780
Sub-ModuleMacros
Testing Beta Successful

Relationships

Activities

KB3NPH

2018-04-26 12:32

administrator  

K7ZCZ

2018-05-03 19:35

manager   ~0004927

For now, this is by design. There's a restriction that nothing in the stream contain a comma, so I've just change the error message to describe that fact.

It could be fixed, but I don't think the work to rewrite the serialization, make a migration scheme, test everything; is at all justified. There's a very simple workaround, and with a clear error the limitation is known.

K7ZCZ

2018-05-04 11:51

manager   ~0004946

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4104

error message fixed with this checkin

g3ucq

2018-05-10 15:40

viewer   ~0004988

OK for me

Issue History

Date Modified Username Field Change
2018-04-26 12:32 KB3NPH New Issue
2018-04-26 12:32 KB3NPH File Added: Ticket #419258 - 2018-04-26 13_26_37-macro mgr comma error (1).jpg
2018-05-03 19:35 K7ZCZ Note Added: 0004927
2018-05-04 09:28 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-05-04 11:51 K7ZCZ Assigned To => K7ZCZ
2018-05-04 11:51 K7ZCZ Status new => resolved
2018-05-04 11:51 K7ZCZ Resolution open => fixed
2018-05-04 11:51 K7ZCZ Sub-Module General => Macros
2018-05-04 11:51 K7ZCZ Note Added: 0004946
2018-05-09 23:28 K7ZCZ Fixed in Version => 6.4.0.839
2018-05-10 15:40 g3ucq Note Added: 0004988
2018-05-12 01:19 WA9PIE Status resolved => closed
2018-05-12 01:19 WA9PIE Testing Not Started => Beta Successful
2018-05-13 15:25 WA9PIE Fixed in Version 6.4.0.839 => 6.4.0.840
2018-05-13 15:26 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe